[Q] Fastboot 'FAILED (remote: signature verify fail)

Search This thread

aethel

New member
Jan 20, 2019
3
1
I know this is extreme thread necro, but I didn't see a solution that worked for most people posted, so I thought I would share what worked for me, at least relevant to a phone where the unlock process is carried out via HTCdev.

Basically the problem (for me) appears to be that standard the fastboot.exe in most generic adb packages out there (including the ones I've seen posted on this site) will run produce this error "remote signature verify fail" if you try to use them to unlock your HTC device. For that to succeed, you must use the fastboot.exe downloaded from step 4 of the instructions on HTCdev.

Of course, if you just unzip the folder downloaded from step 4 there, it doesn't contain all the necessary files. for the fastboot command to run. So you also need to copy adb.exe and adbwinapi.dll from the standard package of adb tools (or the SDK install folder from step 1 if you were following the HTCdev instructions) into the folder where you unzip the contents of step 4. Then you can run a command prompt in that folder and (assuming you followed the steps up through 8 and have your unlock.bin in that folder as well), it should sucessfully unlock the bootloader. At least this worked for me.

Hope this helps someone else!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    To unlock the bootloader, you don't need RUU. You should have just used the HTCDev tool.
    I don't know what went wrong, soI can't help you. Try looking for help in Wildfire S forum.