• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Google Play Store Error 497 (Cannot download apps)

Search This thread

Evilv2

Member
Aug 7, 2013
37
21
Hey all,

I've searched the forums (long time lurker). I have a Nexus 4 on PA 3.94 that cannot download apps through the Google Play Store. I downloaded the v.4.3.10 APK and installed, then wiped the app cache - however Error 497 still persists. (NOTE: this worked on a separate Nexus 4 on PA 3.94 that was having the same issue, on the same WiFi network).

I've also tried:
- Factory Wipe
- Clean install of PA 3.94

Any suggestions would be appreciated!

Edit: The working Nexus 4 is now having error 497 again on the same WiFi network indicating the APK download and app cache wipe didn't work.

Edit 2: Currently experiencing intermittent Error 497 while on WiFi (on multiple ISPs). Downloads work more often over Cell Networks (T-mobile for example).

Efforts that DO NOT fix Error 497:
- Updating to Google Play Store 4.3.10
- Clearing Google Play Store and Google Play Services data (and cache).
- Rebooting phone
- Removing Google Play account
- Wiping Cache and Dalvik Cache
- Factory Reset

Edit 3: Issue exists on multiple devices (Nexus 4, Nexus 7, Galaxy Nexus, Galaxy S3, Galaxy S2, GT-I9500) and on multiple JB Versions (4.2.2 and 4.3).

Edit 4: General consensus is to wait this out. Google is aware of the issue and it is likely an issue with Google's servers. Just wait it out by downloading over Network or downloading APKs on your computer/device browser.
 
Last edited:

thunder2132

Senior Member
Mar 11, 2011
622
218
Michigan
Hey all,

I've searched the forums (long time lurker). I have a Nexus 4 on PA 3.94 that cannot download apps through the Google Play Store. I downloaded the v.4.3.10 APK and installed, then wiped the app cache - however Error 497 still persists. (NOTE: this worked on a separate Nexus 4 on PA 3.94 that was having the same issue, on the same WiFi network).

I've also tried:
- Factory Wipe
- Clean install of PA 3.94

Any suggestions would be appreciated!

Edit: The working Nexus 4 is now having error 497 again on the same WiFi network indicating the APK download and app cache wipe didn't work.

Several posts like this have popped up across a couple of different forums. I'm having the same issue. I can download some apps, but others (Google Play Music, TV Guide Mobile, Google Play Services) won't download. I was running stock rooted. I tried installing CM10.1 thinking maybe it was an android 4.3 thing, that also didn't work. I tried doing a full factory reset to both 4.3 and 4.2.2, neither worked. My wife's phone, an Optimus G, works perfectly on the same WiFi network. The downloads work on mobile data, but I've already been throttled for the month (hit my 500MB limit with straight talk as I was troubleshooting the error)

I'm wondering what else is related. Who is your ISP? Mine is Comcast.
 
  • Like
Reactions: Evilv2

Evilv2

Member
Aug 7, 2013
37
21
Several posts like this have popped up across a couple of different forums. I'm having the same issue. I can download some apps, but others (Google Play Music, TV Guide Mobile, Google Play Services) won't download. I was running stock rooted. I tried installing CM10.1 thinking maybe it was an android 4.3 thing, that also didn't work. I tried doing a full factory reset to both 4.3 and 4.2.2, neither worked. My wife's phone, an Optimus G, works perfectly on the same WiFi network. The downloads work on mobile data, but I've already been throttled for the month (hit my 500MB limit with straight talk as I was troubleshooting the error)

I'm wondering what else is related. Who is your ISP? Mine is Comcast.

My ISP is Comcast as well. I don't have network access here (T-Mobile) so I can't test if that would work for me like it has for you. I did see one other thread posted this week with the same issue. Perhaps this will be resolved with the next PA update or the next Google Play Store update.
 

coop3422

Senior Member
Nov 12, 2008
108
3
Calgary, AB
Just started having this issue tonight. My cell provider is bell and isp is telus, I'm in Canada. This is the first time I've tried downloading something since the 4.3 updated, and this phone has always been stock. Maybe it's related to the update?
 

nickshertzer

Senior Member
Dec 13, 2006
1,146
616
www.nickshertzer.com
Same here. Error 497. Comcast ISP. Worked when switching to cellular. I fixed this by going into my router configuration and adding Google DNS (8.8.8.8) as default.

Error has something to do with Comcast dns servers. Hope this helps.
 
  • Like
Reactions: Evilv2

kalkap

New member
Aug 19, 2010
3
0
error 497

Just started having this issue tonight. My cell provider is bell and isp is telus, I'm in Canada. This is the first time I've tried downloading something since the 4.3 updated, and this phone has always been stock. Maybe it's related to the update?

Try changing your DNS. I've read that this has helped write a few people and explains why it often only occurs in certain locations.
 

bcram11

Member
Nov 21, 2009
9
1
I seemed to have the same issue. I was hitting the update all button on top of the screen and specifically Google Play Books and just recently FB Messenger failed to update. I then went into each app individually and used the update button to update. This method worked for me. Both apps are now installed without issues.

Nexus 4, stock, unrooted, T-Mobile
 

iggie94

Senior Member
Sep 19, 2012
106
5
Chicago
Same here. Error 497. Comcast ISP. Worked when switching to cellular. I fixed this by going into my router configuration and adding Google DNS (8.8.8.8) as default.

Error has something to do with Comcast dns servers. Hope this helps.

This seems to have worked for me.

---------- Post added at 09:53 PM ---------- Previous post was at 09:40 PM ----------

Never mind. I still can't download certain apps. Is there anyway to fix this?

Edit: I fixed both DNS with 8.8.8.8 and that seemed to fix my issue. I downloaded all my apps.
 
Last edited:

Evilv2

Member
Aug 7, 2013
37
21
Ituryl SALT

Same here. Error 497. Comcast ISP. Worked when switching to cellular. I fixed this by going into my router configuration and adding Google DNS (8.8.8.8) as default.

Error has something to do with Comcast dns servers. Hope this helps.

I'll try the DNS out. Thanks.

Note: The Error 497 has been occurring intermittently now while on Comcast.
 

yaggermr

Senior Member
Jan 2, 2011
103
44
I have switched my dns setting twice still no luck half the apps get the 497 error. I'm on Comcast Michigan Nexus 4.
 
Last edited:
Sep 19, 2010
10
0
Same problem with 497 and "package file is not valid" on wifi

I am having the same problem with my nexus 4. Its definitely not the 4.3 update because mine was working fine when I got that update. It has to be google servers and your ISP (I am on Suddenlink in Arkansas). I tried force stopping/data/cache wiping google play/frameworks....that yielded no success. The only thing that remotely worked was changing my DNS in my router to 8.8.8.8/8.8.8.4.4. That works on some apps, but others give me the "Package is not valid" error. Still others make it to a certain percentage of download, then just freeze. The download arrow in the notification bar even disappears when this happens.

However, my mobile data works perfectly every time! I can tether to my nexus 7 and that works fine too. Its just the wifi that is messed up. Oh and I initially thought it might be my router so I switched back to my old one and that didn't work either.

My conclusion: everything worked fine on wifi until the new google play update a few days back (4.3.10). I manually pushed that to my phone and tablet and ever since this has happened. Even after uninstalling the update (rolling google play back to 4.2.3) it is still messed up. It seems the problem is Google/ISP server issues. Glad my cell data works though!

Oh and you can even use your wifi in your phone/tablet and go to the web version of the play store and download/update just fine....very strange. I hope google fixes this soon! I love my nexus 4 and 7 and hate how I am restricted like this.
 

luma

Member
May 28, 2006
40
5
I'm having the same problem with a new N7. Also using Comcast in MI. Factory wipe the tablet, enter in my Google account, and core apps like Chrome and Play Music refuse to update, package file invalid. I've been troubleshooting this for hours until I ran into this thread. Switched over to using my phone in tether mode and my tablet updates right away. Comcast is doing something that is breaking Google Play.

More details: changing DNS to 8.8.8.8 doesn't seem to help. Updates and installs for certain apps will fail like clockwork over Comcast, work fine over Sprint, every time.
 
Last edited:

yaggermr

Senior Member
Jan 2, 2011
103
44
Hideman vpn let me run updates that didn't run on my comcast wifi. Dns setting did not help. Something odd is going on. I've gone back 4.2 and that doesn't fix my issues. I also did upgrade to the latest play store a day or two ago. It some might be some weird authentication error. I get 497 errors and the invald file error. Behind the vpn things run fine. Its driving me nucking futs. I've wiped, tried custom Roms downgraded and tried multiple DNS severs.
Invalid file Hideman vpn thread kind of helped me even though I don't want to use a VPN every time I have app download or upgrade on the play store.
http://forum.xda-developers.com/showthread.php?t=2191125

Sent from my Nexus 4 using xda premium
 

adam73647

Member
Oct 15, 2008
38
0
I am getting this error, as well as the package is invalid. Getting this on both Mediacom wifi as well as my carrier. ATT here.
 

AndroidBoi1

New member
Aug 8, 2013
1
1
Google Play and Wi-Fi Issues

I was getting the same issue from three different Wi-Fi networks. I was at home, work and Starbucks and still was receiving error 497 or package invalid issues. Tried over cellular data and it worked. Wondering if the Google Play store is having issues with Wi-Fi networks. Try installing updates NOT using Wi-Fi.

Using AT&T Samsung Galaxy S4 and Nexus 7 (2013)
 
  • Like
Reactions: KaiTzer

adam73647

Member
Oct 15, 2008
38
0
I was getting the same issue from three different Wi-Fi networks. I was at home, work and Starbucks and still was receiving error 497 or package invalid issues. Tried over cellular data and it worked. Wondering if the Google Play store is having issues with Wi-Fi networks. Try installing updates NOT using Wi-Fi.

Using AT&T Samsung Galaxy S4 and Nexus 7 (2013)

I've tried both ways, both ways errors.
 

stone1269

Member
Aug 8, 2013
9
4
I have been having this exact issue for two days on Frontier DSL and a 2013 Nexus 7. I have tried 3 different routers, changing DNS settings, etc. and nothing has worked. If I reset the router, however, and immediately try a problem download, it will usually work. If I wait too long, I will get the 497 or package file errors....

Like others, it will work perfectly every time if I am connected to a cellular hotspot.
 
  • Like
Reactions: KaiTzer

Melarsa

Member
Aug 18, 2010
49
8
Just chiming in to say I've been having this same issue both last night and tonight. Some apps will download or update, and some won't. The ones that won't give me error 497 or say package file invalid. This is true on my new 2013 Nexus 7, the old 2012 Nexus 7, and Galaxy Nexus when using wifi. Everything was working peachy on all three devices until last night.

When using cell data either on the phone or as a mobile hotspot for the tablets the apps will download again, but as soon as I switch back to wifi I start getting errors. I've tried clearing the cache & data and force closing the Play Store & Google's Framework Services, deleting the apps and trying to redownload them, rebooting the devices, restoring past Titanium Backups of the Play Store, etc. But so far the only way to download or update apps since last night is to use cell data.

The new Nexus 7 has Play Store v4.3.10 The old Nexus 7 is running 4.2.3. I can't check the version on the Galaxy Nexus right now. But all three are having the same problem so I don't think it's version specific. The two Nexuses are running stock 4.3 and the Galaxy Nexus is running a custom 4.2.2 Rom, so it isn't Android version specific, either. All are rooted & unlocked, if that matters.

For what it's worth I also have a Comcast router, but it was working fine with Play Store updates until last night. I have the feeling this is something on Google's end. No idea what's happening, but I hope it gets resolved soon.
 

Noiseboy1176

Member
Jul 23, 2013
20
16
Sydney
Google Pixel 6 Pro
Same issue here too. On both wifi and mobile data though. I tried changing my DNS to Google, wiped cache and dalvik, tried pushing the update from play store on desktop. Always the same 497 error. :/

Sent from my Nexus 4 using Tapatalk 4
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey all,

    I've searched the forums (long time lurker). I have a Nexus 4 on PA 3.94 that cannot download apps through the Google Play Store. I downloaded the v.4.3.10 APK and installed, then wiped the app cache - however Error 497 still persists. (NOTE: this worked on a separate Nexus 4 on PA 3.94 that was having the same issue, on the same WiFi network).

    I've also tried:
    - Factory Wipe
    - Clean install of PA 3.94

    Any suggestions would be appreciated!

    Edit: The working Nexus 4 is now having error 497 again on the same WiFi network indicating the APK download and app cache wipe didn't work.

    Several posts like this have popped up across a couple of different forums. I'm having the same issue. I can download some apps, but others (Google Play Music, TV Guide Mobile, Google Play Services) won't download. I was running stock rooted. I tried installing CM10.1 thinking maybe it was an android 4.3 thing, that also didn't work. I tried doing a full factory reset to both 4.3 and 4.2.2, neither worked. My wife's phone, an Optimus G, works perfectly on the same WiFi network. The downloads work on mobile data, but I've already been throttled for the month (hit my 500MB limit with straight talk as I was troubleshooting the error)

    I'm wondering what else is related. Who is your ISP? Mine is Comcast.
    1
    Same here. Error 497. Comcast ISP. Worked when switching to cellular. I fixed this by going into my router configuration and adding Google DNS (8.8.8.8) as default.

    Error has something to do with Comcast dns servers. Hope this helps.
    1
    Google Play and Wi-Fi Issues

    I was getting the same issue from three different Wi-Fi networks. I was at home, work and Starbucks and still was receiving error 497 or package invalid issues. Tried over cellular data and it worked. Wondering if the Google Play store is having issues with Wi-Fi networks. Try installing updates NOT using Wi-Fi.

    Using AT&T Samsung Galaxy S4 and Nexus 7 (2013)
    1
    I have been having this exact issue for two days on Frontier DSL and a 2013 Nexus 7. I have tried 3 different routers, changing DNS settings, etc. and nothing has worked. If I reset the router, however, and immediately try a problem download, it will usually work. If I wait too long, I will get the 497 or package file errors....

    Like others, it will work perfectly every time if I am connected to a cellular hotspot.
    1
    Having the same error here too. Cannot update both the Instagram and Chrome Beta app :rolleyes: