[Q][GSI][A/AB][arm64] Android Q Developer Preview

Search This thread


Senior Member
Oct 19, 2014

Thanks to you & simonsmh - I was able to boot Android R Developer preview (Pixel-AB-R-20200222-ErfanGSI.img-0514) on my OP3. No Wi-Fi or Mobile connection. To be expected from the first DP.



  • Screenshot_20200213-034351.png
    115.5 KB · Views: 809
  • Screenshot_20200213-034415.png
    115 KB · Views: 806
  • Screenshot_20200213-034440.png
    112.7 KB · Views: 797
  • Screenshot_20200213-034849.png
    155.9 KB · Views: 743
  • Screenshot_20200213-035021.jpg
    127 KB · Views: 738
  • Screenshot_20200213-040038.png
    137.1 KB · Views: 732
  • Screenshot_20200213-040054.png
    161.7 KB · Views: 719
  • Screenshot_20200213-040113.png
    119.5 KB · Views: 688
  • Screenshot_20200213-040119.png
    126.6 KB · Views: 669
  • Screenshot_20200213-040210.png
    113.3 KB · Views: 667
Last edited:
  • Like
Reactions: allrightlite


Mar 29, 2017
I flash 3 gsi img but without luck to boot it on realme 2 rmx1809...it either stuck on boot logo or just dosent boot...any tips or guide


Sep 13, 2016
i tried many gsi on realme 3 pro rmx 1851
fingerprint works on first boot but after reboot fp dont work
i can still enroll more fingerprints but cant use them to open device

---------- Post added at 02:01 PM ---------- Previous post was at 02:01 PM ----------

i tried many gsi on realme 3 pro rmx 1851
fingerprint works on first boot but after reboot fp dont work
i can still enroll more fingerprints but cant use them to open device


Senior Member
Aug 8, 2012
it seems that i can't install some kind of apps , is that a storage problem ?? my device pixel 3a


Senior Member
Aug 8, 2012
How did you flash it ??
Did your device get the official beta ?
Because I tried to flash latest 11 GSI on my phone's Q's boot and vendor. It didn't boot.
Can you tell me how did you do it ??

install Q july patch , then :

fastboot erase system

fastboot flash system Generic-erfan.img

fastboot -w

fastboot reboot
  • Like
Reactions: Liftedcorn

Top Liked Posts

  • There are no posts matching your filters.
  • 260

     * Your warranty is now void.
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
    Android "Q" is the upcoming ninth major version of the Android operating system. It was first announced by Google on March 2019, and the first developer preview was released on the same day. The second developer preview is expected to be released at the next Google I/O developer conference.

    [more stable] Pixel: Ported from Pixel 2 firmware (walleye)
    Generic: Ported from Google GSI with gapps

    GET UPDATES FROM: https://t.me/androidqgsi

    Requirements :
    • Treblized device with 8.1 or P vendor

    Global Bugs :
    • VoLTE

    Device specific Bugs :
    • ...

    Instructions :
    for A-Only :

    for AB :

    Downloads :

    Notes :
    Fix gapps: install google play services with "adb install"
    if images didn't worked properly post your logs(logcat and console-ramoops) on telegram group i'll come for help : @androidqgsi
    Logcat without PC: take /data/local/tmp/logs/log
    Enable adb before boot using this command in TWRP:
    Linux/mac :
    adb push ~/.android/adbkey.pub /data/misc/adb/adb_keys
    Win :
    adb push C:\Users\<userName>\.android\adbkey.pub /data/misc/adb/adb_keys

    My paypal: https://www.paypal.me/erfanoabdi

    Tested on:
    give me logs if didn't worked, or donate me a device :)
    Tested by myself:
    1. Moto Z (A-only)
    2. Moto X4 (AB)

    [DEV-ONLY] Bug Fixing

    NVM :D

    Ah actually this is ridiculous to have bug fixing post here, and i hate my port, real P GSI shouldn't done like this. but anyway this is ported from closed source P and i can point in most popular fixable bugs here...

    by looking into logs(adb logcat -b all) if we see :
    1) library "libxxxxxxxxx.so" not found
    fix of this error is very simple as you guys all know we just need to put needed lib from system image of base rom in https://github.com/erfanoabdi/P_sem...GSI_Patches/Vendor/P Blobs/POST-sGSI_1/vendor
    and zip up "POST sGSI 1" with new libs

    Feel free to make pull request new libs in github

    2) cannot locate symbol :
    for example LG RIL error was like this:
    CANNOT LINK EXECUTABLE "/vendor/bin/hw/rild": cannot locate symbol "_ZN7android8hardware5radio4V1_08toStringENS2_22CdmaSmsWriteArgsStatusE" referenced by "/vendor/lib64/[email protected]"...
    a) here we need to find where is unknown symbol located in 8.1 system image
    so in terminal goto system/ and :
    grep -r "_ZN7android8hardware5radio4V1_08toStringENS2_22CdmaSmsWriteArgsStatusE"
    output in this case is :
    Binary file lib/[email protected] matches
    Binary file lib64/[email protected] matches
    (here you may get long list of blobs, only find and grab needed ones)
    b) now just copy libs to vendor and rename them
    in this case i renamed [email protected] to [email protected]
    ***important rule keep string name same as original file only replace one letter (a->W)***
    c) and sed renamed lib (in my case) :
    sed -i "s/[email protected]/[email protected]/" "P_semiGSI/POST_sGSI_Patches/Vendor/P\ Blobs/POST-sGSI_1/vendor/lib/[email protected]"
    sed -i "s/[email protected]/[email protected]/" "P_semiGSI/POST_sGSI_Patches/Vendor/P\ Blobs/POST-sGSI_1/vendor/lib64/[email protected]"
    we're almost done here
    d) now open POST-sGSI_2 and sed "referenced by" lib from error line in log
    like this : https://github.com/erfanoabdi/P_sem...ETA-INF/com/google/android/update-binary#L154
    e) and zip up "POST sGSI 1/2" with new libs

    Feel free to make pull request new libs/hax in github

    3) more...
    Update for DP5


    Wiki page: https://github.com/erfanoabdi/P_semiGSI/wiki/OnePlus-5T and https://github.com/erfanoabdi/P_semiGSI/wiki/OnePlus-5 (Thanks to timocapa)

    OnePlus 5/5T users, you MUST be decrypted in order to boot this GSI. This means flashing the noverity zip and formatting data. The link to the zip which I used to get it working is here: https://drive.google.com/file/d/1BtZKnNc2ooe9lcDd0JJ8eHzylA0StSm2/view The recovery I am using is the latest codeworkx recovery here: https://sourceforge.net/projects/ch....1-0-20180414-codeworkx-dumpling.img/download for dumpling and https://sourceforge.net/projects/ch...-20180414-codeworkx-cheeseburger.img/download for cheeseburger.

    Some things to take into consideration before I followed these steps: I was using OB11 as my daily driver since it's release and I have always been encrypted.

    This is exactly how I managed to get it booting on my 5T:
    1) format data to remove encryption (I'm on OOS OB11 before doing this)
    2) reboot recovery
    3) factory reset
    4) flash Mokee ROM (latest nightly)
    5) flash noverity zip
    6) reboot into OS
    7) get past set up and reboot into TWRP
    8) factory reset
    9) install P GSI
    10) mount vendor
    11) install all the latest POST zips in the order of 1 to 3
    12) reboot into OS

    OPTIONAL: After you have booted into Android P and the lockscreen shows. You can reboot back into TWRP and install the latest BETA version of Mqgisk

    Alternative instructions if you are getting kicked back into the recovery with the display log saying "RescueParty", do all of the above but replace step 11 with the steps below (Thanks to @jelousdogs for his method):
    11) Flash POST Zip 1,2 (Dont flash zip 3 Yet)
    12) Reboot to system (You will see the rom booting and reboot to recovery suddenly)
    13) Flash POST zip 3 in recovery and reboot to system

    If this STILL does not work, try this: After completing all of these steps, mount vendor partition in TWRP, then use the TWRP File Manager. Copy the build.prop file from the vendor partition to your internal storage (/sdcard) and move it to your PC via MTP in recovery. Add "persist.sys.disable_rescue=true" (without quotes) to the bottom of the build.prop file you have just copied to your PC. Save and transfer it back to your internal storage. Copy the build.prop from your internal storage to /vendor, replacing the original file. Press on the build.prop file in your /vendor partition and press "chmod". Remove all of the "0000" numbers in the text box and type "0600", then confirm the chmod. Reboot to the OS.

    DIRTY FLASHING DP5 FROM DP4 (Thanks to timocapa):
    1) reboot into TWRP and flash the DP5 GSI.
    2) reboot into the OS.
    Simple as that.

    - If you get kicked into recovery after trying to boot the GSI, look at TWRP's display log where flashable zip text are printed out and see if "init_user0_failed". This means you are encrypted and the GSI is having trouble with it. You must be decrypted as said above.
    - Yes, this includes the new gesture pill nav bar. SETTINGS > SYSTEM > GESTURES > SWIPE UP ON HOME BUTTON (Your stock launcher must be working, i.e. not Force Closing, in order for this to work because the new overview app switcher is part of the stock Pixel Launcher).
    - Weird software issues like apps not opening, random FCs, settings going blank? Try a factory reset in TWRP and reboot to see if it has fixed any problems!
    Known bugs confirmed by a number of 5/t users:
    - Potato quality camera, you can use GCam to remedy the problem but expect blue dots in HDRmode (OnePlus problem)
    - Front facing camera can only be used in OOS camera (wait for official sources)

    To get rid of the three persistent notifications:
    1) install GMS update (https://www.apkmirror.com/apk/googl...2-8-72-100400-202717283-android-apk-download/)
    2) Tap on the blue finishing setup notification and connect to wifi, then force close the pixel setup so it re-appears again
    3) Go to settings > accounts > sign into google
    4) Tap on the blue notification again and you should be able to go further than "pixel is finishing setup" page.
    5) Force stop play store to remove the play store persistent notification

    Hope this helps other OP5/5T users out there who are having trouble booting this.
    DP5 is out : https://androidfilehost.com/?w=files&flid=279589
    dirty flash from dp4 :
    - only flash system.img

    *but clean flash is always recommended*

    change log of new zips:
    * op5t fingerprint fix