• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] Having issues compiling my first CM kernel build.

Search This thread

azraelpwnz

Member
Sep 16, 2013
5
1
Hello all!

I have recently started to get my system ready for some android software and kernel programming. I am following the guide from the cyanogenmod website. I am unable to post an exact link due to my low post count, apologies. If you really need to see which guide I am using, message me and ill get it to you.


I am stuck on the last step of "Configure the Build."

When I send "make ARCH=arm CROSS_COMPILE=$CCOMPILER oldconfig" to terminal, the following is my output.


Code:
[email protected]:~/android/system# make ARCH=arm CROSS_COMPILE=$CCOMPILER oldconfig
/bin/bash: bison: command not found
============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=4.1.2
TARGET_PRODUCT=full
TARGET_BUILD_VARIANT=eng
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a
HOST_ARCH=x86
HOST_OS=linux
HOST_OS_EXTRA=Linux-3.8.0-19-generic-x86_64-with-Ubuntu-13.04-raring
HOST_BUILD_TYPE=release
BUILD_ID=JZO54K
OUT_DIR=/root/android/system/out
============================================
grep: build/target/board/generic/recovery.fstab: No such file or directory
find: `src': No such file or directory
build/core/tasks/kernel.mk:82: **********************************************************
build/core/tasks/kernel.mk:83: * Kernel source found, but no configuration was defined  *
build/core/tasks/kernel.mk:84: * Please add the TARGET_KERNEL_CONFIG variable to your   *
build/core/tasks/kernel.mk:85: * BoardConfig.mk file                                    *
build/core/tasks/kernel.mk:86: **********************************************************
make: *** No rule to make target `oldconfig'.  Stop.
[email protected]:~/android/system#

I am unable to locate BoardConfig.mk for an unknown reason. Also, I dont know why the GREP returned no such file or directory, and why src wasnt found either.

Please help, I am almost completely set up to start helping the community!

Thanks,

Azraelpwnz