• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] High wakelock count and battery drain (New Google play service).

Search This thread

Isebox

Member
Aug 20, 2011
12
1
Poland
Hey.

Few days ago, i have updated the google play services to 6.1 version.
After that a new kind of wild wakelock appeared. No idea why. I can't find anything about that one.

This wakelock is called : "wake:com.google.android.gms/.auth.be.proximity.authorization.userpresence.UserPresenceService"
And it's growing all the time, and it happened only after the update. I've lost after i unplugged (80%) ~20% in about 1hr with screen off.

I'm using Archidroid 1 (Newest one) on latest beta of boeffla kernel. And apart from that was everything fine.
Tried to clean Google play services cache and data. No results.


Screens below.


 
Last edited:
  • Like
Reactions: SXUsr

haha01haha01

Member
Jan 15, 2012
19
7
Same thing happened to me today on Nexus 4 with CM11M10

EDIT: I think it is related to WearableService under Google Services, I killed it and the situation has significantly improved. Try doing it on your device and see if it helps.
 
Last edited:
  • Like
Reactions: ercxar

malachow

Senior Member
May 14, 2013
2,577
3,568
Hey.

Few days ago, i have updated the google play services to 6.1 version.
After that a new kind of wild wakelock appeared. No idea why. I can't find anything about that one.

This wakelock is called : "wake:com.google.android.gms/.auth.be.proximity.authorization.userpresence.UserPresenceService"
And it's growing all the time, and it happened only after the update. I've lost after i unplugged (80%) ~20% in about 1hr with screen off.

I'm using Archidroid 1 (Newest one) on latest beta of boeffla kernel. And apart from that was everything fine.
Tried to clean Google play services cache and data. No results.


Screens below.


I probably managed to get rid of the same wakelock.

#1 install Disable Services app from Google Play
#2 open it, go to "system" tab
#3 find Google Play Services, open, find "Wearable Services" & untick it
#4 et voila, ready :)
 

ANDydeROID

New member
Sep 24, 2014
3
20
I probably managed to get rid of the same wakelock.

#1 install Disable Services app from Google Play
#2 open it, go to "system" tab
#3 find Google Play Services, open, find "Wearable Services" & untick it
#4 et voila, ready :)

I also had this problem. I additonally disabled the following services in Google Play Sevices:

"com.google.android.gms.auth.be.proximity.authorization.userpresence.UserPresenceService"
"com.google.android.gmx.config.ConfigFetchService"

and all other services with the word "fitness" or "wearable" (as my former poster already said)

Hope I could also help ;)
 

Vahooli

Senior Member
May 16, 2011
430
50
i have this problem and i cant solve it with disable all fitness and wearable services! **** google play services always has a problem !
 

ANDydeROID

New member
Sep 24, 2014
3
20
i have this problem and i cant solve it with disable all fitness and wearable services! **** google play services always has a problem !

Edit: I have seen you use the Galaxy S2 (GT-9100) ... This could be something different from the S3 (GT-9300)
Is there no other thread available that deals this problem with your phone?

Can you say someting about your phone?

Do you really have a Galaxy S GT-9300?
Which Version is your Google Play Service?
Which Version of Android do you use?
Do you use a custom rom?
What is listed at top of the 'Google Play Serices' in WLD? Is it still the same like that posted by the thread starter?

Best wishes
 
Last edited:

butchieboy

Senior Member
Feb 15, 2012
8,959
5,016
springfield.il
I probably managed to get rid of the same wakelock.

#1 install Disable Services app from Google Play
#2 open it, go to "system" tab
#3 find Google Play Services, open, find "Wearable Services" & untick it
#4 et voila, ready :)
Thanks for info..did what you suggested wakelock went from 9% down to 1%. I also unchecked Nlp and location history havent had any wierd things happen to my device[emoji106]

FirekatV8/FireGearXXX
 
  • Like
Reactions: kage00

Tuxedo75

Senior Member
Jan 4, 2013
436
28
I tried but no real improvements unfortunately on my Xperia SP (modded stock 4.3), now reverted to stock play services and battery drain disappeared but nothing works... :(
 

Tuxedo75

Senior Member
Jan 4, 2013
436
28
Update...
I noticed that the battery drain was really greater if the signal quality was bad...
So if I've good signal quality I haven't same drain than if with bad signal...and there was a BIG difference...

It's normal?

Simone"Tuxedo"Monsignori
 

bigwig22

New member
Oct 11, 2014
1
1
Xposed framework

Hi there,

i've had the very same problem for a cpl weeks and finally found what worked for me :

I had an Xposed module named 'Disable Google Network Location Consent'.

I just had to disable and uninstall the module (click and hold onto it in the module section of xposed).

Reboot.

et voila!!

Big thanks to my friend AoEKiller here on XDA and in RL for the help on that!
 
Last edited:
  • Like
Reactions: PlayersHeaders

shelter

Member
Jun 6, 2009
41
5
Seems to work for me, this has been bugging me for a while.
But I don't like disabling stuff I don't know what they do. What are the fitness and wearable services?

EDIT:
Thought it worked, it didn't... I will have to monitor WLD to see what casues the wakelocks on my phone. I CAN get rid of it but as soon as I start to install apps it comes back. :(
 
Last edited:

agusaon

Senior Member
Nov 20, 2013
66
9
It seems like nobody else is getting this error. I'm from the moto g 4g forums and I haven't found anyone else with this wakelock. From now, I'm using disable services app, but I thought that with the new play services update it should be fine. Guess I was wrong
 

Tuxedo75

Senior Member
Jan 4, 2013
436
28
Seems that I've partially solved the issue disabling the service:

UserPresenceService

After disabling that service wakelocks.was really solved...
 

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    I probably managed to get rid of the same wakelock.

    #1 install Disable Services app from Google Play
    #2 open it, go to "system" tab
    #3 find Google Play Services, open, find "Wearable Services" & untick it
    #4 et voila, ready :)

    I also had this problem. I additonally disabled the following services in Google Play Sevices:

    "com.google.android.gms.auth.be.proximity.authorization.userpresence.UserPresenceService"
    "com.google.android.gmx.config.ConfigFetchService"

    and all other services with the word "fitness" or "wearable" (as my former poster already said)

    Hope I could also help ;)
    14
    Hey.

    Few days ago, i have updated the google play services to 6.1 version.
    After that a new kind of wild wakelock appeared. No idea why. I can't find anything about that one.

    This wakelock is called : "wake:com.google.android.gms/.auth.be.proximity.authorization.userpresence.UserPresenceService"
    And it's growing all the time, and it happened only after the update. I've lost after i unplugged (80%) ~20% in about 1hr with screen off.

    I'm using Archidroid 1 (Newest one) on latest beta of boeffla kernel. And apart from that was everything fine.
    Tried to clean Google play services cache and data. No results.


    Screens below.


    I probably managed to get rid of the same wakelock.

    #1 install Disable Services app from Google Play
    #2 open it, go to "system" tab
    #3 find Google Play Services, open, find "Wearable Services" & untick it
    #4 et voila, ready :)
    1
    Hey.

    Few days ago, i have updated the google play services to 6.1 version.
    After that a new kind of wild wakelock appeared. No idea why. I can't find anything about that one.

    This wakelock is called : "wake:com.google.android.gms/.auth.be.proximity.authorization.userpresence.UserPresenceService"
    And it's growing all the time, and it happened only after the update. I've lost after i unplugged (80%) ~20% in about 1hr with screen off.

    I'm using Archidroid 1 (Newest one) on latest beta of boeffla kernel. And apart from that was everything fine.
    Tried to clean Google play services cache and data. No results.


    Screens below.


    1
    Same thing happened to me today on Nexus 4 with CM11M10

    EDIT: I think it is related to WearableService under Google Services, I killed it and the situation has significantly improved. Try doing it on your device and see if it helps.
    1
    I probably managed to get rid of the same wakelock.

    #1 install Disable Services app from Google Play
    #2 open it, go to "system" tab
    #3 find Google Play Services, open, find "Wearable Services" & untick it
    #4 et voila, ready :)
    Thanks for info..did what you suggested wakelock went from 9% down to 1%. I also unchecked Nlp and location history havent had any wierd things happen to my device[emoji106]

    FirekatV8/FireGearXXX