[Q] How To Add Root How A Custom Rom?

Search This thread

Shaheer

Senior Member
May 22, 2013
634
483
Richmond
Hello Everyone,

I'm ik4evr. (Making the SM-T520 rom) =)

Anyway, i'm trying to add root to my custom rom. However, every time I do it using the kitchen, and flash the rom and try to open SuperSU it says binary not installed. I tried manually putting the root files in my room too. Can anyone out there help me with this. Thanks!
 

THEDEVIOUS1

Senior Member
Nov 26, 2009
808
928
Hello Everyone,

I'm ik4evr. (Making the SM-T520 rom) =)

Anyway, i'm trying to add root to my custom rom. However, every time I do it using the kitchen, and flash the rom and try to open SuperSU it says binary not installed. I tried manually putting the root files in my room too. Can anyone out there help me with this. Thanks!

welcome to my world...it took me about a week of research before i found anything that helped & dont even remember where i read it at now. Long story short....there seems to be an issue with the binaries that the kitchen uses so in the end i finally just copied the su/busybox/init.d files from cleanrom for the T320 & havent had a problem since
 

Shaheer

Senior Member
May 22, 2013
634
483
Richmond
welcome to my world...it took me about a week of research before i found anything that helped & dont even remember where i read it at now. Long story short....there seems to be an issue with the binaries that the kitchen uses so in the end i finally just copied the su/busybox/init.d files from cleanrom for the T320 & havent had a problem since

Thanks for the reply. Unfortunately, that didn't work still =(
Anything else?
 
  • Like
Reactions: spton

THEDEVIOUS1

Senior Member
Nov 26, 2009
808
928
Thanks for the reply. Unfortunately, that didn't work still =(
Anything else?

If that didnt work then it might be your updater-script...once again just copy the one from a known working deice with an exynos cpu & 4.4.2 (N9000 MAYBE?) then u should be ok. Also...did u swap the daemonsu file in xbin as well? Another thing...delete the su located in "bin" & make sure its in "xbin". The last thing i can think of...did u unpack the boot.img & change the value in the dfault.prop to make it non-secure?

edit: I was just thinking...i noticed u said "supersu" but every guide ive seen added "superuser" instead so swap that too. U should be able to include either but mine didnt work either until i switched them although it could have been coincidence since i also made all of the rest of the alterations around the same time...if u notice in my thread i told users to go download supersu AFTER they flash just to be safe but now that i have it working i'll probably try changing apps again for the next version to eliminate a step
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    welcome to my world...it took me about a week of research before i found anything that helped & dont even remember where i read it at now. Long story short....there seems to be an issue with the binaries that the kitchen uses so in the end i finally just copied the su/busybox/init.d files from cleanrom for the T320 & havent had a problem since

    Thanks for the reply. Unfortunately, that didn't work still =(
    Anything else?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone