• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] How to disable the HOME button ?

Search This thread

prallo

Senior Member
Aug 8, 2013
279
64
How to disable the HOME button in the Galaxy S6 ?
Don´want my phone to wake up everytime it is in my trousers.
Is there an apk file for it ?

Thanks !
 
Last edited:

schoolsux

Senior Member
May 7, 2010
711
1,533
Gotham City
lunsarn.se
Not off topic at all, actually. My question is very legitimate and I am actually interested to hear your answer.

Well, depending on the trousers I wear, I have found this to be annoying as well. Tight pockets often click the home button by accident and wake up my phone, then it sometimes also manages to unlock the screen and start all kinds of apps, call someone or whatever. They could use the proximity sensor to detect phone is in a pocket, but they didn't... :(
 

Japultra

Senior Member
Oct 21, 2010
720
170
Los Angeles
Well, depending on the trousers I wear, I have found this to be annoying as well. Tight pockets often click the home button by accident and wake up my phone, then it sometimes also manages to unlock the screen and start all kinds of apps, call someone or whatever. They could use the proximity sensor to detect phone is in a pocket, but they didn't... :(

You don't have the fingerprint security on? Have you tried repositioning the phone? Maybe the home button against your body as opposed to against the pocket? Or phone top down vs bottom up, etc? My pants are usually pretty tight as well but I've never noticed this issue myself (not to say that it doesn't happen, just that I've never noticed it).
 

Thoth33

Senior Member
Jun 2, 2015
157
72
Since everyone ignored your question the answer is as follows.

Open generic.kl in root explorer (device/system/usr/keylayout)

Find the line "Key 172 HOME" and commet it out by editing it to "# Key 172 HOME"
If you just want to disable home button wake, i have a workaround here:
http://forum.xda-developers.com/galaxy-s6/help/guide-how-to-disable-home-button-wake-s6-t3128348

To everyone else, whats the point of being a smart ass about his question? if you dont know the fix dont post. Dont pick apart his motives for litterally no reason. Android is about CHOICE.
 

godutch

Senior Member
Jun 29, 2009
2,558
374
www.burgerforumeu.nl
To everyone else, whats the point of being a smart ass about his question? if you dont know the fix dont post. Dont pick apart his motives for litterally no reason. Android is about CHOICE.

I have found that many times people ask for a solution to weird problem X but if you ask a bit more problem X is a workaround for problem Y which they figured they couldn't solve, so it's better to try to solve problem Y. That way you really help them.
 

cjshelby78

New member
Dec 11, 2015
2
0
Very good for google cardboard!

Since everyone ignored your question the answer is as follows.

Open generic.kl in root explorer (device/system/usr/keylayout)

Find the line "Key 172 HOME" and commet it out by editing it to "# Key 172 HOME"
If you just want to disable home button wake, i have a workaround here:
http://forum.xda-developers.com/galaxy-s6/help/guide-how-to-disable-home-button-wake-s6-t3128348

To everyone else, whats the point of being a smart ass about his question? if you dont know the fix dont post. Dont pick apart his motives for litterally no reason. Android is about CHOICE.
 

hajyihia

Senior Member
May 31, 2013
524
59
this happened to me two months ago, i took my phone from my pocket and found out that i only have 40% battery left, the phone sent many many messages, video calls, calls, whatsapp......since then i use the pattern lock...but it's annoying
 

rcroonenberghs

New member
Sep 3, 2019
1
0
Since everyone ignored your question the answer is as follows.

Open generic.kl in root explorer (device/system/usr/keylayout)

Find the line "Key 172 HOME" and commet it out by editing it to "# Key 172 HOME"
If you just want to disable home button wake, i have a workaround here:
http://forum.xda-developers.com/galaxy-s6/help/guide-how-to-disable-home-button-wake-s6-t3128348

To everyone else, whats the point of being a smart ass about his question? if you dont know the fix dont post. Dont pick apart his motives for litterally no reason. Android is about CHOICE.

do you need root access on your phone to do that? Because I'm getting "java.io.filenotfoundexception:Read-only file system" error
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Since everyone ignored your question the answer is as follows.

    Open generic.kl in root explorer (device/system/usr/keylayout)

    Find the line "Key 172 HOME" and commet it out by editing it to "# Key 172 HOME"
    If you just want to disable home button wake, i have a workaround here:
    http://forum.xda-developers.com/galaxy-s6/help/guide-how-to-disable-home-button-wake-s6-t3128348

    To everyone else, whats the point of being a smart ass about his question? if you dont know the fix dont post. Dont pick apart his motives for litterally no reason. Android is about CHOICE.
    1
    Both of you off topic ! I just ask for a solution ! Thanks anyway ! [emoji12]