[Q] How to get rid of "System UIDs Inconsistent"?

Search This thread

Cookie Ninja

Senior Member
Jan 21, 2010
2,043
699
Found this thread after searching thru the forum. I reflashed stock to eliminate some ROM inconsistencies. Rooted and restored user apps and stock jb browser using TB. On rebooting I got this funny message with a "i'm feeling lucky" button to proceed....WTF?
Thanks for pointing me to use TWRP to fix permissions.....
Details and screenshot here http://forum.xda-developers.com/showthread.php?p=48133004
 
Last edited:

psikonetik

Senior Member
Aug 25, 2013
79
0
Hi everyone I'm having the same problem restoring with titanium from SD card.
If I restore the app quits unespectadly and if I reboot it gives me the UIDs message. So I fix permissions with TWRP but then the app is reset without the data restored and the SD card is damaged.

What can I do??
 

R4WK1LL

New member
Jun 12, 2012
4
0
Hi guys, currently I'm on Cool ICS v18 (HTC, S-OFF) and having the same issue. I have tried the "Fix Permissions" method via CWM (which failed), then TWRP (failed again), and the last one through Sterickson's Fix Permissions tool (same thing).

When I say failed, I meant that each tools did confirm that it has fixed the issue, but then again the "System UIDs Incosistent" warning keeps popping up after each reboot; and when I check "data/system/uiderrors.txt", it keeps updated with the same errors.

Any advice on what should I try next? Thanx beforehand.


Edit:

Scratch all that.. it turns out that my issue is caused by FolderMount app. I should've unlinked the data before changing the ROM. It should be obvious that the "Fix Permissions" method won't works on apps data that hasn't even mounted.. :facepalm in shame:

Anyway, for anyone else who might have similar issue, here's what I did to fix it:
1. Backup FolderMount settings.
2. Backup each apps data (that is linked to FolderMount) with Titanium Backup.
3. Delete those apps data (don't just unlink them) from FolderMount interface.
4. Restore those data back with Titanium Backup (so they're all go back to "/data/data/" folder).
5. Use the "Fix Permissions" method described on this thread. This time around, I use TWRP.
6. Done!

Optional:
If you still want to use FolderMount (I did!), just restore it's backup settings; then move the data back to ext. storage like you've done before and you're good to go.
 
Last edited:

SteeLx

Senior Member
Apr 26, 2011
57
2
Mumbai
ajwebdesigner.in
Im using XOLO Nvidia Tegra 4 tablet.

I started facing this issue. I checked log in data/misc
So I uninstalled pvcz_2 (plant vs zombies 2).
Rebooted in TWRP > Cleaned Cache and Dalvik > Fix Permissions.

But I still face the same issue after reboot.

so went back again to data/ opened that uid text file and uninstalled all cusing files. Uninstalled "Anamoly 2" & plants vs Zombies 2 and restarted into TWRP, fixed permissions again.

ITS FIXED now :)
 
Last edited:

txlatino1983

Member
Jul 1, 2009
49
0
Austin/Dallas
Hey guys I have a t-mobile Note 3 stock rom 4.4.2 how can I find the data/system folder?
I have Root Explorer and File Manager but am unable to find this directory. Does my phone need to be rooted?
I am getting the following message "System UIDs Inconsistent". After I press the I'm feeling lucky button then the following message pops up and I have to hit OK about 5 times to it "Unfortunately VolteConfigurationMenu has stopped". I have noticed that while the VoLTE message is on my Signal just shows a circle with a line through it. It takes about 10 seconds for it to finally go away and my signal to return to 4G/LTE.
Any help is appreciated
 

txlatino1983

Member
Jul 1, 2009
49
0
Austin/Dallas
Here are a couple of screenshots of the errors.
Thanks.
 

Attachments

  • Screenshot_2014-07-28-21-46-35.jpeg
    Screenshot_2014-07-28-21-46-35.jpeg
    120.7 KB · Views: 234
  • Screenshot_2014-07-29-10-27-30-picsay.jpg
    Screenshot_2014-07-29-10-27-30-picsay.jpg
    141.5 KB · Views: 189

Osama Abedin

Senior Member
Aug 10, 2014
95
17
That fix permission thingy still didnt work out for me
In Fact i couldnt even swipe
I mean when it says swipe to continue i swipe and then twrp restarts
 

Majal

New member
Dec 23, 2014
3
0
Make sure that a specific TWRP is really for your device.

same thing happens to me. once i swipe to fix the permissions, twrp restarts. any thoughts guys? thanks!

Make sure that a specific TWRP version is really for your device (or at least the most updated one). For me Flashify app makes selection + download + install of TWRP automated and easy.
 

masChmagic

Member
Jul 16, 2007
47
1
Ouch, i "fixed permission" with CWM because Titanium Backup wouldnt restore data (parse error).
And all of a sudden, now I get this "UID inconsistent, you must wipe /data".

I tried the #37 but ES Explorer says /data is empty.. but it was full of folders before I tried the "fixed permission" thing
 

simona.pisano.70

New member
Apr 9, 2016
3
0
Fantastic, ok. It was only a stupid app. Uninstalled and reinstalled and ok.

---------- Post added at 09:09 AM ---------- Previous post was at 09:07 AM ----------

ES Explorer says /data is empty only becouse you must say him in setup to show hidden and system files....
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    system UIDs inconsistent, it keeps showing up after every boot.
    i have nexus 7 GSM 32 gb rooted using nexus 7 toolkit with clockworkmod recovery, android version 4.2.1 build number JOP40D
    i tried Rom manager fix permission the same problem, i don't like resetting it any suggestion
    thank you

    I found the answer in another thread. I used TWRP (Advanced - Fix Permissions). It was instantly fixed.
    I took a full backup before trying this, but didn't need it.
    1
    I was on 4.2.1, rooted, and with TWRP as recovery.
    I wanted to get the OTA to 4.2.2 so I did full Titanium backup and then used the WugFresh toolkit to flash stock 4.2.1.
    After flashing, I was offered the OTA which I allowed to install.
    When finished, I got root back with Rootkeeper and restored all Apps and Data (not System data) with Titanium.

    Everything was working, but on every reboot I got the message :
    "System UIDs Inconsistent. UIDs on the system are inconsistent, you need to wipe your data partition or your device will be unstable."

    I also found that My Phone Explorer would no longer connect via USB so I decided to go back to 4.2.1.

    I again flashed it with the toolkit and did another restore with Titanium. Again, everything seems to be working, but I still get this message on every boot.

    I thought using Titanium Backup was a standard way of restoring apps and data.
    How do I get rid of this message without wiping and reinstalling all my Apps individually, which means losing all my game scores, etc?
    1
    same problem

    system UIDs inconsistent, it keeps showing up after every boot.
    i have nexus 7 GSM 32 gb rooted using nexus 7 toolkit with clockworkmod recovery, android version 4.2.1 build number JOP40D
    i tried Rom manager fix permission the same problem, i don't like resetting it any suggestion
    thank you
    1
    it took me time and I did it using clockwork mod recovery
    advanced then fix permissions
    but nothing happen , still the same.
    should I try flashing TWRP recovery then..
    if yes. could u help me with a simple guide
    much appreciated
    thank you

    Sent from my Nexus 7

    You can boot any recovery you want without hard-flashing it to the device (so long as the boot loader is unlocked).

    With the device in bootloader/fastboot mode,

    Code:
    fastboot boot name-of-recovery-image-file.img

    So download TWRP and give it a roll.
    1
    for me uninstalling quadrant did the trick :D