• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Issues with A701 upgrade to 4.1.1

Search This thread

misteral1970

Member
May 3, 2010
30
0
Hi All,

Really sorry to post a new thread about this, but I am unable to add a post here: http://forum.xda-developers.com/showthread.php?t=1911437

So, followed Member - OPs guide to manually update my A701 to JB.

Simply put, the patch would not install (failed with a permissions error)
Put JB on anyway (just to see) and this won't let me get past the choice of language and location (Also, at this stage, SuperUser tells me system is requesting SuperUser access and whatever I do, it accepts)

So, used CWM to put the 4.0.4 build back, and that worked fine - though according to About Tablet I am actually on 4.1.1
I see improved UI speed and responsiveness, it's all looking great.
But Play Store won't run. Tried adding the latest version, still 'unfortunately stops' Also Nova refuses to run.

Has anyone run into any of these issues (Patch not installing, Play Store failing) and have any ideas what I can do to fix them?
Really sorry again for making a new thread in the wrong forum, I didn't see a choice (other than waiting!)

Thanks in advance,

Al
 

Moscow Desire

Retired Senior Moderator
Hi All,

Really sorry to post a new thread about this, but I am unable to add a post here: http://forum.xda-developers.com/showthread.php?t=1911437

So, followed Member - OPs guide to manually update my A701 to JB.

Simply put, the patch would not install (failed with a permissions error)
Put JB on anyway (just to see) and this won't let me get past the choice of language and location (Also, at this stage, SuperUser tells me system is requesting SuperUser access and whatever I do, it accepts)

So, used CWM to put the 4.0.4 build back, and that worked fine - though according to About Tablet I am actually on 4.1.1
I see improved UI speed and responsiveness, it's all looking great.
But Play Store won't run. Tried adding the latest version, still 'unfortunately stops' Also Nova refuses to run.

Has anyone run into any of these issues (Patch not installing, Play Store failing) and have any ideas what I can do to fix them?
Really sorry again for making a new thread in the wrong forum, I didn't see a choice (other than waiting!)

Thanks in advance,

Al

Mate, it doesn't sound good.

What I would do, at this point, is Fastboot the 4.1 image again.. And stay the heck out of CWM. If you Fastbooted the 4.0.4 image, and you still have it showing 4.1, then you have a serious issue. So boot to fastboot, and try it again. Clearly, whatever you did with CWM, didn't work,

Installing a rom from CWM, requires certain things to be done, either in the install script, or via CWM.

Most notably, Formatting User data, cache, dalvik, system, and data. If any of these do not get done, chances are, the rom install will not go good. The basic install script, generally only formats System and Flexrom. This is because Acer distributes a full rom with the understanding there is nothing on it. Most rom modders know this, which is why they give extra instructions via cwm.

The big thing, is when you boot your tablet, is if it says which bootloader you are on. So you have to look,. You want to be on the JB bootloader.

MD
 
Last edited:
  • Like
Reactions: misteral1970

misteral1970

Member
May 3, 2010
30
0
Thanks for the response MD,

A tiny bit unsure how to proceed. I understand everything that you said (well, I think I understood correctly!)
I have in fact tried to fastboot the 4.1.1 image again, and again I am stuck on the language and location screen (did this last night before giving up for the day)

I have read and understood "Stay away from CWM" (and I know that it is in this case only - have used CWM on my Gnex without issue)

Please forgive me if what I am about to write is ridiculous - this is kind of where we'll see whether I understood correctly or not.

I'm thinking that if the various areas were not wiped, and that could be the reason for the snafu, then it would be worth going into CWM (which I have been warned to stay away from, and which I would stay away from except for this one thing) and formatting the user data, system, dalvik etc, then applying either the 4.1 or 4.0.4 to result in a working tablet.

Or possibly flashing the bootloader to make sure it is JB

Or going back to the weird 4.0.4/4.1.1 hybrid which works but doesn't allow Play Store and finding a way around that issue.

Mate, I'm not sure which way to go at this point!
Fastbooting 4.1 is a dead end at the moment (but could that be a bootloader issue....)
Fastbooting 4.0.4 gives me the hybrid (though I can check this again tonight)

BTW, the only CWM Rom work I have tried to do has been with the patched update (second downloadable file I think) - everything else has been done via ADB

So.....CWM to wipe/format caches? (I'm thinking 'NO! DID YOU NOT HEAR WHAT I SAID ABOUT STAYING AWAY FROM CWM????' but I'm asking anyway!)
Flash a new bootloader on? If so, any idea where I would find it (will obviously search here and Google)

Thanks anyway, and thanks in advance if you have any more advice. I really do appreciate the support!

Al
 

Moscow Desire

Retired Senior Moderator
Well Al,

This is perplexing to say the least. Clearly fastbooting the 411 results in frozen at the wizard. My question, when you have the unlocked bootloader, does it say JBxxxxxxxx unlock mode when you boot the tab? Because it should. If it doesn't, then you're still on ICS bootloader. And will have to do the CWM thing to get JB installed. The 411 image flash, is to get a rooted version.

And this is the point. Personally, I do not trust the CWM's at this point. That's just me (already bricked 1 tab 3 months ago with a faulty CWM) I know the folks with ICS are using Pawitp's CWM, and haven't reported issues. But I don't know if they are doing wipes or not.

As with the 404 image, well, why playstore doesn't work is perplexing. You could try reinstalling the playstore via manual method (root required). Which is to delete the vending.apk, install a new vending.apk (making sure permissions are the same as the other files), then reboot. Go to settings, wipe the playstore cache's. Then try Playstore again. This was an old method we used with market issues in HC.

Personally, I feel the issue is with the wipes before running the patch. But I would hate you do the wipes and formats, then discover the emmc chip bricked. So it's 50/50.

But heck, you have warranty. Just install some update.zip, and it resets your bootloader so service doesn't complain ;)

Wish I could give you a definitive answer, but these processes are too new.

MD
 

hks47

Member
Dec 22, 2008
5
0
Keep warranty

But heck, you have warranty. Just install some update.zip, and it resets your bootloader so service doesn't complain ;)

MD

Can you make a short tut how to replace the old unlocked Bootloader?
My Tab has some Problems with the Display so it need a service ...

witch cwm to use?
witch update.zip?
remove cwm and su if necessary

Android Version: 4.0.4
Baseband: 11.810.922.00
Kernal:2.6.39.4+
Image:ACER_AV043_A701_RV08RC02_EMEA_DE
Build: ACER_AV043_A701_1.017.00_EMEA_DE
 
Last edited:

misteral1970

Member
May 3, 2010
30
0
Hi MD,

Thanks for such a speedy and useful response!

Warranty: nope! I'm in China, bought the tablet in Shanghai (now way down south in Shenzhen) and it was a dodgy deal to say the least. I suspect they were being lifted from the factory. No complaints from me about this, or about any difficulties caused by rooting/flashing/CWM. My choice of action all the way along and I am aware of the risks ;)

Just flashed 404 again and it is fine so far, again very nice and smooth. Going to look at the Play Store and see how it behaves, see what I can do as far as vending.apk is concerned (although I'm lost when it comes to permissions. Obviously I know what permissions are in tech terms, but no idea where they would be set, how to change them, what to use as a reference) I figure this is the path of least resistance for right now.

Then I'm going to see if I can apply the standard A701 update to JB (which I won't be able to because of rooting/unlocking but I will fiddle around) and see if I have any joy.

Got my keen eyed gf to check the message on boot, you were right that with the 411 image applied it still had an ICS bootloader, so that's good to know if I want to try going back to the flashed JB image. However, I have no idea how to flash the JB bootloader/kernel, and the CWM process for the patched update fails each time (despite editing the first line of the necessary file in META-INF/Google/Android)

So, I will keep you up to date with progress. Fingers crossed!!!

Al
 

misteral1970

Member
May 3, 2010
30
0
Quick update.
Play Store seemed fine for quite a long time (although I didn't download anything, I was able to browse no problem)
Went to install my back up of Nova, and of course had to tick 'Unknown Sources'
As soon as I did that, allowing installation of apps not downloaded from the play store, I got the 'Unfortunately Play Store has stopped working' message. Before I installed anything else, immediately I ticked that box.

Unticked it, but still not working - installed Nova, not working.

So....
 

Moscow Desire

Retired Senior Moderator
Quick update.
Play Store seemed fine for quite a long time (although I didn't download anything, I was able to browse no problem)
Went to install my back up of Nova, and of course had to tick 'Unknown Sources'
As soon as I did that, allowing installation of apps not downloaded from the play store, I got the 'Unfortunately Play Store has stopped working' message. Before I installed anything else, immediately I ticked that box.

Unticked it, but still not working - installed Nova, not working.

So....

Well, seems like Nova is the culprit. I assume you are talking about nova launcher? Or nova the game?
 

misteral1970

Member
May 3, 2010
30
0
Hi MD

Yes, Nova launcher but no, it's not the culprit. At least I don't think so.
The play store stopped as soon as I ticked 'Install from unknown sources', before I installed Nova.
Very odd.

Quick questions:

1) Any advice/links/downloads for changing to JB bootloader if I apply the 4.1.1 again? Given that I cannot run the patched update/flash from CWM, I am guessing I would need to directly install/flash the bootloader from ADB...

2) Don't kill me for asking this. I know to stay away from CWM, I have seen you post it a good few times here, I heed the warning....BUT.....
Given that I have CWM installed and it's working ok (apart from failing to apply updates) - I have 6.0.1.4 - many of the guides to updating the 701 say it needs 6.0.1.1. Would the slightly more recent version of CWM make a difference in terms of success or failure of the update? Update is failing with a 'set_perm:some changes failed' very early in the update.

Seriously, I am being extremely wary of CWM, it's just that currently I have a slightly disabled tablet and it would be great to get this sorted.

Thanks, once again, for all your help,

Al
 

misteral1970

Member
May 3, 2010
30
0
Update again, put 404 back on (after issue with play store and unknown sources)
Opened play store, downloaded Apex launcher - all good.
Ran Apex, all good....then suddenly Play Store stops, Apex stops, never to return.

With 404 img on, About Tablet still says 4.1.1

The saga continues!!
 

misteral1970

Member
May 3, 2010
30
0
Aaaand that's the end of that!

Put 4.1.1 back on, pushed the boot.img from the official update.
Now no CWM, so it seems no recovery mode....if I try to get there by volume down and power on, it goes into update mode.
And of course neither the official update nor the 'patched' one will apply.

Can boot to the first start screen (language/location) but can't get any further.

Maybe I can find a service center here in Shenzhen who can sort it out.....as I said before, no harm no foul, I knew the risks!

Thanks one more time MD for all your support and advice :eek:)
 

misteral1970

Member
May 3, 2010
30
0
Or is it......?

Didn't give up, didn't surrender. Found out how to get into fastboot using frantic waggling of the rotation lock.
Just flashed 404 on again, waiting for boot to finish. Might still have a semi-usable tablet! Then I just wait till a 100% working JB manual update surfaces!
 

Moscow Desire

Retired Senior Moderator
Or is it......?

Didn't give up, didn't surrender. Found out how to get into fastboot using frantic waggling of the rotation lock.
Just flashed 404 on again, waiting for boot to finish. Might still have a semi-usable tablet! Then I just wait till a 100% working JB manual update surfaces!

HA HA, you found the User Data wipe.... ;) Yeah, a little known secret from the 500 forums. ;)

MD
 
  • Like
Reactions: misteral1970

misteral1970

Member
May 3, 2010
30
0
It's so strange....so now I'm back to having flashed 404 but the tablet thinks it's 411.
Play store was fine for about 40 minutes, I quickly got chrome, currents and BBC news.
I turned off the Acer ring and play store died...

But here I am, typing to you on the tablet and it's fine. And what a change in performance. It's most noticeable in currents..the increase in speed and smoothness when scrolling between pages makes it at least ten times better than before.

But the last flash was 404....weird....

I'll leave it like this for now. No market but at least it's not semi bricked!
 

misteral1970

Member
May 3, 2010
30
0
Super Quick update - in lieu of finding a sparkly copy of vending.apk, I tried wiping data and uninstalling Play Store (reverting to factory)
It duly downloaded a new version, and worked fine.
Then I popped Apex on, the GPS got busy, and Apex and Play Store died.

The wipe/uninstall worked again for Play Store so to be honest, I am currently quite happy. Ok, it's not perfect, but if I can quickly reinstate Play any time it fouls up, I can still build up a decent amount of apps to make the thing useful.

And seriously, whatever changes are there (considering the weird 404/411 hybrid) the performance is incredibly enhanced. All the faffing has been worth it, it is finally the tablet that it should have been from the start.
 

Moscow Desire

Retired Senior Moderator
Super Quick update - in lieu of finding a sparkly copy of vending.apk, I tried wiping data and uninstalling Play Store (reverting to factory)
It duly downloaded a new version, and worked fine.
Then I popped Apex on, the GPS got busy, and Apex and Play Store died.

The wipe/uninstall worked again for Play Store so to be honest, I am currently quite happy. Ok, it's not perfect, but if I can quickly reinstate Play any time it fouls up, I can still build up a decent amount of apps to make the thing useful.

And seriously, whatever changes are there (considering the weird 404/411 hybrid) the performance is incredibly enhanced. All the faffing has been worth it, it is finally the tablet that it should have been from the start.

Well, good news then. I think it's an interesting set-up. Hybrid. Still not sure though, why it pulls 411 from the build.prop as it should have been changed when you flashed the 404image. But honestly, after reading the OP's steps, I believe he references going back to 404 via CWM, and not fastboot. This of course would mean installing a full 404 original rom. I'll have to look over my JB system dump and see where the other prop would be. Maybe something changed in JB.

So if you can live with it, it's probably better to leave it be till we come up with something more definitive. :D

MD
 

misteral1970

Member
May 3, 2010
30
0
"So if you can live with it, it's probably better to leave it be till we come up with something more definitive"

Yeah, totally agree.

Mate, seriously, thanks for the support and advice on this. It makes a big difference. Even as I sat there last night with what seemed to be an unusable tablet, being able to chat to you about it meant that at least I didn't feel completely adrift!

Big big thanks :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi All,

    Really sorry to post a new thread about this, but I am unable to add a post here: http://forum.xda-developers.com/showthread.php?t=1911437

    So, followed Member - OPs guide to manually update my A701 to JB.

    Simply put, the patch would not install (failed with a permissions error)
    Put JB on anyway (just to see) and this won't let me get past the choice of language and location (Also, at this stage, SuperUser tells me system is requesting SuperUser access and whatever I do, it accepts)

    So, used CWM to put the 4.0.4 build back, and that worked fine - though according to About Tablet I am actually on 4.1.1
    I see improved UI speed and responsiveness, it's all looking great.
    But Play Store won't run. Tried adding the latest version, still 'unfortunately stops' Also Nova refuses to run.

    Has anyone run into any of these issues (Patch not installing, Play Store failing) and have any ideas what I can do to fix them?
    Really sorry again for making a new thread in the wrong forum, I didn't see a choice (other than waiting!)

    Thanks in advance,

    Al

    Mate, it doesn't sound good.

    What I would do, at this point, is Fastboot the 4.1 image again.. And stay the heck out of CWM. If you Fastbooted the 4.0.4 image, and you still have it showing 4.1, then you have a serious issue. So boot to fastboot, and try it again. Clearly, whatever you did with CWM, didn't work,

    Installing a rom from CWM, requires certain things to be done, either in the install script, or via CWM.

    Most notably, Formatting User data, cache, dalvik, system, and data. If any of these do not get done, chances are, the rom install will not go good. The basic install script, generally only formats System and Flexrom. This is because Acer distributes a full rom with the understanding there is nothing on it. Most rom modders know this, which is why they give extra instructions via cwm.

    The big thing, is when you boot your tablet, is if it says which bootloader you are on. So you have to look,. You want to be on the JB bootloader.

    MD
    1
    Or is it......?

    Didn't give up, didn't surrender. Found out how to get into fastboot using frantic waggling of the rotation lock.
    Just flashed 404 on again, waiting for boot to finish. Might still have a semi-usable tablet! Then I just wait till a 100% working JB manual update surfaces!

    HA HA, you found the User Data wipe.... ;) Yeah, a little known secret from the 500 forums. ;)

    MD