[Q] Mt65xx Android Phone Driver

Search This thread


New member
Mar 8, 2007
Help removing hacked iOS6 from android 4.2.0 phone

Purchased from china and it has a really terrible hack version of iOS6. I found a way to boot into factory mode and gleaned the following info.

I don't have USB drivers for it either. Anyone come across a similar situation and have a solution?

Under the version option from factory mode I get the following info;

BB Chip: MT6577
MS Board: mobitech77_m01_ics2
IMEI1: not posting this
IMEI2: not posting this
Modem Ver.: MAUI.11AMD.W12.22.SP.V14 2012/09/22
Bar Code: not posting
Build Time: Mon Mar 25 15:16:18 CST 2013
UBoot Ver: 2010.06
Kernal Ver: 3.0.13 ([email protected]) (gcc version 4.4.2 (gcc) ) #1 SMP PREEMPT Mon Mar 25 15:11:38 CST 2013
Android Ver: 4.2.0
SW Ver: ALPS.ICS2.MP.V1.18
Custom Build Verno: 1364195513


---------- Post added at 04:29 PM ---------- Previous post was at 04:00 PM ----------

I've somehow found a way into Android recovery mode but without an image to burn to replace the factory settings it still does me no good.


mobile lover

Senior Member
Sep 4, 2011
How to Install Your Android Phone USB Driver
  1. Download and extract Zip file to Desktop Download
  2. Plugin phone to Computer
  3. When ask for driver
  4. Select extracted folder and press Next.


working and tested by me:good:
Last edited:


New member
Aug 30, 2013
Rooting the Phone

Hi guys I am using Lava Iris N400, Android ICS 4.0.4, guys I am unable to Root the phone as the driver is not being installed properly. This is happening with me from last 3 months now i am tired of making my phone rooted successfuly perhaps i need to increase my internal memory. Also If any one knows how to increase the internal memory of the phone then also please tell me the same.
If there is any one who has used this phone . then do contact me on the id - [email protected] and contact No- 8765167823 it's (INDIA). So I will be Waiting for the success response.


New member
Dec 12, 2012
ALPS MT6517 USB Installation

Hi, I have an iPhone 5 clone which I cannot connect to my pc. (Win 7 64/32 bit) When I plugged it in, it detects as "Unknown Device" in USB controllers category in Device Manager. I've tried a bunch of MTK 65xx drivers, ADB drivers, Install from disk (.inf file), even tried Pda.Net but still can't install the usb drivers.

I've also tried to power it off then press Volume + then plugged it. (SD card removed, battery cannot remove because it's soldered) It detects as MTK USB Port but it never detects as MTK 65xx Preloader as to what I've searched.

I am so frustrated and I really really want to connect this to my pc so I can start flashing on it.
I hope you can help me with this guys..

model: MT6517
board: sanstar15_2006_p5_gb2
manufacturer: ALPS
CPU: ARM Cortex-A9
RAM: 233 MB
hardware: MT6575
Android Version: 4.1.2 (but I can tell it's Gingerbread)
Kernel Arch: armv71
Kernel Version:


Senior Member
Aug 29, 2011
Hi. You may find tutorials like seniormember Kumar Abishek in http://forum.xda-developers.com/showthread.php?t=2206421.
You may search for MTK phone preload drivers. Mobileoncletools are for MTK devices. Some brands like Xiaomi, HTC, Oppo, have root procedures included.
Many of the drivers are not accepted by W7/W8.1 but the phone becomes detectable. If you want to root, Vroot .apk succeeded where others failed. Congrats

Top Liked Posts