[Q] No SIM card detected Xperia E C1505 Nanhu

Search This thread

Ruud033

Member
Jul 24, 2013
32
14
Hey guys, first of all a big hello to everyone, since this is my first post here on XDA!
I've been on this forum for a while, but it's only since now that I really can't figure things out anymore on my own, or trough other posts.

Now the situation:
I've got a sony Xperia E C1505 (codename Nanhu) (that's single SIM)
which is not running well even on stock software. On stock software (ROM version 11.3.A.0.47) the phone keeps freezing after a while, say 10 seconds after the reboot. When it freezes, it instantly reboots.
I got tired of this rebooting phone and first flashed Firefox O.S. to see what it looks like. It's quiete awesome but I didnt have any radio's... Anyways ATLEAST it didnt freeze on me.

So I flashed back again to the stock 11.3.A.0.47, to see myself run into the freezing problems AGAIN!
This time I decided that I'd flash CM10 to see what it does.

So far I came across 2 different versions:

- JB version (by jjim, am I correct?)
- FXP version (by FXP)

I've been running FXP228 now and it works flawlessly! Everything works, every radio is intact and even the camera app works.
But.. *drumroll..* here's the thing; My SIM card does not get detected. It doesen't even ask me for a PIN at startup!
I've downloaded this 3rd party app for my SIM info, it says the following:

SIM state: UNKNOWN
Phone Type: GSM
Network type: UNKNOWN
The IMEI is correct though

The baseband is correct aswell, atleast I believe so.

Btw, I live in the Netherlands and my SIM card is from Vodafone. I've already tested this card in another phone, it works as it should.

What can I do to make the SIM-Card be detected? I've scoured the forums looking for solutions.. Sadly enough, I only came across this which was my closest approach to my problem:
http://forum.xda-developers.com/showthread.php?t=2277279

I also noticed this:
http://forum.xda-developers.com/showthread.php?t=2209767

Anyway's.. I'm sort of stuck right now. The next step for me is to try n flash FXP 220..
If anyone's got a direct solution or workaround for me on this stage, I'd be happy.

Also, some explainment around the whole JB rom's would be nice. I understand that I first have to flash a modified stock ROM from JB to install CM10 ? Where can I get this .TFT file? I've already searched in http://forum.xda-developers.com/showthread.php?t=2326830 and http://forum.xda-developers.com/showthread.php?t=2330638 but I don't get much wiser out of it.

Looking forward to your responses!

- Ruud



Edit: SOLVED!!

http://forum.xda-developers.com/showthread.php?t=2276943

I used the xperia_e_single_jb_cwm.elf first, then i flashed nanhu-CM10DS-0.8.1.33-ota.zip
After 2 reboots it finally got into the home screen, asked me for the PIN straight away and works like a charm.

Many thanks to jjim

Hope this helps for a future user.


Things i have tried:

- Flash FXP firmware versions; (failed)
- 220 (failed)
- 224 (no gsm)
- 228 (no gsm)

- Restore stock over and over (failed)
- Modify stock (failed)
- Modified the FXP firmware with modem.zip files from the stock and re-flashed (failed)

- Flashed JB firmware. SUCCES!!!!

Greetings Ruud from the Netherlands
 
Last edited:

el_zdo

New member
Oct 20, 2013
1
0
Hey man, thanks a lot with your post, Im having exactly the same problem.

I have tried with FXP241 with no lock detecting the SIM card.

I downloaded the files you posted. Flashed the jjm34 boot+recovery and then installed the CM10DS file you mentioned. During the install I had the error "symlink: some symlinks failed"

Did you have the same problem?

Thanks!
Zdo
 

Johnt880

Senior Member
Dec 7, 2013
211
51
Dublin
hello

Do a factory reset and if that fails then flash the stock rom onto your phone

---------- Post added at 03:36 AM ---------- Previous post was at 02:42 AM ----------

You need to flash a file called cm_nanhu_DS-ota110 to fix any simcard problem ,I have it on my phone now and testing it atm Works okay
 

xperia_bird

Senior Member
Apr 15, 2014
330
72
Hey guys, first of all a big hello to everyone, since this is my first post here on XDA!
I've been on this forum for a while, but it's only since now that I really can't figure things out anymore on my own, or trough other posts.

Now the situation:
I've got a sony Xperia E C1505 (codename Nanhu) (that's single SIM)
which is not running well even on stock software. On stock software (ROM version 11.3.A.0.47) the phone keeps freezing after a while, say 10 seconds after the reboot. When it freezes, it instantly reboots.
I got tired of this rebooting phone and first flashed Firefox O.S. to see what it looks like. It's quiete awesome but I didnt have any radio's... Anyways ATLEAST it didnt freeze on me.

So I flashed back again to the stock 11.3.A.0.47, to see myself run into the freezing problems AGAIN!
This time I decided that I'd flash CM10 to see what it does.

So far I came across 2 different versions:

- JB version (by jjim, am I correct?)
- FXP version (by FXP)

I've been running FXP228 now and it works flawlessly! Everything works, every radio is intact and even the camera app works.
But.. *drumroll..* here's the thing; My SIM card does not get detected. It doesen't even ask me for a PIN at startup!
I've downloaded this 3rd party app for my SIM info, it says the following:

SIM state: UNKNOWN
Phone Type: GSM
Network type: UNKNOWN
The IMEI is correct though

The baseband is correct aswell, atleast I believe so.

Btw, I live in the Netherlands and my SIM card is from Vodafone. I've already tested this card in another phone, it works as it should.

What can I do to make the SIM-Card be detected? I've scoured the forums looking for solutions.. Sadly enough, I only came across this which was my closest approach to my problem:
http://forum.xda-developers.com/showthread.php?t=2277279

I also noticed this:
http://forum.xda-developers.com/showthread.php?t=2209767

Anyway's.. I'm sort of stuck right now. The next step for me is to try n flash FXP 220..
If anyone's got a direct solution or workaround for me on this stage, I'd be happy.

Also, some explainment around the whole JB rom's would be nice. I understand that I first have to flash a modified stock ROM from JB to install CM10 ? Where can I get this .TFT file? I've already searched in http://forum.xda-developers.com/showthread.php?t=2326830 and http://forum.xda-developers.com/showthread.php?t=2330638 but I don't get much wiser out of it.

Looking forward to your responses!

- Ruud



Edit: SOLVED!!

http://forum.xda-developers.com/showthread.php?t=2276943

I used the xperia_e_single_jb_cwm.elf first, then i flashed nanhu-CM10DS-0.8.1.33-ota.zip
After 2 reboots it finally got into the home screen, asked me for the PIN straight away and works like a charm.

Many thanks to jjim

Hope this helps for a future user.


Things i have tried:

- Flash FXP firmware versions; (failed)
- 220 (failed)
- 224 (no gsm)
- 228 (no gsm)

- Restore stock over and over (failed)
- Modify stock (failed)
- Modified the FXP firmware with modem.zip files from the stock and re-flashed (failed)

- Flashed JB firmware. SUCCES!!!!

Greetings Ruud from the Netherlands

Do you still have got the Modem.zip files for the stock rom ??
 

njeanz

New member
May 9, 2014
4
0
Hi Everyone,

I have purchased my Xperiz Z 'C6602' in the start of this year (2014). Yesterday, I faced a problem that my mobile was showing no Sim card detection. I have restarted my mobile many times, open the Sim slot and again placed it corrected but the problem persists. I have reset my mobile, check the aeroplane mode but all is well. I am wondering that how this happened because my mobile was working great. I used it at night very well and then after some hours at morning the mobile showed no network connection (detect no Sim) while the Sim was in the Sim Slot.

Please tell me the solution of this problem. Thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hey guys, first of all a big hello to everyone, since this is my first post here on XDA!
    I've been on this forum for a while, but it's only since now that I really can't figure things out anymore on my own, or trough other posts.

    Now the situation:
    I've got a sony Xperia E C1505 (codename Nanhu) (that's single SIM)
    which is not running well even on stock software. On stock software (ROM version 11.3.A.0.47) the phone keeps freezing after a while, say 10 seconds after the reboot. When it freezes, it instantly reboots.
    I got tired of this rebooting phone and first flashed Firefox O.S. to see what it looks like. It's quiete awesome but I didnt have any radio's... Anyways ATLEAST it didnt freeze on me.

    So I flashed back again to the stock 11.3.A.0.47, to see myself run into the freezing problems AGAIN!
    This time I decided that I'd flash CM10 to see what it does.

    So far I came across 2 different versions:

    - JB version (by jjim, am I correct?)
    - FXP version (by FXP)

    I've been running FXP228 now and it works flawlessly! Everything works, every radio is intact and even the camera app works.
    But.. *drumroll..* here's the thing; My SIM card does not get detected. It doesen't even ask me for a PIN at startup!
    I've downloaded this 3rd party app for my SIM info, it says the following:

    SIM state: UNKNOWN
    Phone Type: GSM
    Network type: UNKNOWN
    The IMEI is correct though

    The baseband is correct aswell, atleast I believe so.

    Btw, I live in the Netherlands and my SIM card is from Vodafone. I've already tested this card in another phone, it works as it should.

    What can I do to make the SIM-Card be detected? I've scoured the forums looking for solutions.. Sadly enough, I only came across this which was my closest approach to my problem:
    http://forum.xda-developers.com/showthread.php?t=2277279

    I also noticed this:
    http://forum.xda-developers.com/showthread.php?t=2209767

    Anyway's.. I'm sort of stuck right now. The next step for me is to try n flash FXP 220..
    If anyone's got a direct solution or workaround for me on this stage, I'd be happy.

    Also, some explainment around the whole JB rom's would be nice. I understand that I first have to flash a modified stock ROM from JB to install CM10 ? Where can I get this .TFT file? I've already searched in http://forum.xda-developers.com/showthread.php?t=2326830 and http://forum.xda-developers.com/showthread.php?t=2330638 but I don't get much wiser out of it.

    Looking forward to your responses!

    - Ruud



    Edit: SOLVED!!

    http://forum.xda-developers.com/showthread.php?t=2276943

    I used the xperia_e_single_jb_cwm.elf first, then i flashed nanhu-CM10DS-0.8.1.33-ota.zip
    After 2 reboots it finally got into the home screen, asked me for the PIN straight away and works like a charm.

    Many thanks to jjim

    Hope this helps for a future user.


    Things i have tried:

    - Flash FXP firmware versions; (failed)
    - 220 (failed)
    - 224 (no gsm)
    - 228 (no gsm)

    - Restore stock over and over (failed)
    - Modify stock (failed)
    - Modified the FXP firmware with modem.zip files from the stock and re-flashed (failed)

    - Flashed JB firmware. SUCCES!!!!

    Greetings Ruud from the Netherlands
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone