[Q] OPO flashed on CM11s - Mobile Data issues

Search This thread

4p9xD

New member
Jul 13, 2014
1
0
0
[/ATTACH]Hello my friends,

I really need your help now. Since the Oneplus One is so new there are only few people having experience with the smartphone and it's Problems. I searched the whole Internet but dit not find anyone with the OPO who has the same Problem as me..

My OPO is the chinese Version and i flashed it without PC on CM11s.
But I found that my Smartphone has got no mobile Internet and also I am not able to call someone.

After I saw this I flashed the phone two more times, but with my PC and fastboot. I used the Images here: https: //cyngn.com /products /oneplusone/
Once I flashed my phone with PC and fastboot I got mobile data sometimes for about one or two minutes, after that it breaks down.

My APN's are the same with my Provider.

I tried to solve this Problem for the whole weekend, I now even consider selling the phone again..

It would be really really nice if someone is able to help me!

Best regards,
4p9xD

My phone Display:
Screenshot_2014-07-13-13-33-37.jpg
 

chriss2

Member
Jun 26, 2008
28
0
0
Warsaw
hi
I had a similar problem. I had a sim card trimmed with scissors and was too loose.
I replaced the card with a new one.

A problem, however, remained. Sometimes I can not call, sometimes not the Internet. It looks like something crashed and helps only restart.

You tried to upload the "modem chack"?
 

C13v3r0n3

Senior Member
May 13, 2013
263
244
0
If you have a Chinese version then you need a kernel made for your phone.

Sent from my One using XDA Premium 4 mobile app
 

xSteeve

Member
May 7, 2009
8
1
0
Another one here! I have exactly the same thread starter problem, 1 min after turn on the phone I cant call anymore or sending messages...

Right kernel? Can someone explaine? I have tryed to flash 3 version of CM11 and return back to ColorOS, the problem is not solved :|
 

aziizqi

New member
Jul 15, 2014
1
0
0
same problem

I'm having the same problem, the phone was working just fine when i first used it on ColorOs with voice calls working on 4g. however, as soon as I flashed CM11 it stopped working and I can only use 2g to make phone calls even though 4g internet works fine. I have flashed ColorOs but a rooted one, CM11 and other roms the problem is still there. If some one can find a solution for us I would be grateful.
 

ET118

New member
Apr 20, 2014
1
0
0
I have the same issue, after flashing to CM11s, its like the cell network is sick, turn on for a while, then off. when the phone is in the pocket (sleep) totally not network, and people cannot call in.

I flash back to Colour OS, more stable and 4G is working fine.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I've created a guide, Check this out .

    http://forum.xda-developers.com/oneplus-one/help/guide-fixing-opo-cm11s-modem-problem-t2824139

    Hello... I would like to know how to do this. I have the same issue and would like to do the same to solve it. any help would be appreciated. thank you!

    ---------- Post added at 03:16 PM ---------- Previous post was at 03:03 PM ----------



    Hello... I would like to know how to do this. I have the same issue and would like to do the same to solve it. any help would be appreciated. thank you!
    1
    hi

    for me the problem is almost resolved after installing CM11s (nightly), but only if I am connected to my network. if I am roaming and I use the other network can connect only EDGE. - it's problem...
    I think the biggest problem is with the official version: cm-11.0-XNPH25R-bacon-signed.

    Did you try to install the nightly version?
    I'm curious if it will be a positive effect.
    *
    If you're using titanium do not restore system settings ...!

    If your tests are confirmed i also will flash modem.bin from colorOS.

    What is your date of manufacture of your OPO (is on the package). My 30.06.2014

    Hi chriss,

    My OPO manufacture date is 29.06.2014. Almost same day that yours!

    Well I confirm my tests. 3G working stable (I can't test 4G because I don´t have 4G plan). No more disconections or hangs in phone calls. Tested with two carriers SIMs: Simyo and Movistar (spanish). Default configurations on mobile data settings.

    Before I tried:

    XNPH25R
    XNPH22R+XNPH25R incremental update
    CM11s (nightly)

    Always same problems.

    As promished I post the file.

    NON-HLOS.bin

    I've extracted this from the latest ColorOS 2.0.5 beta 2014/7/19 rom here or here.

    The file we need is NON-HLOS.bin.

    And the fastboot command is:

    Code:
    fastboot flash modem NON-HLOS.bin

    Hope this helps.

    Regards. Pau
    1
    hi guys i've big problem with chinese opo here in italy...my phone work only in edge mode, no 3g no 4g...
    @xSteeve what version of cyanogenmod do you use with color os modem???

    CM11 25R version, flash the modem and you solve the problem! :)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone