• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] Orbot broken on Enomther (Logcat included)

Search This thread

Alclub

Member
Feb 24, 2010
23
0
As certain Pandora users on this board may know, Orbot never works on Enomther's rom, but runs fine on CM and presumably stock (haven't tested stock). Orbot cycles between "Starting Orbot" and "Could not start Tor process", does this twice, then exits.

It appears to be failing at findProcessId(TorServiceUtils.java:68).

The tor log reveals:
1. "Orbot is starting"
2. "got tor proc id: -1" (i'm guessing -1 is an error flag)
3. "Couldn't start Tor process"

It then says "checking for an existing tor process", then quits on error.

I guess it can't find the tor background service.
Edit: I think the tor service isn't starting, even though Orbot thinks it did. Might have something to do with iptables or something.

Logcat: http://pastebin.com/6GESYFmm

I'm not a dev, but is there a simple solution to this? Is there something obvious I can change in the Orbot source, maybe I can compile my own client.

Thanks guys.
 
Last edited:

Jack_R1

Senior Member
Aug 9, 2009
4,365
962
You're not connected to WiFi, right? Using cellular data?

See if you receive the same warnings on CM6:

09-25 04:29:38.433 W/ORBOT ( 1990): Unable to get proc id for: /data/data/org.torproject.android/tor
09-25 04:29:38.433 W/ORBOT ( 1990): java.lang.NumberFormatException: unable to parse 'app_61' as integer

Other than that, the error dump is binary - not much to do with it...