• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Phone stuck on...

Search This thread

Geeenie

New member
Apr 29, 2013
4
0
Hey everyone, so I've been using a Cyanogenmod S2 for the past few months and everything was great.
Until recently it started to reboot by itself,
until one day when I woke up "Kernel panic upload mode" was on the screen.
I rebooted the phone,
and then was greeted with a black screen after the Samsung Galaxy S2 screen.
The buttons do light up, but nothing else could be done.
I entered download mode to flash a new firmware,
but then somehow it failed and then it says connect to computer to redownload firmware or something when I boot it on right now.
I can't get it to flash anything at all, whenever I use odin it gets stuck at setup connection,
I installed Kies but it doesn't recognize my phone as well, neither does my computer....

Need help. Desperately. :crying::crying::crying:
 

Geeenie

New member
Apr 29, 2013
4
0
Then you need to flash a stock rom with Odin. You don't really have any other option.


<OSM> T989UVMC6_T989TMB_T989UVMC6_HOME.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> aboot.mbn
<ID:0/003> NAND Write Start!!
<ID:0/003>
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

That's the problem, I can't seem to get Odin to flash no matter what, I've already tried different versions of Odin,
but they always end up with either this (failure) or stuck at setup connection..
Any ideas, please?
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    44.8 KB · Views: 515

MistahBungle

Senior Member
Nov 7, 2011
7,171
3,236
108
There's been many threads re: this issue on here over the past week listing the troubleshooting steps to go thru when Odin won't work, search for those threads (Immortalneo has listed them, go through his posts as a shortcut).

Edit - Hang on a minute, what model number do you have; what's the sticker on the phone chassis under the battery say ?
 

Geeenie

New member
Apr 29, 2013
4
0
There's been many threads re: this issue on here over the past week listing the troubleshooting steps to go thru when Odin won't work, search for those threads (Immortalneo has listed them, go through his posts as a shortcut).

Edit - Hang on a minute, what model number do you have; what's the sticker on the phone chassis under the battery say ?

I'm using a GT-i19100
I'm going through immortalneo's posts but so far nothing's up..
Am currently following this guide but to no avail, (no .pit file in the compressed .rar file) http://forum.xda-developers.com/showthread.php?p=40154030&highlight=+pit#post40154030

Edit: I think it's a GT-i19100G because I vaguely remember such a thing on the startup screen...
 
Last edited:

MistahBungle

Senior Member
Nov 7, 2011
7,171
3,236
108
If you've got an I9100, why are you trying to flash firmware for T-989 ?? I suggest you go back to Samfirmware & get an I9100 stock rom for starters.

Ignore that guide; your phone isn't bricked. However, it may well be if you try & flash a PIT file (Although, if you've somehow flashed firmware for a different model including PIT, you may need to at some point. Just not yet). OK. This is the first & last time I'm posting this stuff for the next month:-

Stuff to try when Odin doesn't work
-----------------------------------

*Must run Odin as administrator in Windoze.
*Ensure Kies & all it's processes aren't running in Windoze task manager. Kill them if they are (choose 'kill process tree').
*Try different USB ports; you must be using a 'powered' or mainboard port.
*Try different USB cables (particularly the cable that came with the phone if you're not using it now)
*Try different versions of Odin (search on here/Google)
*Uninstall Kies, reboot, redownload & reinstall it, reboot, try the flash again.
*Check the rom/kernel you download for corruption. Programs like 7Zip, IZarc, WinRar, etc will allow you to 'test' the rom file you download. If there are any errors/any of the files fail the test, bad download. Try again/try downloading with a different internet connection if it keeps happening.
*Run Windoze Update.
*And if all this fails, try a different PC. And if it won't work first time on another PC, go thru the above steps on that PC.
 
Last edited:

krlosalvarenga

Senior Member
Apr 1, 2013
83
2
San Lorenzo
Hello everyone ..
It could solve the problem? I am in a very similar, and have helped me a lot, but none of the options so far have been effective. I'm starting to resign myself to use it as a paperweight, but still have not lost hope.:crying:
 

GamingDj

Senior Member
Nov 19, 2012
607
321
Cluj
I'm using a GT-i19100
I'm going through immortalneo's posts but so far nothing's up..
Am currently following this guide but to no avail, (no .pit file in the compressed .rar file) http://forum.xda-developers.com/showthread.php?p=40154030&highlight=+pit#post40154030

Edit: I think it's a GT-i19100G because I vaguely remember such a thing on the startup screen...

Stop Now :0 ! You are trying to install a T-Mobile T989 firmware.It's a Galaxy s2 too,but from T-Mobile.It's not the same.Search on Sammobile for an I9100 firmware,preferable Android 4.0.3 or 4.0.4.Of course it gives an error,because it's not the right firmware.