[Q] Power on when plugged in (boot when docked)?

Search This thread

chemicstry

Member
Apr 23, 2013
5
1
Vilnius
ppcoin.d7.lt
Is it possible to make such patch as a Magisk module so that no boot.img patching is required? I'm not too familiar with android modding and wondering if Magisk is loaded at all at this stage? Any help would be very appreciated.
 

aIecxs

Senior Member
Feb 17, 2016
1,891
543
gitlab.com
I didn't say there is an answer... you can figure out and tell us. btw what do you mean, Magisk is loaded [...] no boot.img patching is required? Isn't that oxymoronic? :)
 
Last edited:

chemicstry

Member
Apr 23, 2013
5
1
Vilnius
ppcoin.d7.lt
I didn't say there is an answer... you can figure out and tell us. btw what do you mean, Magisk is loaded [...] no boot.img patching is required? Isn't that oxymoronic? :)
I meant that I want to apply this modification with just a magisk module (zip).

Currently this modification requires unpacking boot image, modifying ramdisk and reflashing, which I rather not do if there is a way without flashing (magisk module).
 

chemicstry

Member
Apr 23, 2013
5
1
Vilnius
ppcoin.d7.lt
It seems that it is impossible to add init scripts via modules: https://github.com/topjohnwu/Magisk/issues/933

My added `.rc` file appears in `/system/etc/init/`, but is not loaded as confirmed by `dmesg`.


The alternative way of patching ramdisk is not as straightforward either, so here is how I got it to work on Xiaomi Note 10 Pro:
1. Get boot.img (mine was from original ROM zip, patched with magisk)
2. Unpack with `magiskboot unpack boot.img`. The `magiskboot` is not in PATH and can be found in `/data/adb/magisk/magiskboot`.
3. Create custom.rc:
Code:
on charger
    exec u:r:magisk:s0 -- /system/bin/reboot
4. Modify ramdisk with `magiskboot cpio ramdisk.cpio "add 0700 overlay.d/custom.rc custom.rc"`.
5. Repack boot.img with `magiskboot repack boot.img`. A new-boot.img will be created.
6. Flash via `fastboot flash boot new-boot.img`.
 
  • Like
Reactions: aIecxs

aIecxs

Senior Member
Feb 17, 2016
1,891
543
gitlab.com
Thx for pointing out. So all you can do is flashable zip anykernel3 that can applied to from TWRP (I never did but should be possible)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    SOLVED: Power on when plugged in (boot when docked)?

    Hey guys, I know that no one else may ever have any use for this, or even care, but I wanted to post an update. I was finally able to get this figured out through some guess work, trial and error, and looking at the work someone else did on a fairly similar project.

    I owe plenty of credit to the fine work done by Chainfire on his project described in this link. His work, while not the same project, demonstrated that something similar to what I wanted to do WAS possible.

    Anyway, to make the tablet boot up when first plugged in- The battery charging indicator that runs when you first plug in the Galaxy Tab is run from the file /system/bin/playlpm. To make it boot automatically, delete the old playlpm (or better yet, rename it to playlpm.bak, just in case) and replace it with the following script.

    /system/bin/playlpm
    Code:
    #!/system/bin/sh
    /system/bin/reboot

    Be sure to set the ownership and permissions the same as the old playlpm. It didn't work for me at first because I had forgotten to give execute permission.

    Thats all that it takes. Most of the time, the Tab should have enough power to go straight to booting. If the battery is really dead, it may flash the charging battery icon a few times, failing to boot until it gets enough charge. It will eventually come on.

    I don't know of any additional side-effects for doing it this way, but there may be some, I don't know what else the stock playlpm is supposed to manage. This worked for my purposes though. Hope it could help someone else.
    5
    Appologies if this has been asked/answered here before. I tried searching, but didn't find any solution. Maybe someone else has stronger Google skills than I.

    Here is what I am trying to do. I'd like to find a way to have the Galaxy Tab power on automatically when it is plugged in to power and begins charging. My company has several Galaxy Tabs (rooted) that are being used for a specialized purpose. They should be plugged in 24/7. However, it is possible that they will lose power, and the battery will eventually run down. When power is restored, I'd like to be sure that they come back on, without any user interaction.

    I don't THINK this is the case, but it is worth asking: Is this a standard Android setting I can change anywhere?

    I assume I will have to modify some code. Right now, I notice that when the Tab is turned off, and you plug it in, the charging indicator shows up and displays the battery levels. To me this indicates that code is running SOMEWHERE as soon as the Tab gets plugged in. I'd like to hijack that, and just have it power on.

    Does anyone know where I should start looking for the code that runs when the device is plugged in? I found a charging.jpg in /mnt/.lfs that seems to be the image that displays, but so far no sign of what code is running. If there is any sort of init script, that would be amazing if someone could point that out.

    Even if you don't know how to accomplish this, if you have any helpful pointers or "take a look at these files" to point me in the right direction, I'd really appreciate it.

    As always guys, thanks for all the help!
    4
    Hello,

    None of the proposed solutions worked for me on Samsung Galaxy Tab A 10.1 (T580) with Android 7 (no boot, black screen, boot to Recovery, etc.), but after much testing, I've found another way to make it work.

    Extract boot.img from the rooted device and copy to PC (13540000.dwmmc0 -> T580's boot partition):
    adb shell "su -c dd if=/dev/block/platform/13540000.dwmmc0/by-name/BOOT of=/sdcard/boot.img"
    adb pull /sdcard/boot.img

    Download Android Image Kitchen:
    https://forum.xda-developers.com/showthread.php?t=2073775

    Drag-and-drop boot.img to unpackimg.bat.

    Open ramdisk/init.rc

    Search for on charger and add at the end (after write /sys/class/power_supply...):
    setprop ro.bootmode "normal"
    setprop sys.powerctl "reboot"

    Save file and repack image (double click on repackimg.bat).

    Rename image-new.img to boot.img

    Tar boot.img file (you will need tar for Windows):
    tar -cf boot.tar boot.img

    Download Odin latest version:
    https://samsungodin.com/

    Open Odin, click on AP, select boot.tar file.

    Reboot device to download mode:
    adb reboot download

    Click Start on Odin.

    After reboot, disconnect and power off device. Reconnect the USB cable and wait.
    2
    I think I'm in the same boat as @fritz.barnes. I've tried every combination of suggestion here but there's something weird going on.

    I have a Samsung Galaxy Tab A 10.1 (2019) with unlocked bootloader, TWRP, and root (Magisk).

    It appears as if anytime i replace /system/bin/lpm and put in the suggested shell scripts to trigger a reboot, it appears this isn't running at all or incurring some kind of exception.

    I was initially really confused because there were other people saying that the script appeared to be working but that it was booting them into recovery/TWRP, and that appeared to be what was happening to me. But after going through so many scenarios, I think there was a reason for that.

    1. When I first made the change to /system/bin/lpm after being in USB debugging and from ADB shell, when I turned the tablet off with cord unplugged, then plugged in cord, I got stuck at the initial lightning charge screen that doesn't have the real battery %, etc.
    2. When this just got stuck forever and didn't reboot (regularly or into TWRP), I held POWER + VOL DOWN to reboot, then POWER + VOL UP to get back into TWRP. After getting into TWRP, mounting system, and making the similar changes to /system/bin/lpm, it "appeared" to be working in that after powering off with cord unplugged, it would start up when cord plugged in but go immediately into TWRP.
    3. I realized later after trying multiple different versions of this file that all kept going into TWRP, if I rebooted regularly into system first with TWRP, then powered off with cord unplugged, then plugged cord in, I was still stuck at the initial lightning charge screen that doesn't have the real battery %, etc.

    After all that, I'm assuming the initial lightning charge screen has nothing to do with /system/bin/lpm, and that this shows regardless of what /system/bin/lpm is. But compared to the original /system/bin/lpm behavior of in a few seconds showing correct battery %, my attempts at the shell script /system/bin/lpm probably just appear to be doing nothing (not rebooting) and just keeping me at the initial lightning charge screen.

    As I said, I tried multiple different versions of the script throughout this thread and nothing has seemed to work. I have created the file or copied the file in different ways and also verified EOL characters, etc.

    Does anyone have any idea what's going on with my situation (and possibly with @fritz.barnes having the same or similar issue that I do) or how to debug this? Is there something that has been altered with reboots by TWRP that requires any sort of Android property to be set or anything? I'm not an Android developer, but I see this in the TWRP source in terms of doing a system reboot, but I'm not fully sure what's going on here.

    Code:
    case rb_system:
    			Update_Intent_File("s");
    			sync();
    			check_and_run_script("/sbin/rebootsystem.sh", "reboot system");
    #ifdef ANDROID_RB_PROPERTY
    			return property_set(ANDROID_RB_PROPERTY, "reboot,");
    #elif defined(ANDROID_RB_RESTART)
    			return android_reboot(ANDROID_RB_RESTART, 0, 0);
    #else
    			return reboot(RB_AUTOBOOT);
    #endif

    Thanks!

    ---------- Post added at 09:48 PM ---------- Previous post was at 09:21 PM ----------



    Not sure if I'm normally supposed to reply to my own post here, but I have some more information that seems interesting.

    If I take the original /system/bin/lpm, make a copy and then use the copy as /system/bin/lpm (and move the original to a different file, i.e. /system/bin/lpm.bak), the copied version of the original binary also seems to not work and keep me at the initial lightning charge screen. I am making sure to chmod 0755 and chown root.shell any copied files as you can see below. The original file has timestamp of 2008-12-31, and this specific file appears to be the only one that will work (and go to the normal charge indicator screen).
    aFwCp4k.png


    Not sure if this will further help diagnosis anything, but what's going on here? Why with a copy of the original lpm binary does this also result in me being stuck at the initial lightning charge screen? Any ideas?

    I'd be willing to send a $50 bounty via Venmo to whoever can help me get this working.

    from my own experience, if something get stuck, it means the comand in tge lpm file is wrong, you have to try different command.

    i have successfully auto boot 4 different phone, S4, Mate 7, zenphone6, redmi 6a, they all need to use different command, eventhough i only changing the same file. in my case in init.rc and some by just changing kpoc file.

    Sent from my Redmi Note 7 using Tapatalk

    Hi guys, as a followup after trying again tonight it is working!

    I came across a different link where someone posted his "one-liner" for doing this:
    mount -o remount,rw /dev/block/platform/dw_mmc.0/by-name/SYSTEM /system && cp /system/bin/lpm /system/bin/lpm_orig && echo "#!/system/bin/sh\n/system/bin/reboot" > /system/bin/lpm

    As mentioned previously, with me using Magisk users have reported "/system" mount not existing.

    What it looks like it boils down to at least for me, is that every time I was trying this, I was doing a move/rename of the original /system/bin/lpm, then creating a new /system/bin/lpm (as root/root) and then doing a chmod 0755 and a chown to root/shell. Apparently this method did not work for me even though I was seemingly left with the same file with same permissions, but looks like since this person's one-liner does a copy to backup original /system/bin/lpm and then just overwrites the existing file contents with the simple shell shell script to auto-boot, this works!

    I'm not sure if my situation is related to Magisk or what, I'm just not very familiar with Android mounts/partitions/etc. but if anyone is having a problem similar to mine, replacing contents of existing file worked for me.
    2
    Found solution that works on Samsung Galaxy Tab A6

    For me the reboot scheme didn't work but what did work was putting into /system/bin/lpm this:
    Code:
    #!/system/bin/sh
    echo b > /proc/sysrq-trigger

    Hope it helps someone :)