[Q] Problem; Lollipop has stopped Tethering working

Search This thread

jonmorris

Senior Member
Apr 22, 2012
1,722
478
Hatfield, UK
www.jmcomms.com
Since updating, I've discovered that I can no longer use USB Tethering or set up a wireless hotspot.

Or should I say, I can, but neither give the other device any connectivity - even though it works fine on the phone itself.

Anyone else having problems, or can suggest a fix?
 

bartolo5

Senior Member
Dec 1, 2010
281
118
Since updating, I've discovered that I can no longer use USB Tethering or set up a wireless hotspot.

Or should I say, I can, but neither give the other device any connectivity - even though it works fine on the phone itself.

Anyone else having problems, or can suggest a fix?

Works fine here on 5.0.2 full wipe, nordic ftf, USA bought D6603 on AT&T USA network. Maybe they changed something on your carrier with 5.0.2 that needs your account to be provisioned for tethering on Lollipop. Sometimes depending on the carrier a different apn is used for tethering and the carrier can then block you if you are not provisioned. The APN's change often with every version.
 

jonsmith709

Senior Member
Feb 8, 2010
170
30
Exeter
Since updating, I've discovered that I can no longer use USB Tethering or set up a wireless hotspot.

Or should I say, I can, but neither give the other device any connectivity - even though it works fine on the phone itself.

Anyone else having problems, or can suggest a fix?

I'm on the same as you with 3 and can no longer tether although I can create a Hotspot and people can join, just no data......really annoying. Apart from that i like the update.
 

jonmorris

Senior Member
Apr 22, 2012
1,722
478
Hatfield, UK
www.jmcomms.com
I'm on the same as you with 3 and can no longer tether although I can create a Hotspot and people can join, just no data......really annoying. Apart from that i like the update.

I've created a thread on the Sony Mobile forum, as I suspect this is a problem that isn't more widespread simply as people haven't tried tethering yet, or have assumed it was a network problem and maybe given up.

I am wondering if there's something going on where networks such as Three are now able to use another APN for tethering (as is now the case on iOS), but we are yet to be given the opportunity to select an APN for tethering? Or we have to add something in to the existing APN setting?
 

jonsmith709

Senior Member
Feb 8, 2010
170
30
Exeter
I think its a Lollipop issue as the Nexus devices had it. I'll try tonight with a different network sim to see if it works.
 

trjcasper

Senior Member
Jan 27, 2011
67
5
Can you post your APN?

I use T-Mobile.

Name T-Mobile Data
APN fast.t-mobile.com
Proxy not set
Port not set
Username not set
Password not set
Server not set
MMSC http://MMS.msg.eng.t-mobile. Com/MMS/wapenc
MMS proxy not set
MMS port not set
MCC 310
MNC 260
Auth type none
APN type default, supl,a-gps,MMS
APN protocol IPv4/IPv6
APN roaming protocol IPv4

When I first got my D6603 I couldn't tether. My APN protocol was set to ipv4 only. Making the change to IPv4/IPv6 fixed it.
 

bradmax57

Senior Member
Jul 9, 2009
538
32
Newcastle upon Tyne
Im in the same boat, I posted on the 5.0 thread but just to say I think its just a three problem unfortunately as I know a few people who have the handset etc and they are fine with tethering if there not on three, EE for example works fine. I guess we will have to wait for a three firmware or UK 5.0. I didn't backup my original firmware from my three handset and cant actually find a three firmware?
 

jonmorris

Senior Member
Apr 22, 2012
1,722
478
Hatfield, UK
www.jmcomms.com
Im in the same boat, I posted on the 5.0 thread but just to say I think its just a three problem unfortunately as I know a few people who have the handset etc and they are fine with tethering if there not on three, EE for example works fine. I guess we will have to wait for a three firmware or UK 5.0. I didn't backup my original firmware from my three handset and cant actually find a three firmware?

It will be dead easy to change. Just flash the new firmware over the old and don't wipe.

I am wondering whether to try and use the iOS Portable Hotspot APN that Three introduced on its new tariffs, but I don't know the exact settings. If that works, Three might be taking advantage of a new feature in Lollipop that allows it to restrict tethering, and hasn't considered (or doesn't care about) the impact on people still on the One Plan.
 

jonmorris

Senior Member
Apr 22, 2012
1,722
478
Hatfield, UK
www.jmcomms.com
On a non uk rom again I presume?

Yes, the same generic ROM.

In all my years of flashing firmwares, I've never had any such problems. Now if I'd flashed a ROM for the wrong variant and lost support for certain bands, fair enough, but data is working just fine on both the Z3 and my wife's Z2.. but tethering is broken.

If it works by the time a UK ROM is released, or specifically a Three UK one, I suspect it will only be because it has been fixed - not because there's actually a need for a specific ROM.
 

jonmorris

Senior Member
Apr 22, 2012
1,722
478
Hatfield, UK
www.jmcomms.com
As I'm sure someone will say it sooner or later, did you do a clean install or an upgrade (no wipe)?

I did an upgrade. I cannot believe for one second that will make a difference, but it would be good to know if someone has the problem who did a clean install.
 

jonsmith709

Senior Member
Feb 8, 2010
170
30
Exeter
I'm back on 4.4, I'll wait until the UK one is released to see if it makes a difference. I didn't try a different sim from another provider though, did anyone else? I do like what they have done with lollipop though and miss it already:p
 
Last edited:

runamonk99

Member
Dec 28, 2010
33
66
It stopped working for me, I found a solution to my issue and got it working. I posted the solution in the general forum.

Since updating, I've discovered that I can no longer use USB Tethering or set up a wireless hotspot.

Or should I say, I can, but neither give the other device any connectivity - even though it works fine on the phone itself.

Anyone else having problems, or can suggest a fix?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    It stopped working for me, I found a solution to my issue and got it working. I posted the solution in the general forum.

    Since updating, I've discovered that I can no longer use USB Tethering or set up a wireless hotspot.

    Or should I say, I can, but neither give the other device any connectivity - even though it works fine on the phone itself.

    Anyone else having problems, or can suggest a fix?