• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] problem with touch in lock screen in my xperia neo MT15i

Search This thread

sakib0007

New member
Aug 13, 2013
3
0
well,

With due respect, i would let all of u guys to know that i have been suffering from touch problem with xperia neo MT15i. the problem is that when i want to unlock my phone with slide lock than the touch does not response properly! i mean i need to slide the lock for several time through my thumb. is not it bothering? despite it , whenever i can manage to unlock my phone by sliding over, initially the touch does not respond smoothly! suppose, whenever i go to the apps drawer instantly after unlocking, the app or game start while i try to slide over to go to the next apps drawer! that means on which app or game my thumb touches for sliding and going in next page, my phones receives that i wanted to stat the game or app! please help me! please!!!!!!! please response my sms!!! i ardently request to all the XDA guys!!!

well, i need to add some xtra info. regarding my problem, that i have rooted my phone several times through flash tool and stock rom with locked boot loader! i have never suffered from touch problem in before! recently i have been! i also wanna mention that, the problem arose suddenly! one day i wake up from bed and my phone was behind me! so i guess that my phone display have been strongly pressured through my arm or something else!!!!!!!!!!!!!!!!! so please help me considering all the issues!!!!!!!!!!!!!! android version: ics 4.0.4,build number: 4.1.B.0.587,kernel: 2.6.32.9-perf!!!!!!!!
 

Oli0909

New member
Nov 9, 2013
3
0
Just want to say that same thing is happening to me last few weeks with same phone. Thing is, it didn't worked worse and worse, but it just worked well one day, and the other day it was terrible, and it still works equally terrible. I never rooted or flashed my phone and never sleeped on it so I think that's not the problem.

Hope you can help us..
 

sakib0007

New member
Aug 13, 2013
3
0
Just want to say that same thing is happening to me last few weeks with same phone. Thing is, it didn't worked worse and worse, but it just worked well one day, and the other day it was terrible, and it still works equally terrible. I never rooted or flashed my phone and never sleeped on it so I think that's not the problem.

Hope you can help us..

i think u are supposed to flash ur ROM using flash tool! bout for doing these u need to downolad ftf. file from the ROM section and flashtool software also! its very easy to flash ur phone!!!!! i hope problem will be solved!!!!! dont forget to back up ur files before flashing!!!!!!!
 

Samith_LK

Member
Nov 15, 2013
5
1
Same here

Hey, I'm having the same issue with my Xperia Neo (MT15i). :crying:

My phone is nearly 2 years old. I have used Gingerbread, then ICS, Jelly Bean (Rooted-Cyanagenmod). I had no issue with the touch screen earlier. Since the phone performs bit slow on advanced android versions I decided to install Gingerbread again to make it faster.

From the day I installed GB again, I'm having this issue.
  • Gotta swipe about 4 times to answer or reject a call. (Even I do press power button to off the screen, then power button again only then swipe works)
  • Swipe about 4 times to unlock the screen.
  • Try the pattern about 4 times.

I believe it's a software issue. If it's a hardware issue touch screen should not be working at all right? The thing is, it only malfunctions like that for the first 4~5 touches when the screen turned on. After that the whole touch screen works perfectly.

I was using my phone rooted for a long time without any issue. This started when I tried to flash gingerbread again in last month. I flashed another gingerbread tft, but the problem still remains.

Today I flashed the kernel to FusioN v5.5 and installed MIUI 5, still the issue is there... :confused: :confused: :confused:
 
Last edited:

sakib0007

New member
Aug 13, 2013
3
0
touch problem

Hey, I'm having the same issue with my Xperia Neo (MT15i). :crying:

My phone is nearly 2 years old. I have used Gingerbread, then ICS, Jelly Bean (Rooted-Cyanagenmod). I had no issue with the touch screen earlier. Since the phone performs bit slow on advanced android versions I decided to install Gingerbread again to make it faster.

From the day I installed GB again, I'm having this issue.
  • Gotta swipe about 4 times to answer or reject a call. (Even I do press power button to off the screen, then power button again only then swipe works)
  • Swipe about 4 times to unlock the screen.
  • Try the pattern about 4 times.

I believe it's a software issue. If it's a hardware issue touch screen should not be working at all right? The thing is, it only malfunctions like that for the first 4~5 touches when the screen turned on. After that the whole touch screen works perfectly.

I was using my phone rooted for a long time without any issue. This started when I tried to flash gingerbread again in last month. I flashed another gingerbread tft, but the problem still remains.

Today I flashed the kernel to FusioN v5.5 and installed MIUI 5, still the issue is there... :confused: :confused: :confused:


i am totally confused bro what to do!!! on a very day i went to a hardware technicians shop to solve the problem!! they said it may be hardware problem but did not say surely!!!!!!! i am looking forward a kind help from any expert of this forum!!!!!!!!!!!!!!
 

Santstoff

Senior Member
Dec 15, 2012
100
30
29
Bangalore
Hello people!

I had the same problem when 2 of my friends tried to pull the phone vigorously! -_-
I had to swipe 4-5 to get it to respond and the screen would act weird for another couple of seconds! -_-
Tried Factory Reset etc but still no use!

So I took it to the service center and they said it could be the digitizer(screen) problem but not sure, and that it would cost 4k for that! :eek:
Fortunately I had another problem with the sound setting on my phone so I gave it back to them to solve that at least. They flashed the phone with latest ftf(some GB ftf at the time) and gave back the phone saying they couldn't solve the sound issue.
BUT to my surprise/luck my screen prob was fixed! :D And I dint pay them a single pie! :p

So I think y'all should try flashing the Stock ftf, preferably ICS 4.1.B.0.587 and its Kernel :)
Here is the link - http://forum.xda-developers.com/showthread.php?t=1952333

I hope it works for y'all! All the best! :D

P.S - I'm now running Super Jelly Bean 8.0 on SuperFusionNeoKK Kernel
 
Last edited: