[Q] Random Reboots?

Search This thread

Zer0_

Senior Member
Jun 30, 2010
1,034
304
Toronto
Have you guys ever experienced your x10 randomly restarting itself? Sometimes when I'm talking on the phone or just have my phone lying on my bed, it just restarts itself. I doesn't bother me too much since it isn't that frequent, but it pisses me off when it does restarts while I am on the phone...
Does anyone know why it does this and how it can be prevented?
 

nbk1986

Member
Apr 10, 2008
16
0
Berlin
Hi shukla,

I've got exactly the same problem! Which firmware is on your phone? I've got the 026 on my X10i. I think it's the firmware or the new root method?!

If I'll find some time this week I would like to try some things out...Some other experienced that problems, too?

Regards,

Martin
 
Last edited:

urs74

Senior Member
Jun 14, 2010
451
24
London
I've had random reboots as well running 26 firmware (using the 3 step root method) thankfully never during a call last time was while in Toronto this past Saturday taking pictures with Vignette.
 

nbk1986

Member
Apr 10, 2008
16
0
Berlin
I think I was wrong with my thoughts. Today I've read a lot about our problem with rebooting. Seems it is the Sony backup application. It is randomly accessing the SIM card and thats the reason why our phones crashes. Right now I am going to flash my phone again. I'll tell you some more details after flashing is done.
 

nbk1986

Member
Apr 10, 2008
16
0
Berlin
Ok, well it's not easy to fix that problem. Yesterday I flashed my X10 about 6 times. With original SEUS firmware and the problem still appears. Then I flashed with 026 debranded firmware. After that I rooted my phone with the doshaska.net method. After that I removed the restore/backup app from /system/app. The problem still appears till now - but not so often. In fact, I had reboots every minute, so my phone didn't came up. I really don't have a clue why it happen. Someone else got an idea?

Regards ,
Martin
 

TTLExpired

Member
Feb 10, 2010
18
0
The only way I could stop mine from rebooting was to remove SetCPU. Are you using it? If so, feeze it or remove it and see how it goes. I do have another problem now with the damn screen not sleeping unless i push the power button! Oh well, the joy of fiddling :(
 
Last edited:

Gentimp

Senior Member
Aug 26, 2010
65
0
Nothing out of the usual battery dain yet. I am running the branded Dutch t- mobile firmware. I'm going to root it soon.

Sent from my X10i using XDA App
 

gitin

Senior Member
May 15, 2009
770
433
need help please

glad i found this thread

i got the same problem since yesterday, my phone just restarts or turns off during call or anytime even if the screen is off and its just lying on my bed..

and doesnt starts on pressing start button, though i do feel vibration...the only way to start is to remove battery for few seconds and then put it again

infact i am using my phone without back cover as everytime i have to remove battery

tried 24 firmware and 26 with rooting method...same problem now trying to update from SEUS...lets c how it goes,,,fingers crossed

anybody else had this problem..? if cleared please advise me wot 2 do

i was using setcpu, juice defender and was rooted by .app method, what i think this problem started after uploading Dark Luster theme

but everything gets formatted when u reflash isn't it..?

please help

thanks
 
Last edited:

gitin

Senior Member
May 15, 2009
770
433
glad i found this thread

i got the same problem since yesterday, my phone just restarts or turns off during call or anytime even if the screen is off and its just lying on my bed..

and doesnt starts on pressing start button, though i do feel vibration...the only way to start is to remove battery for few seconds and then put it again

infact i am using my phone without back cover as everytime i have to remove battery

tried 24 firmware and 26 with rooting method...same problem now trying to update from SEUS...lets c how it goes,,,fingers crossed

anybody else had this problem..? if cleared please advise me wot 2 do

i was using setcpu, juice defender and was rooted by .app method, what i think this problem started after uploading Dark Luster theme

but everything gets formatted when u reflash isn't it..?

please help

thanks
alright i found the solution myself...this post is just to help others

flashing did not solve my problem at all, through SEUS or rooting method nope the problem didn't go

finally i removed my memory card and everything was fine

some things on memory card could cause reboot during calls or randomly, next time try formatting your memory card

hope it help someone

cheers!

luv my x10 though i ve also got iphone but i ve never looked back
 

k0sun7eash3d

Senior Member
Jan 4, 2009
178
7
Bay Area, CA
Just curious, how hot is everyone's phone when it reboots? I've noticed my x10 doing the same when its running a little warm. It usually starts acting up when it's over 105 degrees Fahrenheit.

Sent from my HTC Desire using Tapatalk
 

zbyslove

Member
Jun 6, 2010
38
3
Warsaw
Gitin thx..it looks much better now, however yeasterday I was carrying my x10(still with no memory card in it) in the pocket, it got pretty hot (most probably over 38 degrees) and it turned into this rebooting "mode"..finally I left battery for 20 minutes in cold place..x10 got back to normal..I think that random reboots are the matter of memory card issue (You have solved this problem) or/and overheating of battery - still couldnt find any clue how to ease this pain but read somewhere that Froyo for x10 will have this problem taken care of..
 

peo306

Senior Member
Jul 23, 2010
334
32
paris
i think ( depends on my experiences) the telephone need to reboot coz one applications from SD card want to launch (send or receive) some commands from or to internal (built in memory).
that's means this applications needs to move temporary to internal memory just to execute this command so absolutely android system will restart to create virtual memory to this application to let it runs correctly
first it's better to remove backup/restore programs or make its runs manually, if you have another software need to save data to SD memory ,remove it.
it's better to launch applications directly from internal memory to win the time and performance but At the expense of the memory size
ps: all that explanations depend on the framework version.
sorry for complex explain but i don't have easy way to explain this problems
 

PollPixx

Senior Member
Apr 27, 2009
2,103
618
i suddenly have it now to, first every hour, now every 5 minutes, my phone won't start up anymore:confused::confused:
 

zbyslove

Member
Jun 6, 2010
38
3
Warsaw
sorry..bad news..its pretty cold here in Poland so battery shouldnt turn to hot that easily but apparently the problem is more serious..I have to admit that random reboots occur less frequently than before but that **** still hapens to my x10..after no more than 2 days I had gotten memory card removed it got back to malfunctioning again..
it really pisses me off that I cant enjoy this phone anymore..
android 2.1 or higher is my only hope..

if anybody solved that issue entirely..please, dont be shy, do not hesitate..help us, please!
 

cricka15

Member
Jan 13, 2009
29
0
sorry..bad news..its pretty cold here in Poland so battery shouldnt turn to hot that easily but apparently the problem is more serious..I have to admit that random reboots occur less frequently than before but that **** still hapens to my x10..after no more than 2 days I had gotten memory card removed it got back to malfunctioning again..
it really pisses me off that I cant enjoy this phone anymore..
android 2.1 or higher is my only hope..

if anybody solved that issue entirely..please, dont be shy, do not hesitate..help us, please!

i too am hanging on for the 2.1 update to hope it solves the problem. I've a feeling there's going to be a lot of x10s going into SE for a service though when it is released and doesn't solve the problem!

I'm not 100% but is this problem the entire phone powering down, or just the connection to your network, mine just loses its network connection and then connects again, over and over ........ :(
 

gitin

Senior Member
May 15, 2009
770
433
there's nothing 2.1 update will do

as our phone was working fine when v bought it, its completely a hardware fault

ok do this...
1.take out sim
2.format ur memory card
3.repair through SEUS or root process watever..
4.turn on ur x10 without sim and leaving formatted card inside

it will still give u hard time u can try putting some video on ur memory card and try to play it few times, ur x10 will turn off and wont turn on until u take out battery for few seconds or take ur x10 in front of Air-Conditioner

as someone suggested in rooting thread to keep ur x10 in front of air-conditioner if u get errors while rooting or if rooting process stucks in middle

the same thing applies in our case...try using ur phone in front of A-Con it wont turn off

i tried with a new battery ...still the same

as i ve been repairing mobile phone from last 5 years, i opened my x10, took out the motherboard, took out all plates over IC's, cpu and cleaned it with acetone properly and heated cpu and whole board with Hot Air Gun...everybody who repairs mobile phones knows what i am talking about

still its the same....

still i am not saying i know everything, anybody knows what the problem is and suggest the overcome is most welcome

nxt few months gonna b really cold at my place...i definitely think i'll notice a difference as its really hot these days which is causing my x10 to die
 

naplesbill

Senior Member
Jun 13, 2008
938
81
I did experience this when I debranded my AT&T X10. I have since gone back to the AT&T ROM and have not had this issue since. My battery life has also improved. I did root and remove all the AT&T bloatware. I also edited settings.db to allow for installing non-market apps. This phone is very fast and smooth now with almost no glitches at all.
 

zbyslove

Member
Jun 6, 2010
38
3
Warsaw
mine won't even work anymore..once per every 20 or 30 times and than it turns off itself very quick..I can't recharge battery, nothing..really hope that 2.1 will help somehow..I am thinking of getting back to very first soft that x10 was launched with..seriously I am sickin tired with that ****..
 

lft4ded

Senior Member
Feb 5, 2010
63
3
Greenville, SC
I did experience this when I debranded my AT&T X10. I have since gone back to the AT&T ROM and have not had this issue since. My battery life has also improved. I did root and remove all the AT&T bloatware. I also edited settings.db to allow for installing non-market apps. This phone is very fast and smooth now with almost no glitches at all.

Hi, I have an AT&T X10 and wonder what you debranded your phone to? I debranded mine about a week after I got it to R2BA026 Latin America and never had any issue with rebooting.

Aside from needing to power off the phone to check for software updates (two weeks ago of course :p) my phone has been up for +358 hours without an issue, and that's with installing the AmbientTime home screen several days ago.