[Q] Rooting Chinese Spreadtrum Phone w/ Android 4.0.3

Search This thread

H_Bler

Member
Dec 20, 2012
14
25
So,

I've bought an Samsung Galaxy S3 replica (read: fake, and i want only to root it no flash it):
Model number: S930
Android version: 4.0.3
Baseband version: DM_BASE_12A_W12.28_P1|sc8810_modem|07-13-2012 16:42:35
Kernel version: 2.6.35.7 [email protected] #3
Software version: T300_JYYS930_C3BOM_MLB_V6.6.5_20121105
Hardware version: 1.1.0
CPU: Spreadtrum

When I first plugged it my notebook (Win7 32bit) I've got in the device manager:

Other Devices
- Spreadtrum Phone
- Spreadtrum Phone
- Spreadtrum Phone


I'm trying to root it so I started my research, afts thousands of tests, I discoverd that

Other Devices
- Spreadtrum Phone >> Android Composite ADB Interface (driver instaled with Android SDK)
- Spreadtrum Phone >> SCI General U2S(AT) (COM3) (Google Search: Spreadtrum Drivers)
- Spreadtrum Phone >> SCI Vendor U2S(DIAG) (COM4) (Google Search: Spreadtrum Drivers)

So after all the yellow marks disappeard i've tried almost everything to root it:

- QQPhoneManeger for Android (which recognise the device like: Sprd S930 - allow me to access my "device root" but I can't change anything there, not even copy from it)
- UnlockRoot (which worked in my previous phone MTP65XX also an android replica)
- Odin
- PDA Net
- SparkyRoot
- Z4Root
- Poot-debug + Ministro II
- Instant-root
- Gingerbreak
- OneClickRoot
- SuperOneClick

And recently i've tried the DooMLoRD ROOT v18 - And I've only got:
adb is out of date. killing...
*daemon estarted succefully*

and nothing more, so i've went to search some more, and I've learned how to verify if adb recognise the device.
I added the C:\android-sdk\plataform-tools to my system path and tried the commands
adb devices
my answer was:
*daemon not runing. startin it now on port 5037*
*daemon started successfully*
List of devices attached:

....
Nothing, so i've tried
adb shell
my answer was:
error: device not found

So I re-checked all the drivers, unistalled and re-installed.
tried again same thing...

So now i'm stuck, all the solutions that i've fonund for the problem is now coverd

Is there any way to solve it? Or any way to root my device that isn't listed? Or any driver that's better for my device than the one in Android SDK?

Thanks in advance and sorry for the english.

UPDATE!!

Solved, yay!, view solutions below :)
 
Last edited:

H_Bler

Member
Dec 20, 2012
14
25
Thanks, but already tryied this one.

Did you tried this method http://forum.xda-developers.com/showthread.php?t=1886460 ?
Press the THANKS button if i helped :D

HOPE IT WILL WORK !! GOOD LUCK !!!

Thanks, but this one also don't work, I forgot to list it. 'cause it's similar to the DooMLoRD .bat

All i got is the *daemon started successfully* answer

rwr.png


And than when I kill the adb process in the task maneger, it resume the running, but aways returning the answer
error: device not found

What I don't get is, if the windows system recognise my Android Composite ADB Interface, why the adb don't?
 
Last edited:
  • Like
Reactions: KINGMH

H_Bler

Member
Dec 20, 2012
14
25
SOLVED!!!

I've made it. *so ****ing happy right now*

Solutions:

To - Device adb recognition.

Place Hardware ID VID_xxxx in {user home}/.android/adb_usb.ini.
Source

Subscribing the adb.exe files Download Here
Source

To - Rooting

I've used one of the previos methods i've tried

DooMLoRD ROOT v4

Thanks for the tipo karimkahale

And now i'm going to enjoy my 3 sleepless days victory. :D
 
Last edited:

sergimas

Member
Dec 24, 2012
7
3
I've made it. *so ****ing happy right now*

Solutions:

To - Device adb recognition.

Place Hardware ID VID_xxxx in {user home}/.android/adb_usb.ini.
Font

Subscribing the adb.exe files Download Here
Font

To - Rooting

I've used one of the previos methods i've tried

DooMLoRD ROOT v4

Thanks for the tipo karimkahale

And now i'm going to enjoy my 3 sleepless days victory. :D

Hi everyone, I'm having the same problem with a similar phone, a S3 replica:

Model number: Z15A
Android version: 4.0
Baseband version: DM_BASE_12A_W12.28_P1|sc8810_modem|07-13-2012 16:42:35
Kernel version: 2.6.35.7 [email protected] #3
Software version: T300_JYYS930_C3BOM_MLB_V6.6.5_20121105
Hardware version: 1.1.0
CPU: Spreadtrum

It appears in the Device Manager (Win7 64bit) as:

Other Devices
- Spreadtrum Phone
- Spreadtrum Phone
- Spreadtrum Phone

I tried installing the USB driver that comes with the Android SDK ( sdk\extras\google\usb_driver ) using "Update driver..." but it only says that Windows could not find a driver there ( maybe because of the 64bit OS? ).

I think i will try and install a Win7 32 bit somewhere just in case, but nevertheless, could you elaborate a bit the solution you found please? (mostly the driver part, as I cannot find how to get the device recognized by Windows)

Thanks in advance.
 

H_Bler

Member
Dec 20, 2012
14
25
Hi everyone, I'm having the same problem with a similar phone, a S3 replica:

Model number: Z15A
Android version: 4.0
Baseband version: DM_BASE_12A_W12.28_P1|sc8810_modem|07-13-2012 16:42:35
Kernel version: 2.6.35.7 [email protected] #3
Software version: T300_JYYS930_C3BOM_MLB_V6.6.5_20121105
Hardware version: 1.1.0
CPU: Spreadtrum

It appears in the Device Manager (Win7 64bit) as:

Other Devices
- Spreadtrum Phone
- Spreadtrum Phone
- Spreadtrum Phone

I tried installing the USB driver that comes with the Android SDK ( sdk\extras\google\usb_driver ) using "Update driver..." but it only says that Windows could not find a driver there ( maybe because of the 64bit OS? ).

I think i will try and install a Win7 32 bit somewhere just in case, but nevertheless, could you elaborate a bit the solution you found please? (mostly the driver part, as I cannot find how to get the device recognized by Windows)

Thanks in advance.

Hello,

I, don't know if the trouble is because you have win 7 64bit, but I will say how i've made it.

Windows has already intalled the device as Spreadtrum with generic drives, so any other driver that you try to install tha isn't compatible with the ones windows associated with your device will be avaliated by the system as "no compatible with your device", so what you got to do is, uninstall this generics drivers so the "spreadtrum"s will be displayed with the yellow mark, and under the "other devices" section in the device manager, then, you install manually the spreadtrum drivers that you can find in searches in two of the "spreadtrum" devices (in the drivers i've found in google searches I've got 3 different drivers General, Vendor and Modem, but i've only used General and Vendor as the other "spreadtrum" device was an ADB interface and not a modem) and the other you also install manually but with the driver in the folder "usb_driver" in "android-sdk/extras/google".

Also, when you use "update driver" follow: Search in my computer> pick in a list> have a disc , then you search in the folders of android-sdk and of the spreadtrum drivers that you downloaded.

Hope it helps.

Just one more thing, i've made it with the root access but now my Play Store don't open... it opens loads a little and then close with (the com.android.vending stopped unexpectedly...
I've tried re-instal the native apk, factory reset, everything, bout nothing works :/
I had to re install all my aps via computer with the "adb install xxxx.apk. And every other aps work normally.

Happy holidays everyone.
If anyone have a clue of what to do, i'd like to try it
 

sergimas

Member
Dec 24, 2012
7
3
Hello,

I, don't know if the trouble is because you have win 7 64bit, but I will say how i've made it.

Windows has already intalled the device as Spreadtrum with generic drives, so any other driver that you try to install tha isn't compatible with the ones windows associated with your device will be avaliated by the system as "no compatible with your device", so what you got to do is, uninstall this generics drivers so the "spreadtrum"s will be displayed with the yellow mark, and under the "other devices" section in the device manager, then, you install manually the spreadtrum drivers that you can find in searches in two of the "spreadtrum" devices (in the drivers i've found in google searches I've got 3 different drivers General, Vendor and Modem, but i've only used General and Vendor as the other "spreadtrum" device was an ADB interface and not a modem) and the other you also install manually but with the driver in the folder "usb_driver" in "android-sdk/extras/google".

Also, when you use "update driver" follow: Search in my computer> pick in a list> have a disc , then you search in the folders of android-sdk and of the spreadtrum drivers that you downloaded.

Hope it helps.

Just one more thing, i've made it with the root access but now my Play Store don't open... it opens loads a little and then close with (the com.android.vending stopped unexpectedly...
I've tried re-instal the native apk, factory reset, everything, bout nothing works :/
I had to re install all my aps via computer with the "adb install xxxx.apk. And every other aps work normally.

Happy holidays everyone.
If anyone have a clue of what to do, i'd like to try it

I got to get the drivers installed. I've got:

- Android Composite ADB Interface
- SCI General U2S(AT) (COM4)
- SCI Vendor U2S(DIAG) (COM3)

I tried some of the rooting methods you list (z4root, OneClickRoot, SuperOneClick,...) and finally DooMLoRD ROOT v18, but the problem is that my /system directory is Read-Only, so no way is anything working.

I don't kno how to proceed now (noob here :D), but I'll keep you posted if I find any solution.

Happy holidays, and good luck!
 

fakans

New member
Jun 22, 2012
1
0
s550

I have a similar replica, the s560. Should this metod work on my phone? i want to install cyanogenmod on it

this one focalprice.com/MH0369B/35_Android_40_6820_10GHz_Smartphone_with_WiFi_TV_Bluetooth.html
 
Last edited:

teewee3

Member
Sep 6, 2012
28
5
I got to get the drivers installed. I've got:

- Android Composite ADB Interface
- SCI General U2S(AT) (COM4)
- SCI Vendor U2S(DIAG) (COM3)

Hi!

I'm trying to do this myself, but I can't seem to install the drivers properly. Did you use 64-bit windows 7? And which drivers did you use?
Cause I used "SPREADTRUM SCI-USB2Serial-version-1.5.6.1" which I found via Google search, and none of the drivers I found are not digitally signed. That means they won't install properly in win 64-bit.

I only get: SCI USB2Serial (COM3) and SciCmpst Diaog (COM4), and they are both still with the yellow exclamation mark.
Anyone got a good tip for me?

Thanks in advance
 

sergimas

Member
Dec 24, 2012
7
3
Hi!

I'm trying to do this myself, but I can't seem to install the drivers properly. Did you use 64-bit windows 7? And which drivers did you use?
Cause I used "SPREADTRUM SCI-USB2Serial-version-1.5.6.1" which I found via Google search, and none of the drivers I found are not digitally signed. That means they won't install properly in win 64-bit.

I only get: SCI USB2Serial (COM3) and SciCmpst Diaog (COM4), and they are both still with the yellow exclamation mark.
Anyone got a good tip for me?

Thanks in advance

I've managed to install them on a 32-bit windows 7. Everything I tried on 64-bit just showed the yellow mark, although they where the x64 version drivers.

Regarding the rooting process, I followed this method (As I cannot post outside links yet, just Google: "Root Android 4.0 (Novo método) Atualizado x3") and it worked at last. It's written in portuguese but it's not too difficult to follow looking at the video.

I hope it helps a bit.

Now I was trying to install a custom CWM recovery, prior to install a custom ROM, but I really don't know which one should I use (nor CWM recovery nor ROM) :eek:

If someone can point me in any directions on how to continue, it would be great.

---------- Post added at 11:53 PM ---------- Previous post was at 11:46 PM ----------

Hello,

I, don't know if the trouble is because you have win 7 64bit, but I will say how i've made it.

Windows has already intalled the device as Spreadtrum with generic drives, so any other driver that you try to install tha isn't compatible with the ones windows associated with your device will be avaliated by the system as "no compatible with your device", so what you got to do is, uninstall this generics drivers so the "spreadtrum"s will be displayed with the yellow mark, and under the "other devices" section in the device manager, then, you install manually the spreadtrum drivers that you can find in searches in two of the "spreadtrum" devices (in the drivers i've found in google searches I've got 3 different drivers General, Vendor and Modem, but i've only used General and Vendor as the other "spreadtrum" device was an ADB interface and not a modem) and the other you also install manually but with the driver in the folder "usb_driver" in "android-sdk/extras/google".

Also, when you use "update driver" follow: Search in my computer> pick in a list> have a disc , then you search in the folders of android-sdk and of the spreadtrum drivers that you downloaded.

Hope it helps.

Just one more thing, i've made it with the root access but now my Play Store don't open... it opens loads a little and then close with (the com.android.vending stopped unexpectedly...
I've tried re-instal the native apk, factory reset, everything, bout nothing works :/
I had to re install all my aps via computer with the "adb install xxxx.apk. And every other aps work normally.

Happy holidays everyone.
If anyone have a clue of what to do, i'd like to try it

I guess it won't be the same, but I was having problems with my Play Store also. It did not loaded anything, just giving "Unable to connect" problems, and it was solved (momentarily) uninstalling all updates. That's going back to Android Market, though it updates itself afterwards to Play Store again. You can do it in Applicatins > Manage Applications > Google Play Store, and push the button "Uninstall updates".

As I said, i think it's not the same issue, but I just wanted to share it, just in case.
 
  • Like
Reactions: teewee3

will_power00

New member
Dec 25, 2012
2
1
Where to find the drivers?

Hello,

I, don't know if the trouble is because you have win 7 64bit, but I will say how i've made it.

Windows has already intalled the device as Spreadtrum with generic drives, so any other driver that you try to install tha isn't compatible with the ones windows associated with your device will be avaliated by the system as "no compatible with your device", so what you got to do is, uninstall this generics drivers so the "spreadtrum"s will be displayed with the yellow mark, and under the "other devices" section in the device manager, then, you install manually the spreadtrum drivers that you can find in searches in two of the "spreadtrum" devices (in the drivers i've found in google searches I've got 3 different drivers General, Vendor and Modem, but i've only used General and Vendor as the other "spreadtrum" device was an ADB interface and not a modem) and the other you also install manually but with the driver in the folder "usb_driver" in "android-sdk/extras/google".

Also, when you use "update driver" follow: Search in my computer> pick in a list> have a disc , then you search in the folders of android-sdk and of the spreadtrum drivers that you downloaded.

Hope it helps.

Just one more thing, i've made it with the root access but now my Play Store don't open... it opens loads a little and then close with (the com.android.vending stopped unexpectedly...
I've tried re-instal the native apk, factory reset, everything, bout nothing works :/
I had to re install all my aps via computer with the "adb install xxxx.apk. And every other aps work normally.

Happy holidays everyone.
If anyone have a clue of what to do, i'd like to try it

Hi, Everyone!

I also have a Spreadtrum S930 phone. My problem is I can't even locate the SCI general and the SCI vendor drivers... Can somebody post a link or tell me where to find these drivers? Sorry... absolute noob here. :) Thanks.

Will
 
  • Like
Reactions: arun356y

playvinci

New member
Dec 29, 2012
3
0
Playvinci

Is this how you added your drivers in the .ini file? Also did you have problems loading the drivers because when I installed it (win 7 64bit) it says its unsigned and said something about having a problem installing it. so that when i installed it, it looks like the picture below. would be great if you could post a pic tutorial. btw i can run my adb anywhere since i configured it for fastboot but i still cant find my device. bummer.
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    57.4 KB · Views: 1,864

sergimas

Member
Dec 24, 2012
7
3
Is this how you added your drivers in the .ini file? Also did you have problems loading the drivers because when I installed it (win 7 64bit) it says its unsigned and said something about having a problem installing it. so that when i installed it, it looks like the picture below. would be great if you could post a pic tutorial. btw i can run my adb anywhere since i configured it for fastboot but i still cant find my device. bummer.

In my case, at last I got a win 7 32bit, because I wasn't able to make it work on my 64bit.

I followed this tutorial (Google: "Root Android 4.0 (Novo método) Atualizado x3") to root it, which points to the drivers ( ge.tt/8hWh71S/v/0 ). Though this zip file has 64bit drivers, in my case they didn't work properly, I saw the same screen you post.

Regarding the .ini file, you should put only (I have that myself):

0x1782

In brief, I got the drivers, installed them on a win 7 32bit, and followed the tutorial above. Don't know which could be the problem with my 64bit system :(

I hope it helps.

Anyway, now I'm stuck with my system rooted. I don't know how to flash a CWM recovery image, nor how to flash a new ROM, because every app I tried to do it ( Mobile Odin, ROM Customizer, ROM Manager,... ) does not detect the phone, so it is unsupported and does not let me flash it :eek:.

If someone could help it would be greatly apreciated.
 

playvinci

New member
Dec 29, 2012
3
0
In my case, at last I got a win 7 32bit, because I wasn't able to make it work on my 64bit.

I followed this tutorial (Google: "Root Android 4.0 (Novo método) Atualizado x3") to root it, which points to the drivers ( ge.tt/8hWh71S/v/0 ). Though this zip file has 64bit drivers, in my case they didn't work properly, I saw the same screen you post.

Regarding the .ini file, you should put only (I have that myself):

0x1782

In brief, I got the drivers, installed them on a win 7 32bit, and followed the tutorial above. Don't know which could be the problem with my 64bit system :(

I hope it helps.

Anyway, now I'm stuck with my system rooted. I don't know how to flash a CWM recovery image, nor how to flash a new ROM, because every app I tried to do it ( Mobile Odin, ROM Customizer, ROM Manager,... ) does not detect the phone, so it is unsupported and does not let me flash it :eek:.

If someone could help it would be greatly apreciated.


Thanks Sergimas. I havent tried with a 32 bit yet. I guess I'll borrow my friend's laptop for this and see if it works. BTW... with the .ini file, when you said i should only put "0x1782", that does mean that's the only hex code i need to place on the file and delete the rest? Appreciate much for your reply.

EDIT: So i finally got my adb recognize the device and was able to list the device id however when i used the doomlord and/or he portugese root, it said it wasnt able to root it.

EDIT: Lol so yeah. I dont know what I did but i was able to root my phone using the x64 files that sergimas gave and get this, I still have the yellow icons on both spreadtrum coms (general and vendor)! I mean its freakin yellow!

(If you right click on prorperties it still would show this error) " The drivers for this device are not installed. (Code 28)
Driver is not intended for this platform.
To find a driver for this device, click Update Driver."

I think what I did was, rather than update the first spreadtrum line with google's own file via sdk, I used the composite device that came from "jungo". Then I loaded Doomlord and viola it granted me superuser access! And just when I was about to give up. Lmao.
 
Last edited:

sergimas

Member
Dec 24, 2012
7
3
Thanks Sergimas. I havent tried with a 32 bit yet. I guess I'll borrow my friend's laptop for this and see if it works. BTW... with the .ini file, when you said i should only put "0x1782", that does mean that's the only hex code i need to place on the file and delete the rest? Appreciate much for your reply.

EDIT: So i finally got my adb recognize the device and was able to list the device id however when i used the doomlord and/or he portugese root, it said it wasnt able to root it.

EDIT: Lol so yeah. I dont know what I did but i was able to root my phone using the x64 files that sergimas gave and get this, I still have the yellow icons on both spreadtrum coms (general and vendor)! I mean its freakin yellow!

(If you right click on prorperties it still would show this error) " The drivers for this device are not installed. (Code 28)
Driver is not intended for this platform.
To find a driver for this device, click Update Driver."

I think what I did was, rather than update the first spreadtrum line with google's own file via sdk, I used the composite device that came from "jungo". Then I loaded Doomlord and viola it granted me superuser access! And just when I was about to give up. Lmao.

Happy to read it, I didn't even try it with the yellow marks :laugh:
 

H_Bler

Member
Dec 20, 2012
14
25
I've managed to install them on a 32-bit windows 7. Everything I tried on 64-bit just showed the yellow mark, although they where the x64 version drivers.

Regarding the rooting process, I followed this method (As I cannot post outside links yet, just Google: "Root Android 4.0 (Novo método) Atualizado x3") and it worked at last. It's written in portuguese but it's not too difficult to follow looking at the video.

I hope it helps a bit.

Now I was trying to install a custom CWM recovery, prior to install a custom ROM, but I really don't know which one should I use (nor CWM recovery nor ROM) :eek:

If someone can point me in any directions on how to continue, it would be great.

---------- Post added at 11:53 PM ---------- Previous post was at 11:46 PM ----------



I guess it won't be the same, but I was having problems with my Play Store also. It did not loaded anything, just giving "Unable to connect" problems, and it was solved (momentarily) uninstalling all updates. That's going back to Android Market, though it updates itself afterwards to Play Store again. You can do it in Applicatins > Manage Applications > Google Play Store, and push the button "Uninstall updates".

As I said, i think it's not the same issue, but I just wanted to share it, just in case.

Thanks but as you said yourself, it's not the same issue :/

I've made some discoveries regarding the problem.

After i've got the root access i removed some system apps that i wouldn't use or that i wanted update the system app.

These are the removed apps:
- Download Provider UI
- Email
- ES File Explorer
- My Favorites
- Playtalk
- Water Locker
- Sprd Note

After that the phone bricked, i've made a forced reboot via adb, and when it came back the screen didn't stop blinking, so i've put everything back and started removing one by one, it turned out that the "Playtalk" was the one that couldn't be removed.

With the issue solved, i discoverd that my market/play store didn't work, and that i could'nt realize any download from the browser, so I re-installed everything again and did a factory reset, but it didn't work to solve the problem, after searching a lot, I noted that in my system apps there is no "dowload provider.apk" only the "download provider ui.apk" that i removed in the beginning, and i'm thinking thats the problem with browser, but I don't know if it is the same problem of the market/play store because it don't even open, when i tap the icon, the screen shows: Loading, then it closes, with the "the application stopped unexpectedly" but it don't even "wait" for me to force stop, I just get back to the app laucher screen.


So, If anyone has anything for me to try to solve the issue, it will be awesome 'cause i'm trying to solve it more than 2 weeks.

PS. I already tried to install the "download provider.apk" but every version I try i get the same two problems:
- Incompatible Shared User
or
- Older SDK.
Ps 2. Regarding the market/play store issue, i already tried to clear the data/cache and neither of them work.
 

anakngputa

New member
Jan 3, 2013
2
0
I've made it. *so ****ing happy right now*

Solutions:

To - Device adb recognition.

Place Hardware ID VID_xxxx in {user home}/.android/adb_usb.ini.
Font

Subscribing the adb.exe files Download Here
Font

To - Rooting

I've used one of the previos methods i've tried

DooMLoRD ROOT v4

Thanks for the tipo karimkahale

And now i'm going to enjoy my 3 sleepless days victory. :D

thank you for sharing the info. i have the same phone and have been trying to research on how to root it as well. i've tried my best to understand your instructions but i just can't seem to get it. would you mind doing a walk through of the whole procedure? what files/tools do i need and how do i use them? i also can't seem to download the doomlord tool, i always get an error saying that the source file is damaged. i will appreciate any help. thanks in advance.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    So,

    I've bought an Samsung Galaxy S3 replica (read: fake, and i want only to root it no flash it):
    Model number: S930
    Android version: 4.0.3
    Baseband version: DM_BASE_12A_W12.28_P1|sc8810_modem|07-13-2012 16:42:35
    Kernel version: 2.6.35.7 [email protected] #3
    Software version: T300_JYYS930_C3BOM_MLB_V6.6.5_20121105
    Hardware version: 1.1.0
    CPU: Spreadtrum

    When I first plugged it my notebook (Win7 32bit) I've got in the device manager:

    Other Devices
    - Spreadtrum Phone
    - Spreadtrum Phone
    - Spreadtrum Phone


    I'm trying to root it so I started my research, afts thousands of tests, I discoverd that

    Other Devices
    - Spreadtrum Phone >> Android Composite ADB Interface (driver instaled with Android SDK)
    - Spreadtrum Phone >> SCI General U2S(AT) (COM3) (Google Search: Spreadtrum Drivers)
    - Spreadtrum Phone >> SCI Vendor U2S(DIAG) (COM4) (Google Search: Spreadtrum Drivers)

    So after all the yellow marks disappeard i've tried almost everything to root it:

    - QQPhoneManeger for Android (which recognise the device like: Sprd S930 - allow me to access my "device root" but I can't change anything there, not even copy from it)
    - UnlockRoot (which worked in my previous phone MTP65XX also an android replica)
    - Odin
    - PDA Net
    - SparkyRoot
    - Z4Root
    - Poot-debug + Ministro II
    - Instant-root
    - Gingerbreak
    - OneClickRoot
    - SuperOneClick

    And recently i've tried the DooMLoRD ROOT v18 - And I've only got:
    adb is out of date. killing...
    *daemon estarted succefully*

    and nothing more, so i've went to search some more, and I've learned how to verify if adb recognise the device.
    I added the C:\android-sdk\plataform-tools to my system path and tried the commands
    adb devices
    my answer was:
    *daemon not runing. startin it now on port 5037*
    *daemon started successfully*
    List of devices attached:

    ....
    Nothing, so i've tried
    adb shell
    my answer was:
    error: device not found

    So I re-checked all the drivers, unistalled and re-installed.
    tried again same thing...

    So now i'm stuck, all the solutions that i've fonund for the problem is now coverd

    Is there any way to solve it? Or any way to root my device that isn't listed? Or any driver that's better for my device than the one in Android SDK?

    Thanks in advance and sorry for the english.

    UPDATE!!

    Solved, yay!, view solutions below :)
    7
    SOLVED!!!

    I've made it. *so ****ing happy right now*

    Solutions:

    To - Device adb recognition.

    Place Hardware ID VID_xxxx in {user home}/.android/adb_usb.ini.
    Source

    Subscribing the adb.exe files Download Here
    Source

    To - Rooting

    I've used one of the previos methods i've tried

    DooMLoRD ROOT v4

    Thanks for the tipo karimkahale

    And now i'm going to enjoy my 3 sleepless days victory. :D
    6
    Great!! Glad it worked!!
    But just please press the THANKS button, it's much better :D
    3
    Did you tried this method http://forum.xda-developers.com/showthread.php?t=1886460 ?
    Press the THANKS button if i helped :D

    HOPE IT WILL WORK !! GOOD LUCK !!!
    2
    thanks for highlighting the "Root Android 4.0 (Novo método) Atualizado x3") i have tried other methods but my internal Memory is Read only and they cant copy the Superuser apk and stuff .Can u please explain to me step by step the way you rooted yours because i think your phone is the same as mine .thanks in advance

    Well, I mainly followed what this post says (i'm sure you've done this, but just in case):

    1º: Download ADB Drivers (there's a link on the page, i cannot reproduce it here)
    2º: Extract everything somewhere
    3º: Connect your Android device with USB debugging mode enabled
    4º: Open your Device Manager (Control panel > Device Manager )
    5º: Right click your android device (surely there're three of them, in Other Devices as "Spreadtrum phone" ) and select "Update driver"
    6º: Select "Browse my computer for driver software". Then "Let me pick from a list of device drivers on my computer". Then "Have Disk..." and you browse till you find where you have extracted the drivers of point 1.
    7º: Click in next
    8º: The driver gets installed

    After everything has installed correctly, reboot your computer just to make sure the driver was installed and loaded correctly.

    Place Hardware ID VID_xxxx in {user home}/.android/adb_usb.ini. (Take a look at the three or four first posts of the thread, H_Bler explains this there)

    You can check if everything worked correctly with the ADB tools. In a command prompt, type "adb devices" and it should show your device and its number.

    Gaining Root:

    Download the file Root.exe (it's at the beginning of the article)

    Make sure your device is connected with USB debugging mode enabled and open Root.exe
    Everything will follow to a command prompt with a message:
    "script root
    Se a lista de devices estiver vazia, o script nao vai funcionar...
    List of devices attached
    (O seu dispositivo terá que aparecer aqui em baixo)
    Deseja ter acesso root
    [n] Deixar para depois"

    Write "s", push enter and the root process will begin...

    After all that i got my device with root. I've to say that i had this done twice (dunno what failed at first, but everything went ok the second time), and i had it rooted.

    I don't know what more to say, that's everything I did, I hope it works for you.