• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] S3 No USB OTG Connectivity after update on Stock 4.1.2

Search This thread
Hi can anyone Help me. I've got big issues with my S3 Runing the latest Samsung Firmware (JB 4.1.2; Germany DBT) which i flashed via Odin.
The Device is rooted and recognizes the OTG Cable no more, but the cable works. I tried it on my Fathers S3 with the same Firmware but without root. By the Way its the Samsung Original OTG-Cable. I Also tried other OTG-Cables on both devices. Same result.
My S3 is charging over USB and is recognized as mass storage (MTP mode) when connected to PC,so i don't think its a Hardware problem.
I rooted with CF-Root SGS3 6.4. But there must be something wrong, because CWM manager brought an error message and disabled the Backup/restore options. So i rooted again via Odin, but without a change, Problem with CWM-Manager and OTG still exist.
Then i rooted with CF Auto Root via Odin,but the stock recovery brought no change at all. CWM-Manager was Gone and OTG-cable is still not recognized.
Next step was to the Flash the Stock ROM 4.1.2 again via Odin. After that, root was completely gone, but the OTG wasn't still recognized.
So i decided to Downgrade to 4.0.4 Stock Rom again and Flashed it with Odin.But my S3 wouldn't even boot now.It hung at the Samsung Boot logo and did do nothing more. Then i booted to Recovery mode, did a Cache wipe and Rebooted. It still hung at the boot logo.
Then i tried to Flash JB 4.1.2 Stock Rom again (surely via Odin). There was partly succes. My S3 Booted again normally (no Root and still no OTG-Cable recognition). I rooted again with CF-AutoRoot so i can use my apps which need root access. But i still can't get the OTG connectivity to work.
Everything on this device is working fine on 4.1.2 except that OTG-connector issue.
I'm currently making a backup with Titanium Backup. After that i try a Factory Reset (Hard Reset) If that doesn't work i'm totally at the end with my nerves and go to a Hosiptal.

Why the hell does this not work?? I can't imagine what reason there should be.

Please can anyone help me:crying::crying:
 
Thanks for the Information, but not really helpful. I want to use the Samsung Stock Rom 4.1.2 without branding and root. And OTG don't work no more. I tried my cable on different I9300 fom colleagues Today running 4.1.2 Stock Rom (all without Root) It works perfectly on their devices. In the evening today i try a Hard Reset and hopefully my 4.0.4 Rom shows up. Then i'll upgrade OTA and root again with Autoroot. We'll see what happens.

Edit: Update:

Now i did a Full Wipe/ Factory reset. Downgraded to 4.1.1 then to 4.0.4 and back again.Made some wipes between the Firmware installations with Odin and tried my cable again. Still no USB OTG connectivity with neither of my two cables. So at the End it seems really to be a Hardware problem, although Charging, and MTP mode are doing well.
At last i will send the device back to my vendor to get it repaired in Guarantee.

Sent from my GT-I9300 using xda app-developers app
 
Last edited: