• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] SD Card Won't Mount

Search This thread

TyWillems19

Member
Oct 29, 2012
46
27
Hey so I've been trying to find a solution to this problem for a while now and I can't seem to find anything to fix it.

So I went to format my SD card through my phone (I am running Liquid's ICS rom atm). I went into settings > storage > erase sd card, and followed through on everything. After I accepted that my stuff would be lost I got a notification saying the SD Card is safe to remove, and in storage it gives me the option to Mount the SD Card.

However, when I press mount it acts like it is mounting for like half a second then quickly just says it is safe to remove and the mount button is clickable again. No matter how many times I click it, it will just do the same thing.

I tried booting into recovery and mounting it through there and formatting it and other nonsense and it just says error mounting sd card.

I have also taken out my battery and sd card and left it for like 10 minutes and tried again. Still nothing.

The only thing I haven't tried doing yet is putting it into a computer to manually format it that way, but I don't have a device to be able to do that at the moment so I am looking for a way to solve this without having to drive 23 miles to the nearest electronics store to fix this.

I don't think my SD card is corrupt, I mean it was working perfectly (it is a 32gb card from Verizon when I got the TB) and it just started doing this after I tried to format it through the ROM.

Any ideas?


EDIT:

HEY! So holy **** I had a little bit of a moment there. Anyway, I solved the problem on my own. So what I did was boot into recovery, and partition the SD Card under the Advance option. I just did the first setting for each so my operation was like this: Recovery > Advance > Partition SD Card > (Power button for whatever the first option was until it started partitioning).

After that I tried mounting the SD card and it didn't give me an error. So I went into the recovery settings to format the sd card (still in CWM recovery) and after it formatted I booted up and sure enough to worked!

So this thread can be deleted or locked or whatever. Other people may run into this problem and this worked for me so yea.

Thanks for the thread space lol
 
Last edited: