[Q] Sending sms bug

Search This thread

noidee

New member
Oct 21, 2011
4
2
Since many users of Samsung Galaxy S Plus had similar problems i decided to open a new topic.

Short description:

Sometimes when i try to send an sms which has more than 160 characters i receive a notification with "Message not send".

The problem seems to be only when Network Mode is set on WCDMA (or Auto).

Firmware: 2.3.3
Baseband: I9001XXKF8
Network: Orange Romania

Solutions

1) Update to Android 2.3.5+
or
2) Set Network Mode GSM
 
Last edited:
  • Like
Reactions: yac00b and micmaccc

crisdorya

Senior Member
Jan 30, 2011
110
45
I have no idea why that would happen, I am starting to believe that Samsung has a poor radio in the i9001. Can you confirm the same in other messaging apps?
I would love to try but I have no SMSs in my plan, Vodafone -.-
 

noidee

New member
Oct 21, 2011
4
2
I have no idea why that would happen, I am starting to believe that Samsung has a poor radio in the i9001. Can you confirm the same in other messaging apps?
I would love to try but I have no SMSs in my plan, Vodafone -.-


I don't think that this bug is related to bad network coverage because first 160 characters are send. I tried sending sms from another network operator (Vodafone Romania), but i had the same results.

Bug also occurs using handcent app.
 

mal13

Senior Member
Jan 9, 2010
502
69
Lots of people have complained about that same bug here in finland. Different operators. Seems software bug.
2.3.3 to be exact. I never had that problem but i have flashed to 2.3.4.
 

Unequal77

Senior Member
Apr 27, 2010
86
14
Belgrade
I have had that bug in a 2.3.3 and now in a 2.3.4. It is not happening all the time, but it is present. In a 3G mode of course, in 2G everything is all right.
 

yogi_best

Member
Jan 27, 2011
38
6
34
Cracow
www.forum.android.com.pl
Eh. This is really stupid.
Software bugs in such an old phone ( for samsung since its close to Galaxy S)
I would understand this bugs at S II but here? .. hOpe we can fix it.

I got this error with internet turned complety off also..
 

mal13

Senior Member
Jan 9, 2010
502
69
Some people have realised this probleem seems to be related to phone switching between 2g & 3g. As i don't have this problem...could someone try switching 3g off and then try to send longer sms.
Is this problem related to only android's message program as there's other in market..are they working better??
 

Mikolak28

Member
Sep 17, 2009
42
2
It's been already established that 3G is causing the problem, but switching 3G off everytime you want to send a text is just plain stupid.
 

noidee

New member
Oct 21, 2011
4
2
Some people have realised this probleem seems to be related to phone switching between 2g & 3g. As i don't have this problem...could someone try switching 3g off and then try to send longer sms.
Is this problem related to only android's message program as there's other in market..are they working better??

What baseband do you have?
 

ZappBrannigan

Member
Nov 4, 2008
17
3
Same bug for many users in germany!

Hi!

I'm from germany and here are MANY people having this problem! (for those who speak german: Take a look at the I9000 or I9001 board at "Android-hilfe.de"). There where many, many, many suppostiions why this happens. The only fact that everybody had is that it only happens in "automatic" and "only WCDMA" mode. It NEVER happens in GSM-only! I thougt it was a german-only bug, as it wasn't mentioned here on this board. I helped myself by closing the data network mode (long press at power button) before sending a SMS. I hope sometime a firmware update will fix it!?!
 

sosodemi

Senior Member
Dec 9, 2011
213
66
someware
the sms bug is not

The sms bug(2.3.3) is not a network problem,it is that it converts sms that is over 100 or so caracters ,to mms... and yes 2.3.5 it is sms bug free :)

ps.heloo,new on forum.:)
 

cjason

Senior Member
Feb 2, 2010
77
12
One might try switching following option from "Warning" to "Restricted"
Messaging -> Settings -> (MMS Settings) Creation mode

In theory, this should prohibit MMS creation and add another SMS body instead no matter which network type (2G or 3G) is selected.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Since many users of Samsung Galaxy S Plus had similar problems i decided to open a new topic.

    Short description:

    Sometimes when i try to send an sms which has more than 160 characters i receive a notification with "Message not send".

    The problem seems to be only when Network Mode is set on WCDMA (or Auto).

    Firmware: 2.3.3
    Baseband: I9001XXKF8
    Network: Orange Romania

    Solutions

    1) Update to Android 2.3.5+
    or
    2) Set Network Mode GSM
    1
    Since many users of Samsung Galaxy S Plus had similar problems i decided to open a new topic.

    Short description:

    Sometimes when i try to send an sms which has more than 160 characters i receive a notification with "Message not send".

    The problem seems to be only when Network Mode is set on WCDMA (or Auto).

    Firmware: 2.3.3
    Baseband: I9001XXKF8
    Network: Orange Romania

    Solutions

    1) Update to Android 2.3.5+
    or
    2) Set Network Mode GSM

    I couldnt send messages at all, solved it:

    To reinstall the provider config. message:
    - open the messages app
    - hit menu button on phone
    - go to configurationmessages
    - reinstall the MMS config message from your provider
    send a test sms to yourself or a contact