• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Signal lost after hours of running on N4 - Stock 4.4.4

Search This thread

lonaysta

Member
Jan 29, 2013
19
1
Hi there, I'm kind of desperate because of this problem my Nexus 4 has been experiencing since I received this unit early September. It is a refurbished unit given by Google Play as replacement, and now the warranty has expired (yeah, Sep 16th).

My phone is running stock 4.4.4. It has never been rooted or bootloader unlocked, so pretty "stock" one. I have been using it in similar ways I used the previous Nexus 4 for around one year, but this loses signal after around one day of normal use every time. Then I'll have to reboot it to get the signal back.
I'm on at&t network with the same SIM card that worked flawlessly with my previous Nexus 4(the one sent back to Google because of physical damage). The signal loss is a "all of a sudden" thing, I didn't find any pattern on the occurrence; not after a specific app was run. Usually I leave the phone there for hours (maybe during work or sleep) and then when I pick it up I see signal is lost. I tried running in Safe Mode, even did a complete factory reset. Nothing worked.
When the signal is lost, WiFi and Bluetooth continue to work normally. I can enter the Airplane Mode, but when I want to exit from the long-press-power-button menu, the "airplane mode" option will be grayed. However I can do that in the Settings menu's "airplane mode" check box.

Any clues or suggestions on solving this issue is highly welcomed and appreciated!