[Q] Signal Lost with Screen Sleep

Search This thread

BruceWayne133

Member
Mar 23, 2011
40
2
0
Mississauga
So first a little bit about my phone:

It's a GSM Galaxy Nexus on Telus in Canada. It's rooted and running AOKP M4. I had just flashed Franco Kernel M2, but that's when my trouble started to I just wiped my data, reflashed AOKP M4 and restored from a back-up from before I flashed that kernel. I've never flashed a new radio.

The problem is as follows: when the screen goes to sleep, I lose signal altogether. I don't receive calls, I don't receive texts, nothing. But as soon as I wake the screen, the signal comes back (and it's strong - 3 or 4 bars so it's not a service issue).

Has anybody else had a similar problem? What's the fix?

Any help would be appreciated...thanks!
 

warhummer

Member
Sep 20, 2008
24
4
0
Southern MD
------------UPDATE--------------
Confirmed that I had no issues after flashing back to 4.0.2 stock. Went back to stock 4.0.4 and the problem surfaced again. Tried B29 of AOKP and utilized a minimum CPU setting of 700 MHz which resulted in no issues with the phone signal after going to sleep. I was able to duplicate the problem when I set the CPU to a minimum of 350 MHz. Went back to 700 MHz minimum and everything is working fine.

I'm wondering if the stock 4.0.4, in an effort to squeeze more battery life, lets the processor speed dip down below the threshold require to keep the phone "listening".


-------------------------------------
I've had the same issue after upgrading my phone to 4.0.4. It started life as a 4.0.2 GSM GNex with the Samsung ICS build on it. I flashed the Google version, then manually updated to 4.0.4. I've been searching the forums and found quite a few people with the same problem, but no real solution yet. I'm going to try a few things before taking a swag at a new radio.
 
Last edited:
  • Like
Reactions: littmanr

memoreks

Senior Member
Apr 5, 2007
51
17
0
King's Lynn
I have the exact same problem

I have a GSM Samsung Galaxy Nexus on Vodafone, and within about 2 minutes of the screen sleeping, it loses connection to the network. When awakened, it will re-establish the connection within 5 seconds or so, but it is intensely irritating as I have missed lots of phone calls with this bug.

It has occurred on both my 4.0.2 patched to 4.0.4 and a clean install of 4.0.4 from google's website

I am about to revert back to 4.0.2, but if anyone can fix it in the meantime I would be eternally grateful.

-------------------------------- UPDATE ---------------------------------------------
I concur with warhummer. After rooting my Nexus again after the 4.0.4 update, and installing CPU Tuner from the Market place, I increased the minimum CPU speed to 700mhz (up from 350mhz) and it appears to be keeping its signal now. This would also tally with the fact that while my Nexus was doing things in the background it would maintain signal, but as soon as it was idle, within a few minutes the signal would die.
--------------------------------------------------------------------------------------
 
Last edited:

warhummer

Member
Sep 20, 2008
24
4
0
Southern MD
I have a GSM Samsung Galaxy Nexus on Vodafone, and within about 2 minutes of the screen sleeping, it loses connection to the network. When awakened, it will re-establish the connection within 5 seconds or so, but it is intensely irritating as I have missed lots of phone calls with this bug.

It has occurred on both my 4.0.2 patched to 4.0.4 and a clean install of 4.0.4 from google's website

I am about to revert back to 4.0.2, but if anyone can fix it in the meantime I would be eternally grateful.
I've confirmed a fix (for myself anyways) that if you can get a CPU app that can modify the processor speed, try that via the stock 4.0.4. I'm going to flash mine now.
 

mephissto

Member
Mar 6, 2010
36
3
0
Clermont-Fd
I have the exact same problem. I was on a Rom stock 4.0.2 with root, and after flashing the OTA, I had the problem when the screen is off.

To be sure I flashed the factory image in 4.0.4 but I still had the problem.

I looked at logcat and I had this error that seems to be the problem:

Code:
03-30 15:58:16.639 E/ConnectivityService(  186): Exception trying to remove a route: java.lang.IllegalStateException: Unable to communicate with native dameon to add routes - com.android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet0 default 10.114.222.1 32 0.0.0.0} failed with code 400 : {Failed to remove route from default table (No such process)}
03-30 15:58:16.639 E/ConnectivityService(  186): Exception trying to remove a route: java.lang.IllegalStateException: Unable to communicate with native dameon to add routes - com.android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet0 default 0.0.0.0 0 10.114.222.1} failed with code 400 : {Failed to remove route from default table (No such process)}

I'm going to send my phone to repair and hope they change it, or if someone has a solution.

Right now I flashed the 4.0.2 factory image to be able to use my phone.

PS : maybe someone know how to contact a Google dev ? To report the problem to them ?
 
  • Like
Reactions: memoreks

memoreks

Senior Member
Apr 5, 2007
51
17
0
King's Lynn
SetCPU fixes it

How to sort out the problem of losing signal when GNexus goes into Standby:

1. Install 4.0.4 Stock ROM

Either use the OTA patch or do a clean 4.0.4 install from the Google Stock ROMs page.

2. Root your GNexus
There's lots of info about rooting you GNexus. I used CWM to root mine.

3. Install SetCPU

4. Run SetCPU, and raise the minimum CPU speed from 350mhz to 700mhz. Then tick "Set on Boot". (see attachment)

This should now mean your phone functions perfectly well again, and you benefit from the other good stuff in 4.0.4.
 

Attachments

  • Screenshot_2012-04-01-16-42-00.jpg
    Screenshot_2012-04-01-16-42-00.jpg
    18.7 KB · Views: 1,009
  • Like
Reactions: mephissto

mephissto

Member
Mar 6, 2010
36
3
0
Clermont-Fd
Thank you for the solution, but I don't want to achieve it that way :D for me there is a real problem with probably a hardware piece or something.

I contacted Jean-Baptiste Queru on Twitter, and he said that he will see who can talk to for this.

In the meantime, my Galaxy Nexus is going for repair in the hope I will have a brand new one :)
 
  • Like
Reactions: imfloflo

ceejay83

Senior Member
Feb 21, 2011
2,858
874
0
Los Angeles
Thank you for the solution, but I don't want to achieve it that way :D for me there is a real problem with probably a hardware piece or something.

I contacted Jean-Baptiste Queru on Twitter, and he said that he will see who can talk to for this.

In the meantime, my Galaxy Nexus is going for repair in the hope I will have a brand new one :)

i'm having this problem too. but would it be a hardware problem? i don't remember this happening in 4.0.3. you might just be returning it for another phone with the same problem if you update to 4.0.4
 

mephissto

Member
Mar 6, 2010
36
3
0
Clermont-Fd
It might be a harware problem caused by a some code that was not in Android 4.0.2

I tried CyanogenMod 9 which is on Android 4.0.4 (same bootloader and radio as stock 4.0.4) but AOSP and I had the same issue.

It's really stranged because there are not a lot of people that have this issue.

Let's hope we will have news from Google soon
 

krex

Senior Member
Mar 12, 2007
213
13
0
It might be a harware problem caused by a some code that was not in Android 4.0.2
....
It's really stranged because there are not a lot of people that have this issue.

Let's hope we will have news from Google soon

I also have exactly the same errors in logcat.

Sent from Galaxy Nexus
 

nicholasbgr

Senior Member
Jun 29, 2010
213
19
0
Found your thread on google code. This is what I posted there:

I have a similar issue. My phone doesn't lose signal for good, it just drops and comes back on 5 seconds later and this loop keeps repeating with random times between drops(1 minute intervals most of the time). It started right after updating to 4.0.4. I installed an app to help track when signal drops, I attached and screen of the app. I also tested with AOKP build 28 based on 4.0.3 and the problem was still there. I will test a 4.0.2 build soon.
 

Attachments

  • Screenshot_2012-03-30-20-04-49.jpg
    Screenshot_2012-03-30-20-04-49.jpg
    31.3 KB · Views: 316
  • Screenshot_2012-04-01-19-24-29.jpg
    Screenshot_2012-04-01-19-24-29.jpg
    30.6 KB · Views: 278

neotekz

Senior Member
Oct 7, 2007
1,415
170
0
Ottawa
does it only happen in a weak 3g area? i noticed my phone having signal problems after updating to 4.0.4 too. In the secret menu, *#*#4636*#*# the preferred network type is set and stuck to wcdma preferred and if you are like me and are in a weak 3g area the phone will still prefer a weak 3g to a strong 2g signal. it prefers 3g so much that it will still hold on to it for hours even when the signal is too weak to make or receive calls. With 4.0.2 it was set to gsm/cdma prl which prefers a strong 2g but will switch when there is a strong 3g signal. unfortunately you cannot change this setting in 4.0.4.

i tried ugkl1, ugla4,, xxla2 and now using uglc1. they all had similar signal strength and will hang on to a weak 3g, so i dont think the radio is at fault here. an option for those running aokp is to go into the power saver settings and you can set your phone to go to 2g when the screen is off.
 
Last edited:

quietriot84

Member
Nov 22, 2009
19
4
0
Phoenix
I have been having this issue since 4.0.3 on my GSM Nexus. I have tried multiple radio's and multiple kernels. I was having to change the min cpu to 700mhz. I tried FuGuMod's Kernel and it seems to have fixed my signal issues. I am able to keep the min cpu at 350mhz. If you search the thread he explains what he thought was causing the issue. Once he disabled that feature in the kernel my signal issues went away.

http://forum.xda-developers.com/showthread.php?t=1438417

I think its a mix between software and hardware issues. There is some software setting that the hardware doesnt like. But since this doesnt happen to everyone running a certain kernel and only some people there must have been a bad batch of hardware from samsung.

I think I am going to try a warranty exchange with Samsung.
 
  • Like
Reactions: eezdva

memoreks

Senior Member
Apr 5, 2007
51
17
0
King's Lynn
For me at least, it is occurring in both 2G and 3G areas. I have tested it in both, and also in strong and weak reception areas.

Memoreks

Sent from my Galaxy Nexus using xda premium
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Better Test & Easy Fix (req. root)

    I've found a much better way to identify the signal drop issue and I've also found an app that will run a script at boot to disable the auto voltage setting. My phone has been rock solid in testing all day. The fix requires root access (just like the command line method) so it may not be for everyone - but if you've got an unlocked bootloader you might as well give this a try.


    Easy Test For Issue

    The quickest way to see if you have the issue is to do the following with the phone unplugged from charger or computer:

    1. (Optional, but recommended) Install "No Signal Alert" from the Market.
    2. Disable wifi.
    3. Disable mobile data (Settings->Data Usage->Mobile Data OFF).
    4. Set your display timeout to 30 seconds.
    5. Reboot your phone.
    7. Wait for you display to go to sleep (30 seconds after boot).
    8. If you installed No Signal Alert you should hear a beep within the next 30 seconds, otherwise wait 30 seconds, power on your screen to check your signal. If you have the issue you will see your signal has dropped. With No Signal Alert installed, if I manually turn off the display my phone will beep within 5 seconds because I've lost signal.

    It would be interesting to get feedback from people on 4.0.4 who aren't seeing the issue. Wonder if a few begin to see it by following the above steps.

    Disabling data seems to accelerate the issue - presumably because the radio is not being used to send data so it goes to sleep much quicker...

    Easy Fix For Issue

    This will require you have superuser.apk installed.

    1. Unzip the attached script (radiosaver.sh) to /sdcard on your phone.
    2. Download and run "Script Manager" from the Market.
    3. From within Script Manager, click on radiosaver.sh file in /sdcard.
    4. Click the Su and Boot icons to grant superuser and run at boot (see attached).
    5. Click Save, exit the app and reboot your phone.
    6. Upon reboot the app will request superuser permissions, click yes.

    If everything was done properly then run through the test above and you should still have signal. Don't forget to re-enable data & wife when you're done ;-)

    The attached script just contains the following command to disable auto voltage as suggested earlier in this thread:

    echo 0 > /sys/kernel/debug/smartreflex/sr_core/autocomp

    Like I said, for me it didn't matter what radio I was on or what ROM, if I'm running 4.0.4 it would just fail. Also, I also tried a SIM from Wind (different provider) and it also failed.

    Hope this helps at least preserve battery life for those who were using the SetCPU fix. Good luck!
    4
    Imho the problem is the root itself. Phones without root does not have this problem.
    Not only is that comment utterly untrue, but your opinion is not based on any testing or research.

    If you had done any testing you would quickly realize your theory was unsubstantiated.

    If you had read thought the official Google support thread you would have seen the problem was reported by unrooted users who were pushed the update by Google.

    Root access does not affect the kernel but simply allows greater permissions - you would know this if you understood how the superuser.apk works. Granted, a root user who is running setCPU or some other non-stock kernel modifications could have issues - but this is not the case here.

    I have personally re-imaged my device DOZENS of times trying to resolve the issue - using official factory (4.0.1, 4.0.2, 4.0.4) images and radios and upgrading by "official" and forced means.

    Making uninformed comments are not just a waste of everyone's time but insulting to those that invest their own time and effort trying to figure out solutions for everyone's benefit.


    Sent from my Galaxy Nexus using xda premium
    3
    I tried the other recommended fix, namely to root the phone and then use adb to change the following kernel variable from 1 to 0, i.e.,

    su
    cd /sys/kernel/debug/smartreflex/sr_core
    echo 0 > autocomp

    Contrary to what an earlier post may have implied, this doesn't require using a custom kernel. I've done this with the stock kernel in 4.0.4, and since then the signal hasn't been dropped. I'm guessing this setting will be lost after reboot, so a more permanent way to set this is needed. I don't know the impact on battery consumption yet.

    J
    3
    @neotekz : I'm not in a weak 3G signal, and I still have the issue.

    Someone on the Google code thread said that the issue disappeared when he flashed uikl3 radio. If someone want to try, as I can't do it myself right now :/

    This was the first thing i tried since I'm from Brazil and UIKKL3 is the brazilian radio and it didn't fix it for me.
    What I find curious is that the issue is a little different on my phone, the signal doesn't dies for good, it just becomes intermittent.
    Setting the minimum clock to 700mhz did seem to "fix" it for me but I'm afraid the battery hit wont be gentle.


    I have been having this issue since 4.0.3 on my GSM Nexus. I have tried multiple radio's and multiple kernels. I was having to change the min cpu to 700mhz. I tried FuGuMod's Kernel and it seems to have fixed my signal issues. I am able to keep the min cpu at 350mhz. If you search the thread he explains what he thought was causing the issue. Once he disabled that feature in the kernel my signal issues went away.

    http://forum.xda-developers.com/showthread.php?t=1438417

    I think its a mix between software and hardware issues. There is some software setting that the hardware doesnt like. But since this doesnt happen to everyone running a certain kernel and only some people there must have been a bad batch of hardware from samsung.

    I think I am going to try a warranty exchange with Samsung.
    Here's what I found about the feature he advises to turn off (Smart Reflex)

    Smart Reflex

    The variations in the silicon manufacturing processes are responsible for the difference in performance and/or power consumption of the device. Adaptive Voltage Scaling- AVS, implemented with SmartReflex(TM) technology, tends to narrow this difference.

    Dedicated SmartReflex hardware implements a feedback loop - without processor intervention - which optimizes the voltage levels to account for differences in the manufacturing process, temperature and silicon degradation.
    To enable smart reflex

    # echo 1 > /debug/voltage/vdd_core/smartreflex/autocomp
    # echo 1 > /debug/voltage/vdd_mpu/smartreflex/autocomp

    To disable smart reflex

    # echo 0 > /debug/voltage/vdd_core/smartreflex/autocomp
    # echo 0 > /debug/voltage/vdd_mpu/smartreflex/autocomp


    Impact on Power Consuption on Android System

    This feature is hardware controlled after initialization. Initialization is done from the kernel. Android Power management is completely unaware of smart reflex.

    Power consumption is reduced since the operating voltage is lowered for each operating point in which the device is operating in.
    To minimize the power consumption in runtime

    The maximum power reduction in runtime is achieved when “enable_off_mode”, “sleep_while_idle”and “smart reflex” options are enabled and dvfs option is set to “power save”.

    To minimize the power consumption in suspend

    The maximum power reduction in suspend is achieved when “enable_off_mode”, “sleep_while_idle”and “smart reflex” options are enabled and UART console timeouts are set.

    Please check the power consumption analysis at http://processors.wiki.ti.com/index.php/Android_Benchmarks_DevKit2.3.4v2.1#Power_Management

    http://processors.wiki.ti.com/index...d-2.3.4-DevKit-2.1_PortingGuides#Smart_Reflex
    1
    I have the exact same problem. I was on a Rom stock 4.0.2 with root, and after flashing the OTA, I had the problem when the screen is off.

    To be sure I flashed the factory image in 4.0.4 but I still had the problem.

    I looked at logcat and I had this error that seems to be the problem:

    Code:
    03-30 15:58:16.639 E/ConnectivityService(  186): Exception trying to remove a route: java.lang.IllegalStateException: Unable to communicate with native dameon to add routes - com.android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet0 default 10.114.222.1 32 0.0.0.0} failed with code 400 : {Failed to remove route from default table (No such process)}
    03-30 15:58:16.639 E/ConnectivityService(  186): Exception trying to remove a route: java.lang.IllegalStateException: Unable to communicate with native dameon to add routes - com.android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet0 default 0.0.0.0 0 10.114.222.1} failed with code 400 : {Failed to remove route from default table (No such process)}

    I'm going to send my phone to repair and hope they change it, or if someone has a solution.

    Right now I flashed the 4.0.2 factory image to be able to use my phone.

    PS : maybe someone know how to contact a Google dev ? To report the problem to them ?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone