[Q] Skullcandy 50/50 Earbuds w/ Microphone and Sprint HTC Hero

Search This thread

eXplicit815

Senior Member
Jan 10, 2008
2,577
1,230
0
Apopka, FL
So, I've searched all over, and I can't find anyone who's had this problem, so I don't know if it's just my set up or what.

I got a set of $50 Skullcandy 50/50's for Christmas from my fiancee, and they're not fully functioning on my Hero. When I plug them in, I get the indicator that shows the headphones with microphone on the top of my screen, but the only thing that works is the sound. I can hang up and switch lines with the button on the microphone, but the volume up/down won't work, and the microphone does not push sound through. When I push the volume up/down buttons on my headset, I can hear clicking on the other end of the call though.

Now keep in mind, I've tried these earbuds on a couple different phones, and they work just as they should. They worked on an iPhone 4 and a Droid Incredible.

Is there something I'm missing, or a fix that someone has found to resolve this? I even went as far has having my phone replaced, and it does the same thing.



Thanks in advance.
 
Last edited:

MrDowntown12

Senior Member
May 22, 2010
516
187
73
I have the same problem with some scosche headphones. They change the volume skip tracks, answer and hangup, and I can hear people on the other end. Problem is they cant hear me. Mic won't function. And it only happens on the hero.

As far as I can tell, the hero is just finicky and doesn't like certain headphones/mics. doesn't matter what rom or kernel you use.

I just gave up on it.
 

eXplicit815

Senior Member
Jan 10, 2008
2,577
1,230
0
Apopka, FL
Yeah, it's kind of irritating because I spent so much money on them. I'll just wait it out until I get a new phone. I just can't figure out how it won't work on this phone, but it shows like it should. It's just blowing my mind right now.
 

LuvKnuckle

Member
Nov 21, 2010
7
1
0
schofield
I have 3 different pairs of skullcandy headphones 2 pair of the smokin buds and a pair of lowriders and I havent had that problem with any of them on my hero...I have an Alltel hero and I switch Roms 2-3 times a week. The only thing i can think of suggesting right now is to plug in the headset with the phone off and power it up with them still connected.

Found something that may help..but I cant post links so go to your webbrowser and type in code.google.com/p/toggleheadset/ and download the widget. Hope this helps.
 
Last edited:

eXplicit815

Senior Member
Jan 10, 2008
2,577
1,230
0
Apopka, FL
I have 3 different pairs of skullcandy headphones 2 pair of the smokin buds and a pair of lowriders and I havent had that problem with any of them on my hero...I have an Alltel hero and I switch Roms 2-3 times a week. The only thing i can think of suggesting right now is to plug in the headset with the phone off and power it up with them still connected.

Found something that may help..but I cant post links so go to your webbrowser and type in code.google.com/p/toggleheadset/ and download the widget. Hope this helps.

The widget didn't help :-(