[Q] Snowy Screen (LCD/Touch working)

Search This thread

Flubba

New member
Jan 23, 2014
4
1
Hi guys

First of all: SORRY FOR MY BAD ENGLISH...

As you can see in the title, my Nexus 5 (16 GB) is showing a snowy screen all the time. When i turn it on, the display lights up and the phone probably boots. After the while the display is dimming and then turns off (probably lockscreen...). I managed to slide my finger from a corner to the middle, so that i can say the touchscreen is working.

First I thought the screen was defect, so I ordered a new LCD screen. After replacing the old by the new screen I had to see, thats its not the LCD/touch/display what is defect.

So does anybody had the same problem or can tell me what this might be. I'm not even sure if it's the hardware or maybe the software of the phone. But due to the "process I described in the beginning" when I turn it on, I suggest it's the hardware.

If have no idea what happened to the phone and why it isn't working. (I bought it on the internet as a defect device)

I would be very thankful for any answers.


IMAGE: the "NEXUS 5" on the image is a screen protector!!!
 

Attachments

  • IMG-20140120-WA0001.jpg
    IMG-20140120-WA0001.jpg
    249.9 KB · Views: 1,157

OuncE718

Senior Member
Feb 27, 2010
2,219
361
33
DC by way of BK
When you bought it did they say what kind of damage it had? Like was it water damage? If its water damage then I'd take it apart and clean the board. The board can be corroded due to water dame and/or possibly the ribbon connectors that attach to the screen.

sent from my neXus 5
 
Last edited:

Flubba

New member
Jan 23, 2014
4
1
When you bought it did they say what kind of damage it had? Like was it water damage? If its water damage then I'd take it apart and clean the board. The board can be corroded due to water dame and/or possibly the ribbon connectors that attach to the screen.

sent from my neXus 5

no,... I asked, but got no answer. When connecting the new screen I could see the inside, for me (I have no experiences with that) I looked quite good ;)

I also checked all the connections.
 

OuncE718

Senior Member
Feb 27, 2010
2,219
361
33
DC by way of BK
no,... I asked, but got no answer. When connecting the new screen I could see the inside, for me (I have no experiences with that) I looked quite good ;)

I also checked all the connections.

I'd probably take it back apart and clean it with a soft toothbrush and some rubbing alcohol. REMOVE the battery before you clean it or you will be sorry. Then thoroughly dry it with a blow dryer (make sure it isn't set on hot. Warm or cool is fine).

To me it sounds more like a hardware defect rather than a software defect.

sent from my neXus 5

---------- Post added at 04:06 PM ---------- Previous post was at 03:52 PM ----------

Also did you try getting it into BOOTLOADER Mode? The only software defect I can think of is the person flashing a custom ROM/Kernel and they messed with the voltage setting. A low voltage setting can cause the screen to be snowy/fuzzy looking.

sent from my neXus 5
 

Flubba

New member
Jan 23, 2014
4
1
I'd probably take it back apart and clean it with a soft toothbrush and some rubbing alcohol. REMOVE the battery before you clean it or you will be sorry. Then thoroughly dry it with a blow dryer (make sure it isn't set on hot. Warm or cool is fine).

To me it sounds more like a hardware defect rather than a software defect.

sent from my neXus 5

---------- Post added at 04:06 PM ---------- Previous post was at 03:52 PM ----------

Also did you try getting it into BOOTLOADER Mode? The only software defect I can think of is the person flashing a custom ROM/Kernel and they messed with the voltage setting. A low voltage setting can cause the screen to be snowy/fuzzy looking.

sent from my neXus 5

hmmm... I took it apart, and blow it up. Maybe I'll be doing the alcohol things in a while.

I already tried getting into bootloader (pressing power + Vol down). But now I tried again:

When I keep pressing the two buttons, the screen is slowly blinking: "snow" --> black --> "snow"... three times, then it comes a short "snow" and then its black and stops.

I don't know what normally happend when you hold the buttons at the Nexus 5. Will there appear something three times and then turn off again when you keep holding???

btw: already thank you for your advices (but if it's the hardware, I'm afraid some chip/processor/...??? will be defect)
 

Flubba

New member
Jan 23, 2014
4
1
Solved!!!

Whuhhuuuuu!!! Solved. I bought a new "usb / charging flex cable - thing" (sorry I dont know whats the name) for just 20€ and the problem was solved.
Thank anyway for all your answers and adviced.
 
  • Like
Reactions: Nedim6

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Solved!!!

    Whuhhuuuuu!!! Solved. I bought a new "usb / charging flex cable - thing" (sorry I dont know whats the name) for just 20€ and the problem was solved.
    Thank anyway for all your answers and adviced.