[Q] [SOS][Galaxy s4 MTK6572] Error 4032 (Enable DRAM FAILED) when trying to flash

Search This thread


New member
Aug 1, 2014

everyone help
i flash my phone by wrong preloader
i didnt backup from it
i dont know my build number
please help


  • Help.zip
    8.8 MB · Views: 520


Jul 4, 2014

I got that error too when im trying to flash my brick alcatel one touch 4033E.
if you got it too you're probably fortunate that there is still hope on your android phones

instruction :
1. Remove your phone's battery (make sure to unplug it to your usb cable)
2 Open SP Flash Tool and Run it as Administrator (im using SP Flashtool v5.etc) :p
3 Go to Options tab above or access it by combination of Ctrl+O.
4 Click on Connection Bar then click w/o battery then click the exit.
5 plug your android phones without battery and try to flash (your rom) if it works be grateful.
6 Good Luck!. :good:

Thanks for helping me, will not turn over, please, my phone is with stripes


New member
Aug 19, 2014

let's do it step by step (and your comment after "==>")

1- Download http://forum.xda-developers.com/attachment.php?attachmentid=2342635
we need just the preloader_edit.bin

2- Download then unzip the ROM Files :

3- Remove the phone battery, open the sptool click on preloader then select preloader_edit.bin instead of preloader.bin

4- connect the phone, when it's detected by PC, click on format

5- disconnect then connect the phone again, when it's detected by PC click on "Firmware Upgrade"

6- Wait the end of upgrade operation then disconnect and reboot the phone

exusme the files on 4shared removed
if you can upload files pleas because i have same problem and i will be thankful to you


New member
Aug 23, 2014

hello friends I am days looking for a solution happens to me the same thing so appears the screen of recovery mod fastboot Normal mode mode is put down + power and home appears a screen in Chinese read all the pages but here it does not work the flash tools nothing so update by zip but do not think it's a rom that works or clockwmode by zip

reversed and this one of the screens :crying:??

can someone help me ??::crying:


  • 20140823_024411.gif
    58 KB · Views: 130
  • 20140823_024303.gif
    90.1 KB · Views: 123
  • 20140823_024824.gif
    74.3 KB · Views: 126
  • IMG_20140823_025243.gif
    67.7 KB · Views: 133
  • 20140823_032431.jpg
    116.6 KB · Views: 57
Last edited:


New member
Sep 16, 2010

maybe it help http ://ww w.china-devic es. com/Thread-GT-I9500-MT6572-MT6589-is-fake?pid=8072#pid8072


Senior Member
Aug 11, 2013
plzzzzzzz some one help meeeeeeee

please some one help me :(( i have a fake galaxy s5, "Mt6572" i flashed it, imei is invalid and simcard does not detected!!
i did the IMEI&SN writer with files that a user posted for MTK9572
it gives me error: Enter to ModemMeta Fail:
and phone stucks on SAMSUNG GALAXY S5 screen !!!!
i did these things... but the didn't help... http://forum.xda-developers.com/and...simcard-flashing-mt6572-t2872133/post55340906

---------- Post added at 04:03 PM ---------- Previous post was at 03:31 PM ----------

The steps all go smoothly and fine IMEI written and read.
I restart the phone but nothing happens. The IMEI remains the same (null). The baseband is not detected on MTK Droid Tools.
I tried with Mobile Uncle Tools, but there is no CDS menu where I could find information on the radio and write the IMEI otherwise. The phone is Rooted.

I have flashed the rom posted here several times, all went well with flashing. I am not aware which file contains the information about the baseband: if it is the: recovery.img, or, nvram. or secro, or if there is another file which could be used to flash the baseband alone.
Could you please tell which IMAGE file or BIN file or any other file flashes the baseband?

Thank you for your help.

Try a factory reset from recovery AFTER restoring secro.bin
This restored baseband and IMEI when I had this same problem on a 6572 Cubot c11

Good Luck[/QUOTE]

tnx dude :X i did what you sed... i can now use simcard and connect to gsm networks !!!! but phone steel has invalid imei, but no problom , cuz it works ! tnx :D


New member
Oct 12, 2014
Hardware : MT6572
Model : Galaxy S4
Build number : ALPS.JB3.MP.V1
Build date UTC : 20140211-034713
Android v : 4.2.2
Baseband v: MOLY.WR8.W1315.MD.WG.MP.V1.P4, 2013/12/03 10:42
Kernel v : 3.4.5 ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP Tue Feb 11 11:22:58 CST 2014
Uboot build v : —– should be root shell
LCD Driver IC : 1-otm8012a_boe_suxian_397_wvga_m_guozhen

please help....


New member
Oct 13, 2014
the working rom for me is here -> needrom.com/mobile/s4-gt-i9500-mt6572/

i hope will be good for you also, good luck:fingers-crossed:

Hello, i'm new in xdadevelopers. I have a s4 clon Mt6572 emmc phone with the same problem I donwloaded the files and tried too flash it but the program don't leave me open the "preloader.bin" when i try to flash preloader appears a window and say fail to open. i'll want that you can help me please my phone turn on and i can listen the sounds the touch screen is good, but the only problem is that i can't see anything just some lines on the LCD.
Plase help me guys:
Last edited:


Jun 12, 2012
please urgent

i have Adcom A430 china android phone ...
by mistake i format whole system using ctr recovery and now my phone dont boot only adcom screen logo is still on screen i have backup data but i flash error like dram setting fail or meta system change choose firmware upgrade
i have firmware info of the phone :
preloader 0x0000000000600000 0x0000000000000000 2 /dev/misc-sd
mbr 0x0000000000080000 0x0000000000000000 2 /dev/block/mmcblk0
ebr1 0x0000000000080000 0x0000000000080000 2 /dev/block/mmcblk0p1
pro_info 0x0000000000300000 0x0000000000100000 2 /dev/block/mmcblk0
nvram 0x0000000000500000 0x0000000000400000 2 /dev/block/mmcblk0
protect_f 0x0000000000a00000 0x0000000000900000 2 /dev/block/mmcblk0p2
protect_s 0x0000000000a00000 0x0000000001300000 2 /dev/block/mmcblk0p3
seccfg 0x0000000000020000 0x0000000001d00000 2 /dev/block/mmcblk0
uboot 0x0000000000060000 0x0000000001d20000 2 /dev/block/mmcblk0
bootimg 0x0000000000600000 0x0000000001d80000 2 /dev/block/mmcblk0
recovery 0x0000000000600000 0x0000000002380000 2 /dev/block/mmcblk0
sec_ro 0x0000000000040000 0x0000000002980000 2 /dev/block/mmcblk0
misc 0x0000000000080000 0x00000000029c0000 2 /dev/block/mmcblk0
logo 0x0000000000300000 0x0000000002a40000 2 /dev/block/mmcblk0
expdb 0x0000000000a00000 0x0000000002d40000 2 /dev/block/mmcblk0
android 0x0000000028a00000 0x0000000003740000 2 /dev/block/mmcblk0p4
cache 0x0000000017800000 0x000000002c140000 2 /dev/block/mmcblk0p5
usrdata 0x0000000052c00000 0x0000000043940000 2 /dev/block/mmcblk0p6
fat 0x00000000512c0000 0x0000000096540000 2 /dev/block/mmcblk0p7
bmtpool 0x0000000001500000 0x00000000ff9f00a8 2 /dev/block/mmcblk0

please tell me how to flash step by step


New member
Dec 6, 2014
Help please

Please help me,
I have a samsung phone s4 clone, my hp camera does not work if I insert a memory card and unfortunately gallery has stopped when the camera will be used. if anyone have the same problem with me please help:rolleyes::rolleyes::rolleyes:


New member
Dec 7, 2014

Guys i really need help!!! i have Note 3 mt6572 and i download wrong rom and now its bricked! i tried all roms on needrom but its always error eneble dram faild..its hard bricked i cant turn on..PLEASE HELP..:crying:


New member
Dec 11, 2014

Hardware : MT6572 (MT6589 is Fake!)
Model : GT-I9500
Build number : ALPS.JB3.MP.V1.8
Build date UTC : 20140523-015844
Android v : 4.4.4
Baseband v: MOLY.WR8.W1315.MD.WG.MP.V4, 2013/08/07 10:44
Kernel v : 3.4.5 ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP Fri May 23 09:56:25 CST 2014
Uboot build v : ----- should be root shell
LCD Driver IC : 1-nt35512_dsi_vdo

i have error with DRAM fail.
help how i can make it work again?


Jan 4, 2015
Another bricked clone, please HELP

Hello. I've hardbricked my clone by trying to flash it using the other phone's ROM (yeah I know I was dum), please help me!

My MTK Tools device data

Hardware : MT6572 (MT6589 is Fake!)
Model : GT-I9500
Build number : ALPS.JB3.MP.V1.8

My ROM backup (with some reason bootloader is damaged or something)

I tried about 5 versions of SP Flash Tool (3.* and 5.*), tried to switch to flashing w/o battery mode, tried about 8-15 ROMs (EMMC and NAND), tried to use bootloader_edit, but everything returns error 4032. Also, formatting and testing my clone in flash tool returns error 4032 too. Even I tried another PC (laptop), and it still doesn't seems to work.
I'm getting insane, please help!

Here are some extra photoas of my device

Battery: goo(dot)gl/nAl3D4
Factory data: goo(dot)gl/D97zNf
Last edited:


Jan 4, 2015
shoe me pics of your mobile

Battery: goo(dot)gl/nAl3D4
Factory data: goo(dot)gl/D97zNf

(Change "(dot)" to ".", sorry for such as links for the pictures, I have to post pictures like this because of I did not post 10 messages yet)

But if you want the main view of the clone - its whitecoloured, looks pretty similar to Samsung Galaxy S4. If you want to, I can make photo of the main view of the phone.


Jan 4, 2015
ya make a foto of the fone front and from back without battery so i can see which model you have

Don't know how it would be helpful, but okay, there they are. I have hidden IMEI, because I don't want anyone to use my IMEI code.

Front side: goo(dot)gl/WqjZYL
Back side: goo(dot)gl/86fHL5

(Change "(dot)" to ".", sorry for such as links for the pictures, I have to post pictures like this because of I did not post 10 messages yet)

If you really do need my IMEI, I can PM it to you.

Thanks for trying to help me!

Top Liked Posts