• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] TMOUS Branded HD2 - "No service" upon waking, lots of calls going to voicemail.

Search This thread

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
[Q] TMOUS Branded HD2 - "No service" upon waking, lots of calls going to voicemail.

I've noticed this with a lot of builds - I came back to the HD2 after the whole "NAND" revolution so I can't say if this really happened before then or not.

When I wake my phone I am seeing a lot of times where "No Service" is displayed on the screen but it almost immediate then switches to T-Mobile.

I am also noticing that even with good signal here in the office a lot of my calls go to voicemail without ever waking the phone. I get a ring or two (if I am lucky) then straight to google voice.

At the moment I am running MDJ's CyanogenMod 2.5 and the latest HTC released radio (don't have the number in front of me). This problem has been seen though with various ROMs that I have been running. I've tested it numerous times from my desk phone at random times throughout the day - at least half of the calls are going to voicemail at one point or another without having ever rang the phone.

Oh yes - effective yesterday morning I am not overclocking my phone either.

Is anyone else experiencing anything similar? I can understand going to sleep when the screen is not on, but this is ridiculous! If I slept that hard the alarm would never wake me LOL!
 
Last edited:

DeoreDX

Senior Member
Feb 16, 2009
440
71
Alabamastan
I've noticed that too. I'm on a Tmo USA HD2 with MDJ CM7 2.5 also.

I looked at the new expanded details of cell standby under the battery usage tab. My phone says it's not had signal 30% of the time. I normally don't have issues missing calls or emails at home, though I'm not in a super strong signal area. It'll be interesting to see what it is at work, where I'm literally right under the cell tower with full signal strength. If I'm showing no service there and a high percentage of time without signal, I will know something is wrong.

CAP201101191741.jpg
 

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
I'm seeing 40% myself - WOW - I guess tonight when I get home (I've got balls-to-the-wall signal there) I'll check to see how it does there.

I didn't realize that feature was there with 2.3 - good to know!


Anyone else have anything to throw into the mix?

Thanks!
 

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
Last night at home I had no issues with signal drops - here at the office in 2 hours 25 minutes I've seen 23% without signal.

I'm really curious now if it Gingerbread is just more sensitive or if I really have no signal that often across the board with all ROMs here in the office.
 

muzicman0

Senior Member
I am constantly bouncing between H and Edge, and have noticed a lot of signal drops, but the only last a few seconds. I might try to turn off 3G and see what that does. what radio is everyone running? I'm on 2.15.50.14...

AND...if I want to try a different radio, how do I flash it now that I don't have WM6.5 anymore...I always initiated the flash in WM...
 

bere09

Member
Aug 12, 2010
29
0
My phone has a similarly high percentage of time without a signal, however I have not noticed any calls going to voicemail and everyone that has had to call me has been able to get through.
 

jadrobe

Senior Member
Dec 19, 2010
208
14
I am having the same problem. My radio is same as yours 2.15.50.xx
Same network as my sister's Google Nexus One, but when we have our phones sit beside each other, mine has no signal while hers has full bars. I have already set my network type to GSM only (due to unnecessary charges of my telecom) and somehow it improved but not like it is with the Nexus One.
 

DeoreDX

Senior Member
Feb 16, 2009
440
71
Alabamastan
Monitored it for the day. At home I have a weak 3G signal but a somewhat decent Edge signal, and my phone normally bounces between the two 2-3 bars of 3G then it will drop to no signal then switch to edge then switch back. When I am home every time I unlock the phone it says "No Signal". But I still receive emails and phone calls like normal, I've not seen any abnormal missed calls or emails. I reset my phone this morning when I took it off the charger. In the hours I was at home it said I had no signal for 75% of the time. At work where I have almost perfect signal I had zero % time with no signal. My wife's Vibrant doesnt exhibits the wavering between edge/3g at the house. But it's not like I am getting bad battery life or seeing my phone jump in in power usage like you would normally see with a poor signal. Almost 13 hours off the charger. 52 minutes with the display on. 28 minutes of voice calls. 15 minutes of web browsing. I still have 57% battery left.

CAP201101202008.jpg
 

DeoreDX

Senior Member
Feb 16, 2009
440
71
Alabamastan
Working form my home office this morning so I had a chance to do some testing. Looks like my spotty 3G coverage at my house is the culprit. I mentioned earlier I have 2-3 bars of 3G here but every so often it will bounce to edge then back to 3G. It looks like when the phone is in standby that it doesn't handle that bounce properly, and will sit with "no service" until I wake it up. I put "no service" in parenthesis because even though the phone displays no service and registers that in the "cell standby" portion of the expanded battery use display I can still receive texts and emails and calls. I switched it to 2G only and the "no service" when I wake it up goes away and it does log any additional "time without signal" since I've done that.
 

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
I've switched to 2G only as of reading this. I've got no real need for 3G while at the office so if this is a solution, I'm all for it!

I'll be monitoring throughout the day as well, and make some random test calls from the desk to the phone to see if I land in voicemail.

Great catch though - now if we could only get it addressed!

By the way, what ROM are you running? Curiosity asks if it's a specific Android version issue or not...
 

DeoreDX

Senior Member
Feb 16, 2009
440
71
Alabamastan
I've switched to 2G only as of reading this. I've got no real need for 3G while at the office so if this is a solution, I'm all for it!

I'll be monitoring throughout the day as well, and make some random test calls from the desk to the phone to see if I land in voicemail.

Great catch though - now if we could only get it addressed!

By the way, what ROM are you running? Curiosity asks if it's a specific Android version issue or not...

MDJ's Cyanogenmod 7 v2.5. Just put the 2G/3G toggle into the power control in the notifier window.

I should be getting a G2 in the next couple of days so I'm going to give it a head to head test to see if the G2 exhibits the same behavior. I would test it with my wife's Vibrant but without gingerbread I'm not sure how I can log that no-service information.
 

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
MDJ's Cyanogenmod 7 v2.5. Just put the 2G/3G toggle into the power control in the notifier window.

I should be getting a G2 in the next couple of days so I'm going to give it a head to head test to see if the G2 exhibits the same behavior. I would test it with my wife's Vibrant but without gingerbread I'm not sure how I can log that no-service information.

I added it to the power toggle widget... How do you add it to the notifier Window?
 

bere09

Member
Aug 12, 2010
29
0
I've got to say, since I entered the correct apn settings to fix the MMS blurryness, I have had very little to no down time with regards to signal. Where as yesterday in the same locations at the same time I had 40% down time, today I have 5% and it's going down.
 

JWhipple

Senior Member
Jul 16, 2008
958
100
Melbourne, FL
I'm going to try a an app I found on the market - supposedly it can control 2G/3G based on a schedule..

http://www.appbrain.com/app/timeriffic/com.alfray.timeriffic

If it actually works, I'll just set it to switch to 2G during the days and hours I know I am usually in the office.

ON THE BRIGHTER SIDE - This whole problem has helped me do something that I've been meaning to do - ditch my girlfriend!

She's been pissed as hell because she was one of the people calling my cell while I was at work and never able to get through because of this issue... Well, she refused to listen to my explanation of what really was happening! I told her repeatedly that until I got the problem ironed out to call my desk phone, but she insisted on calling the cell. She swore up and down that I was simply ignoring her calls or shutting my phone off.

She tried calling several times last night while I was still at the office - same problem.

Well, I just got the call from her (actually, text message) - kicked to the curb - THANK GOD!
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hey guys

    I am a noob but a long time lurker since the blackjack days! To fix the issue that you get "no signal" from standby try the following steps:

    1) go to dial pad and enter *#*#4636#*#* ( don't press dial button ).
    2) it should take you to a menu on this menu press : Phone information
    3)Scroll down and click the set preferred network type and then click GSM/CDMA auto Prl.


    Once you are done test it out. It will no longer say no service after standby. I tried this after finding a link and google and I figured I will share.
    1
    So I tryed ..
    1) go to dial pad and enter *#*#4636#*#* ( don't press dial button ).
    2) it should take you to a menu on this menu press : Phone information
    3)Scroll down and click the set preferred network type and then click GSM/CDMA auto Prl.

    However I found it wasnt saving the settings ..
    What I Had to do was .. Make sure Data was NOT Connected ..

    settings/wireless-networks/mobile network < Un-Check this

    Then Goto dial pad and enter *#*#4636#*#*

    And Set: GSM/CDMA auto Prl

    Then Close that Out .. and go back to ..
    settings/wireless-networks/mobile network < Check this

    Seems to have saved the setting now ..
    Maybee thats why it didnt work for you JWhipple ?

    Give it a shot.