[Q] WLAN_RX_WAKE wakelock preventing GNex from entering deep sleep

Search This thread

shadvich

Senior Member
Nov 14, 2010
132
14
Really odd problem here - as of a couple days ago, everything was working perfectly with my galaxy nexus. I decided to jump over to CM10 (was on codename android, IIRC), right after I think there were some new commits to AOSP.

From here on out, my phone would never enter deep sleep when connected to wifi. Any wifi hotspot - the ones I've been using, a hotspot I created from my desktop - the icon would show the phone constant receiving data via wifi. Using better battery stats, over about 5 hours on my desk, 4.5hrs were spent with a WLAN_RX_WAKE kernel wakelock with my phone sitting at 350MHz instead of deep sleep for that time.

I tried a bunch of different kernels (stock CM10, franco, imoseyon, etc) both new and old versions, but the problem was still there. I tried clean flashing a rom, and only installing better battery stats. Same thing with all kernels.

Factory restored google stock images to BOTH ICS and JB. I still have the problem. Tried disabling google location services. No dice. Tried a couple basebands, but I'm pretty sure that only affects cell/data performance, right?

I honestly have no idea what is going on. I've been on this hotspot (campus wifi) for months now without a problem, and now this. Some threads say that this is caused by DHCP requests from the router, but why would I have not seen this until now? My idle drain was at about 1-2% per hour before this, now it is close to 10-15%.
 
Last edited:

TheMan0790

Senior Member
May 22, 2011
844
430
Really odd problem here - as of a couple days ago, everything was working perfectly with my galaxy nexus. I decided to jump over to CM10 (was on codename android, IIRC), right after I think there were some new commits to AOSP.

From here on out, my phone would never enter deep sleep when connected to wifi. Any wifi hotspot - the ones I've been using, a hotspot I created from my desktop - the icon would show the phone constant receiving data via wifi. Using better battery stats, over about 5 hours on my desk, 4.5hrs were spent with a WLAN_RX_WAKE kernel wakelock with my phone sitting at 350MHz instead of deep sleep for that time.

I tried a bunch of different kernels (stock CM10, franco, imoseyon, etc) both new and old versions, but the problem was still there. I tried clean flashing a rom, and only installing better battery stats. Same thing with all kernels.

Factory restored google stock images to BOTH ICS and JB. I still have the problem. Tried disabling google location services. No dice. Tried a couple basebands, but I'm pretty sure that only affects cell/data performance, right?

I honestly have no idea what is going on. I've been on this hotspot (campus wifi) for months now without a problem, and now this. Some threads say that this is caused by DHCP requests from the router, but why would I have not seen this until now? My idle drain was at about 1-2% per hour before this, now it is close to 10-15%.

This is literally the EXACT SAME problem I'm having...I wish someone could properly explain why this is happening and how to fix it.

Sent from my Galaxy Nexus using xda app-developers app
 
  • Like
Reactions: phrozenflame

shadvich

Senior Member
Nov 14, 2010
132
14
Network Log doesn't show up with anything, so the wakelock shouldn't be caused by a rogue app.

Shark, on the other hand, after about 10 seconds of logging, netted me about 300 DHCPv6 'solicit XID' requests. There a bunch of different sources from these requests, they just seem to be other devices on the network pinging my phone to see if it's a DHCPv6 server...?

I've seen some suggestions on other forums to mess around with the router settings, which I can't do because it's campus internet.
 

Guiding.God

Senior Member
Apr 21, 2012
240
96
guidinggod.blogspot.com
Since you've tinkered with rom/kernels etc on phone without any seeming change, it's feasible that there's been some change recently on the other side of the equation namely the network settings of your campus wifi? Maybe your University's tech department has implemented something new etc? Have you tried asking others with wifi enabled phones if they are experiencing this as well?

Found this here (pretty sure you've come across this if you've been googling abt this issue but posting anyways)

"Another more elaborate solution if you rely on that network a lot, is to purchase a wireless bridge or gaming adapter and connect it to your apartment wifi and then connect your own wifi router to that. Then the gaming adapter would get the dhcp IP from your apartment (so who cares if it is renewing it constantly) and your router would treat the connection just as if you were connected directly to an internet connection. Then configure your router for static IP addresses or if your router does not cause issues with DHCP then you don't need static IPs."

from http://rootzwiki.com/topic/16134-kernel-wakelock-wlan-rx-wake/

I know I had an issue with some wlan rx wakelock thing last year but I cannot for the life of me remember how I got rid of it or what changed :eek:
 

shadvich

Senior Member
Nov 14, 2010
132
14
Hmm, seems like an okay solution but my friend's devices don't seem to show the same symptom, and since I roam campus alot, a wifi extender wouldn't be ideal.
 

EddieN

Senior Member
May 13, 2011
164
27
Gothenburg
I am seriously ripping my hair out from this goddamn wakelock ****.

I wake up at 9am and have to charge my phone by 4pm because it's at 16% with 40 minutes of screen on time. Seriously? This is a JOKE.

I've checked with BetterBatteryStats and CPU Spy. Both confirm the phone keeps sitting at 350MHz when it's supposed to be sleeping, as well as wlan_rx_wake keeping the phone awake.

I've set my phone to receive a static IP from my router (DIR-655) but it doesn't help. I really don't know WHAT to do. I've downloaded shark to my phone, sniffed packets, but haven't been able to get anything useful out of it since there is a LOT to sift through (unless you know what you're looking for - which I don't).

This is by far the worst bug/issue I have ever encountered with my phone and it is seriously getting on my nerves. I will be forever greatful to anyone who can help me pinpoint the issue and make it stop.

Also, i REFUSE to "go buy a new router" as it's bull****. This is a bug people experience only sometimes it seems and NO ONE has a fix for it. I read somewhere about a fix being implemented in some kernels but they were for other phones, never found anything like it for the GNex. If anyone knows anything about a fix like that, please show me the way.

I already checked for rogue apps, there were none keeping wifi awake. I've even tried with a totally stock, newly flashed phone with stock kernel and everything. NO extra apps installed except shark, CPU spy and betterbatterystats sideloaded. I didn't even input my GMail to stop the syncing. It STILL KEPT MY GODDAMN PHONE AWAKE.

I am SERIOUSLY desperate. Considering just selling my phone and opting for something else if this continues, it totally cripples everything.

/rant over
 

simms22

Recognized Contributor - R.I.P
Jun 4, 2009
34,053
25,933
BROOKLYN!
www.androidcommunity.com
turn on WiFi, Bluetooth, and GPS, for about 30seconds, then turn them off. put your phone to sleep, then check if you're going into deep sleep. CPU spy is a good app to check if your hitting deep sleep.
 

beekay201

Senior Member
Nov 8, 2010
5,225
1,221
Change wireless network encryption? Wpa2, tkip+aes, aes only, tkip only? Wpa?
Change wifi channel?

Edit: scratch that. Try disabling 5ghz band.

Sent from my i9250
 
  • Like
Reactions: phrozenflame

madd0g

Senior Member
May 8, 2010
2,843
871
I had a similar issue, it turned out it was Dropbox LANSync in my home LAN. I used an experimental forum build on my PC, so it could be this, but in the end I turned LANSync off, since Android doesn't make use of it anyway.

So try this if you have Dropbox running on your network clients.
 

EddieN

Senior Member
May 13, 2011
164
27
Gothenburg
turn on WiFi, Bluetooth, and GPS, for about 30seconds, then turn them off. put your phone to sleep, then check if you're going into deep sleep. CPU spy is a good app to check if your hitting deep sleep.

At the moment I am fiddling with putting my router into different security configurations, per the quote below. But I will give your idea a try as well.

Change wireless network encryption? Wpa2, tkip+aes, aes only, tkip only? Wpa?
Change wifi channel?

Edit: scratch that. Try disabling 5ghz band.

Sent from my i9250

5GHz band? Where do I disable this, the phone or the router? My router chooses channel automatically and is set to Auto 20MHz/40MHz channel width.

madd0g said:
I had a similar issue, it turned out it was Dropbox LANSync in my home LAN. I used an experimental forum build on my PC, so it could be this, but in the end I turned LANSync off, since Android doesn't make use of it anyway.

So try this if you have Dropbox running on your network clients.

I don't have DropBox on my phone or on any of my PC's
 

EddieN

Senior Member
May 13, 2011
164
27
Gothenburg
A quick update, I just tried all the suggestions in the quotes in my previous post but to no avail, still getting the wake locks. I'm seriously going crazy.

Turning wifi off did let the phone sleep, but that was expected as the wake lock is related to wifi. Nothing else has worked. NOTHING.




Sent from my Galaxy Nexus using xda app-developers app
 

madd0g

Senior Member
May 8, 2010
2,843
871
A quick update, I just tried all the suggestions in the quotes in my previous post but to no avail, still getting the wake locks. I'm seriously going crazy.

Turning wifi off did let the phone sleep, but that was expected as the wake lock is related to wifi. Nothing else has worked. NOTHING.

Sent from my Galaxy Nexus using xda app-developers app

This issue appeared again for me, it obviously also helps to disable the NETBIOS on your Windows PC network adapter. There are guides for that online. Also get the "Network Log" app in the Play Store, it shows the traffic so you can see which one's are for the kernel (wlan_rx_wake is a kernel wakelock).
 

Kurre

Senior Member
Aug 10, 2010
1,368
974
Also uPNP feature in router can cause all kind of weird behavior. Better block it from router's firewall.

Sent from my slimbeaned GNex :)
 

EddieN

Senior Member
May 13, 2011
164
27
Gothenburg
What baffles me the most is that all of this shouldn't be needed. I shouldn't have to disable netbios and do things to OTHER devices just so my phone sleeps. This is a jellybean issue imo, I never had these problems on ICS.

The experiments continue, updates incoming.

Sent from my Galaxy Nexus using xda app-developers app
 
  • Like
Reactions: ccs86

madd0g

Senior Member
May 8, 2010
2,843
871
I also suspect the major issue was that my wifi channel was the same as the ones around me. When I changed it, the wlan wakelocks went down significantly.

Sent from my Galaxy Nexus using Tapatalk 2
 

Doomhamma

Senior Member
Sep 25, 2012
678
285
Siroki Brijeg, BiH
At the moment I am fiddling with putting my router into different security configurations, per the quote below. But I will give your idea a try as well.



5GHz band? Where do I disable this, the phone or the router? My router chooses channel automatically and is set to Auto 20MHz/40MHz channel width.



I don't have DropBox on my phone or on any of my PC's

5 Ghz band is disabled when you enter Wi - Fi - advanced - Wi - Fi frequency band ... It's set to auto by default, you try either 2.4 or 5 ghz on manual and check if that helps ( incase you didnt already :D )
 
  • Like
Reactions: damnation333

JuanG

Senior Member
Jan 24, 2011
102
14
Does anyone have any news about this issue? I have the same problem and I can't find the solution. I made several test without any good results.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    So i've had the same problem where my galaxy s3's battery has just gone to 0 in ~10 hours and i finally found the fix for it, this is what's causing it for me and might be what's causing it for you to, anyhow i'm gonna go step by step with what i did to find the culprit.

    I downloaded an app called Network Log and let it log some of my traffic, i quickly found that packets where beeing sent by 192.168.1.74 wich is not any android device but my main computer and there i found the source of the problem, i was then searching around and stumbled across this post, http://forum.xda-developers.com/showpost.php?p=25876666&postcount=3

    I found this line in the post,

    Q: Wakelocks "wlan_rx_wake" wake up my device constantly what I can do about it?
    A: The problem is neither Android nor the kernel, but the router and the (Windows7) network. In the network properties, uncheck "IPv6", disable the service "IP Helper", "Shell Hardware Detection" and "Windows Media Player Network Sharing Service", which provide ongoing Traffic. Then they scored again 98% of deep sleep.

    and i decided to look in to it, i started the "run" command in windows and wrote "services.msc" wich then boots up you services that's started by windows, after that it's pretty simple.

    Find the line called Ip Helper and stop it after that right click it and chose properties and decided the start method as inactive, after that look up the "Windows Media Player Network Sharing Service" and do the exact same thing there, this actually fixed it, my computer for some reason got stuck on sending useless packets over the network and was sending it to my galaxy s3 along with my mothers galaxy note 10.1 (no other android devices where seeing this thou for some reason) and after setting those 2 to disable i now have had my phone at 99% battery for over an hour with wifi active.

    I do hope this helps and i'm gonna post this in the other wifi_rx_wake posts i can find.
    3
    I just got this issue too.
    Tracked it back to SX Virtual server, which is basically the same as D-Link's Shareport. Uninstalled, and the wakelocks seems to be gone.

    What I did was this:
    Tried Shark - it showed that there was a lot of packets sent to and from local computers on my network. Nothing more useful info from that.

    Tried Network Log, it showed the amounts of packets sent and receieved by Kernel. And most of them was sent to/from local computers, using specific UDP ports.

    Used TCPview on the computers to see what it was. It informed that the ports was used by two programs: SX Virtual Server (identical to D-Link Shareport) and Dropbox.

    I uninstalled SX Virtual Server/Shareport (it's useless anyway) and disabled Lan sync in Dropbox.
    Now, the Kernel network activity is almost idle.

    Hope this helps others with this issue.
    2
    I've just reported this to Sonos again as I'm still getting it.

    I get about 2x the battery life on idle with sonos uninstalled as opposed to installed - it's the only app which has that effect
    The magnitude of the drain does I believe relate to the volume of broadcast/multicast traffic on the wlan, which can be tweaked somewhat, but the real issue is whatever the sonos app is doing that allows this drain.
    I presume it's keeping a lock to enable broadcast/multicast - at worst it should release this on sleep....

    Interestingly in the current client there is a setting under "advanced" labelled "show notifications". This is what causes the sonos client to show track playing (and basic controls) in the notification bar. When disabled (which they advised me to try) the wlan_rx_wake issue goes away it seems. YAY! It's still something they could improve, and they are looking at it, but if anyone else has the same issue give this a whirl.
    1
    Not sure if you've tried this and it helps but maybe you can try Network Log or Shark from the store to diagnose this?
    1
    Change wireless network encryption? Wpa2, tkip+aes, aes only, tkip only? Wpa?
    Change wifi channel?

    Edit: scratch that. Try disabling 5ghz band.

    Sent from my i9250