[Q] Xoom Won't turn on

Search This thread

maduka56

Member
Nov 14, 2009
5
1
New to the forum. Love you guys' work. Been a follower since the G1 days. I got the xoom on Thursday (like a lot of you) and have loved it, until last night. My battery was going low (20% or so) and I used it for about 10 more minutes when the whole thing just shot off. I'm not sure what happened. I tried to charge it and nothing happened. If it was my G1 or Nexus, I would have just pulled the cover off and taken the battery out and rebooted, not so easy on the xoom. I think I might have to take it back, but anyone have any ideas as to how I can get it working again?
 

Crankyhobo

New member
Mar 12, 2011
1
0
I just had this happen to me today, so as of March 11 its still an issue. The system appeared to be locked in sleep mode and no amount of pressing or holding the power (or any other) button wakes it up. The little light top right just keeps flashing slowly. It wasn't on a low battery either. lets hope all the other users are savvy enough to search for the answer online. I found it here on xda forum in another thread - hold down power button and volume at the same time. Which interestingly is a trick i wouldn't find in the manual, and i couldnt find an explanation for the blinking light in the manual or PDF guide either. There will be some very very worried xoom owners around until this is fixed.
 

mercurycc

Member
Aug 28, 2010
13
1
Waterloo, ON
My xoom does not respond to my touch, so everything seems still alive, and when I hold on the power button it does ask me if I want to turn it off, but since it does not respond to my click, I cannot reboot the system. Same trick as above solved the problem.
 

Lare2

Senior Member
Feb 3, 2010
148
31
More information would be helpful.

1. Does this happened before or after the update.
2. Rooted, modified in any way etc etc...

AFAIK Mine still working fine. I haven't done anything to mine, so is still pretty stock.

At least there's a way to deal with this.
 

Zargon335

Senior Member
May 28, 2010
161
23
So this just happened to my wifi Xoom. Except the forced reboot method (volume up + power) doesn't get any response. Any quick ideas before I go exchange this at Costco?

edit: This is a completely stock Xoom.
 
Last edited:

p2flol

Senior Member
Sep 8, 2010
157
13
Yep its only happened once to me since launch day, but power + volume up did fix it. No idea why it happened, havent had any problems since though.
 

Top Liked Posts