• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Xperia z2 not turning on

Search This thread

abi_sam

Senior Member
Sep 26, 2013
65
9
i got a xperia z2 phon and it was in 4.4.4 kitkat Germany Telekom firmware and i updated to new lollipop. then i flashed a UK unbranded lollipop firmware.

then my phone didn't charge even i connected to power. my phone turnd off and when ever i connected to power i can see only the red LED light nothing else.

i cant go to flash mod or fast boot using VOL+ UP or VOL+DOWN.

i cant hard reset the phone either.

How can i recover my phone....... the problem is don't have warranty also...:(:(:(:(
 

ptmaniac

Senior Member
Jul 17, 2009
372
213
Aveiro
OnePlus 6
OnePlus 7T
i got a xperia z2 phon and it was in 4.4.4 kitkat Germany Telekom firmware and i updated to new lollipop. then i flashed a UK unbranded lollipop firmware.

then my phone didn't charge even i connected to power. my phone turnd off and when ever i connected to power i can see only the red LED light nothing else.

i cant go to flash mod or fast boot using VOL+ UP or VOL+DOWN.

i cant hard reset the phone either.

How can i recover my phone....... the problem is don't have warranty also...:(:(:(:(

Humm unless you did something really wrong (if you want more help you have to post more info... like what firmware version where you flashing, did it flash ok, how did you flash it?) you should be able to recover by flashing a full .ftf with flashtool.

Make sure your phone is completly powered off (press volup+pwr until phone vibrates 3 times) then let the phone charge for at least 1 hour, then try flashing your phone in flashtool. (don't power on your phone, just start the flash process in flashtool, press vol down and plug the usb cable to your device when requested, it should power by itself and start the flashing)
 
Last edited:
  • Like
Reactions: abi_sam

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    i got a xperia z2 phon and it was in 4.4.4 kitkat Germany Telekom firmware and i updated to new lollipop. then i flashed a UK unbranded lollipop firmware.

    then my phone didn't charge even i connected to power. my phone turnd off and when ever i connected to power i can see only the red LED light nothing else.

    i cant go to flash mod or fast boot using VOL+ UP or VOL+DOWN.

    i cant hard reset the phone either.

    How can i recover my phone....... the problem is don't have warranty also...:(:(:(:(

    Humm unless you did something really wrong (if you want more help you have to post more info... like what firmware version where you flashing, did it flash ok, how did you flash it?) you should be able to recover by flashing a full .ftf with flashtool.

    Make sure your phone is completly powered off (press volup+pwr until phone vibrates 3 times) then let the phone charge for at least 1 hour, then try flashing your phone in flashtool. (don't power on your phone, just start the flash process in flashtool, press vol down and plug the usb cable to your device when requested, it should power by itself and start the flashing)