• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Xposed Framework

Search This thread

ksurla

New member
Jan 10, 2014
2
1
I have an rooted LG Spectrum Android Version 4.0.4.
I am trying to download and install the framwork from the Xposed Installer.
After pressing install/update, I get the following:

Copying Xposed-Disable-Recovery.zip...
Mounting /system writable...
Segmentation fault
Could not mount /system writable
Trying to continue anyway...
Segmentation fault

Failed to create a backup of /system/bin/app_process




--Any help on to how to fix this?
 
  • Like
Reactions: swamyuma
I have an rooted LG Spectrum Android Version 4.0.4.
I am trying to download and install the framwork from the Xposed Installer.
After pressing install/update, I get the following:

Copying Xposed-Disable-Recovery.zip...
Mounting /system writable...
Segmentation fault
Could not mount /system writable
Trying to continue anyway...
Segmentation fault

Failed to create a backup of /system/bin/app_process




--Any help on to how to fix this?

I had such error on my SGY. I updated su binary, then I installed busybox 1.21.1 from Stericson's busybox installer (get it on Play Store).
Then problem was solved.
 

MishXT

Senior Member
Jan 15, 2011
489
42
Bradford
I'm trying to install the Framework, when I go into the app and then press install/update, I get a window that says:

Copying Xposed-Disabler-Recovery.zip...

Could not extract Xposed-Disabler-Recovery.zip

I've tried uninstalling and reinstalling the app, restarted the phone and still getting the same issue. never had this problem before, can anyone help?
 

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
I'm trying to install the Framework, when I go into the app and then press install/update, I get a window that says:

Copying Xposed-Disabler-Recovery.zip...

Could not extract Xposed-Disabler-Recovery.zip

I've tried uninstalling and reinstalling the app, restarted the phone and still getting the same issue. never had this problem before, can anyone help?

If you are trying to install Xposed on a newer Samsung device, Knox and SELInux will fight you. I'm guessing you are running what is in your in your sig, so probably not Knox. Install this: https://play.google.com/store/apps/details?id=com.mrbimc.selinux Grant SU, change to Permissive, reboot (may not be necessary, but doesn't hurt), and try again.
 

MishXT

Senior Member
Jan 15, 2011
489
42
Bradford
  • Like
Reactions: biggdevon

MishXT

Senior Member
Jan 15, 2011
489
42
Bradford
If you are trying to install Xposed on a newer Samsung device, Knox and SELInux will fight you. I'm guessing you are running what is in your in your sig, so probably not Knox. Install this: https://play.google.com/store/apps/details?id=com.mrbimc.selinux Grant SU, change to Permissive, reboot (may not be necessary, but doesn't hurt), and try again.

I tried it. Changed it to permissive and rebooted and I still get this error

Sent from my GT-N7100 using XDA Premium 4 mobile app
 

Attachments

  • 1397749581937.jpg
    1397749581937.jpg
    58.2 KB · Views: 5,151

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
What version of Xposed are you trying to install? Do you have a custom recovery? If so, Xposed 2.5+ will give you an option to install normal via system or you can pick the option to install via recovery. I'd go that route. It's at the top of the framework install part of Xposed - there is a drop down box to choose install methods.

Edit: Looked at the picture you posted and you definitely have the newer version.
 

MishXT

Senior Member
Jan 15, 2011
489
42
Bradford
What version of Xposed are you trying to install? Do you have a custom recovery? If so, Xposed 2.5+ will give you an option to install normal via system or you can pick the option to install via recovery. I'd go that route. It's at the top of the framework install part of Xposed - there is a drop down box to choose install methods.

Edit: Looked at the picture you posted and you definitely have the newer version.

Its 2.5.1. I didnt have this issue before on other roms. Im on ditto 4.4.2 rom and its the first time it hasnt worked for me. Could it be the rom?

Sent from my GT-N7100 using XDA Premium 4 mobile app
 

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
Its 2.5.1. I didnt have this issue before on other roms. Im on ditto 4.4.2 rom and its the first time it hasnt worked for me. Could it be the rom?

Sent from my GT-N7100 using XDA Premium 4 mobile app

It very well could be something in it that isn't being friendly to the normal framework install method, but lemme know if it works the other installation way. If it does, then not a big deal either way.
 

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
I have an rooted LG Spectrum Android Version 4.0.4.
I am trying to download and install the framwork from the Xposed Installer.
After pressing install/update, I get the following:

Copying Xposed-Disable-Recovery.zip...
Mounting /system writable...
Segmentation fault
Could not mount /system writable
Trying to continue anyway...
Segmentation fault

Failed to create a backup of /system/bin/app_process






--Any help on to how to fix this?

Your issue is described here: http://forum.xda-developers.com/showpost.php?p=51314174&postcount=9912 in case you never figured it out.
 

ThePraetor

Member
Nov 12, 2012
28
1
Penang
I'm facing a same problem after use latest ROM DN3 4.4.2. The error 'Could not extract Xposed-disabler-recovery.zip' come out after click on 'install/update' on xposed installer
 

MishXT

Senior Member
Jan 15, 2011
489
42
Bradford
And did you try my suggestion to the other person that had this issue?

I tried the other way and I still had the issue. So I did a clean installation of the rom again and it works now.

I guess something went wring when installing the rom which may have caused the issue.

Thank you for your help

Sent from my GT-N7100 using XDA Premium 4 mobile app

---------- Post added at 11:47 AM ---------- Previous post was at 11:46 AM ----------

What you want to do also after installing the rom freshly. Install the xposed v 2.5 rather than 2.5.1 because 2.5 works perfectly and there's no real need in updating it

Sent from my GT-N7100 using XDA Premium 4 mobile app
 

nucks1000

Member
Mar 15, 2014
7
1
same error

I have an rooted LG Spectrum Android Version 4.0.4.
I am trying to download and install the framwork from the Xposed Installer.
After pressing install/update, I get the following:

Copying Xposed-Disable-Recovery.zip...
Mounting /system writable...
Segmentation fault
Could not mount /system writable
Trying to continue anyway...
Segmentation fault

Failed to create a backup of /system/bin/app_process




--Any help on to how to fix this?


I have the same error, but for me i have a kindle fire HD 7inch

I can't use the play store because when I try to install it it just crashes and so does my you tube that i got without root via apk
 

Asylem

Member
Jul 27, 2013
12
2
Same issue

I am having the same issue with the could not extract the zip file. I have tried what was suggested on this thread as well as reinstalled the rom 3 times. I have used this rom before with no problems. The only two other things I can think of trying are full wipe and format of the sd card or full unroot and revert to stock then reroot and try the rom again. Any thoughts?
 

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
I am having the same issue with the could not extract the zip file. I have tried what was suggested on this thread as well as reinstalled the rom 3 times. I have used this rom before with no problems. The only two other things I can think of trying are full wipe and format of the sd card or full unroot and revert to stock then reroot and try the rom again. Any thoughts?

You're using 2.5 (not 2.5.1) and still having issues? What phone, rom, etc? Might try rolling back to 2.4.1.
 

Asylem

Member
Jul 27, 2013
12
2
I have a Galaxy Note 3 and running wicked rom. I was having the problem just on 2.5.1 but on 2.5 everything would load but none of the modules were working after rebooting. Everything checked out (installed and unzipped) with no errors on 2.5.

Sent from my SM-N900T using xda app-developers app
 

es0tericcha0s

Senior Member
May 6, 2010
4,407
875
mobilemojo5280.com
I have a Galaxy Note 3 and running wicked rom. I was having the problem just on 2.5.1 but on 2.5 everything would load but none of the modules were working after rebooting. Everything checked out (installed and unzipped) with no errors on 2.5.

Sent from my SM-N900T using xda app-developers app

Weird...What modules were you trying to use? When you go into the Framework part, does it show the app_process and XposedBridge.jar as green / active?
 

Asylem

Member
Jul 27, 2013
12
2
It did for the 2.5 version even tho nothing was working. I reverted back to 2.4.1 and things seem to be working at the moment. I was running Wanam and the kbs network module. I'm going to try and play around tonight with some other modules and see if the problem persists.

Sent from my SM-N900T using xda app-developers app
 

Top Liked Posts