[Q] Xposed installed, but not active?

Search This thread


Mar 3, 2019
I fixed my issue after hours of debugging, posting this here in case someone Googles it.
It seems that "XposedBridge.jar" is not included in the Magisk version of Xposed, though strangely it worked fine on Magisk version 19.3.

1. Download the corresponding SDK from here:

2. Extract XposedBridge.jar from \system\framework

3. Using Root Explorer or a similar app, move XposedBridge.jar to your internal device storage in the framework folder at:
/data/adb/modules/xposed/(probably system)/framework

4. Change the permissions for XposedBridge.jar to something like 0777

5. Reboot device, make sure Xposed is enabled in the Xposed Installer App prior to rebooting.
Thanks man! You saved my time! I was trying everything to get xposed to work on my device, thanks to you it's working fine now!
Great find, thanks for sharing it!


New member
Sep 25, 2018
Hi, I wanna thank you for the tips. It resolve my issue. I have to say that I previously try to download the Framework from the main interface but, after the reboot in TWRP while the flashing Framework, errors occours about inability to finally install (all this before creating the error.log file). But after creating the error.log file, the TWRP reboot-flashing finally works, and after reboot i got my Xposed 87.3 working.

Thank again for helping :good:

I write some more, for that people that say even creating error.log don't works.
I made this:
- delete app data
- create error.log (with rw-rw-rw permission) - (thanks @tsrajput)
- reboot phone
- recall Xposed and when it prompt I chose for download (not install)
- after finish download click on OK to TWRP-reboot-install
- done
how can i give permission to error.log for "rw-rw-rw"?

Top Liked Posts

  • There are no posts matching your filters.
  • 111
    really easy open root explorer and go to
    there must be a file name disable just delete it and reboot ur phone
    if I help pls gv me thanks
    the log is

    could not read log:
    /data/data/de.robv.andriod.xposed.installer/log/error.log/error.log: open failed: ENOENT (No such file or directory)


    it's happens when some times xposed log file deleted by it self or gained wrong permission again very easy solution

    open root explorer and goto


    now create a text file here with name error.log and give permission rw-rw-rw and save it now reboot and done

    if it's helped hit thanks
    if someone xposed installed can be used, after restart device xposed not active,this boot script may be helpful:

    setenforce 0
    chmod -R 777 /data/user_de/0/de.robv.android.xposed.installer
    chmod -R 777 /data/data/de.robv.android.xposed.installer

    or view this post http://club.huawei.com/thread-14239436-1-1.html
    Hidden download link:http://pan.baidu.com/s/1geKDa1d

    Go to Installer/ Settings and check "Disable resource hooks". Reboot. Enjoy.

    All (c) credits here -> http://forum.xda-developers.com/mate-8/development/rom-kangvip-slim-t3318572
    Thank you pappschlumpf :):):)
    It was installed but inactive

    I'm new to xda and to xposed, root and Cyanogen(oh actually I mean Leneage OS, Cyanogen died about a year ago..).
    I run this all on my HTC One M7 and don't feel like using Google apps under any circumstances :eek:… Alas, I NEED EXPOSED :D.

    I got the same error as OP said here after my first installation.

    I have installed Xposed now but it says it's installed but not active, see log for more information.
    But there is no log to find in the xposed folder?
    How do I fix this?
    Thanks in advance. :)

    The installer had no error, but xposed wasn't 'installed'.
    When I read this post I thought what PS2004 said must have been false:
    It is in fact possibly working.
    Activate a module and see.
    I tested Custom Appsettings to change Dialer DPI and it works :)

    I tried reinstalling xposed.
    I tried all sorts of ways of reinstalling the xposed framework, patching and installing just using root.
    Still this HTC gave me the same error.
    Then I tried this:
    really easy open root explorer and go to
    there must be a file name disable just delete it and reboot ur phone
    if I help pls gv me thanks

    And my reaction was pretty similar to this:
    the sam eproblem is also occuring with me
    but i did.nt have the file that u stated...
    what to do now

    ---------- Post added at 12:06 PM ---------- Previous post was at 12:04 PM ----------

    i have the same problem
    but i didn.y find any such file that u stated , now what the solution
    kindly please revert me back

    The /data/data/de.robv.android.xposed.installer folder didn't exist even though I was surprised to see /data/data/ existed(I'm a bit of an Android noob, I know).
    Out of my deep desperation I even cleaned the Dalvik cache just to be sure that everything was actually in place..
    That didn't work either.

    So I got thinking:
    If it's already installed but inactive.. and my setting for activating it was already set to active, it didn't work.
    What if it's actually inactive (just like the phone stated), but the xposed installer thinks it's activated?

    So the solution for my problem was:
    1. Open the xposed installer
    2. DISABLE xposed by using the switch in the top corner of the screen
    3. Restart my device(I used the dots in the corner and selected restart device)
    4. Open xposed Installer
    5. Enable xposed
    6. Restart
    7. Open xposed installer

    And voilá, it said "xposed framework version 89 is active."

    I hope this helps everyone else with the problem.
    It works like a charm for me :D :victory: