• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Question] Magisk fbind (folder bind) - links keep disappearing after a few days?

Search This thread
Dec 30, 2018
17
1
Sorry for probably wrong-posting, but I need a solution _fast_!! Can anybody help me _please_?

I'm a Windows user, I don't really know much about Linux-based systems & thus am not able to interpret any logs or do Linux console commands and stuff... and the fbind readme / help isn't all that easy to understand for Linux-illiterates either. Problem:

I mounted a folder from my external SD card to my internal SD by adding the following line to the config.txt file:

from_to InternalFolder .externalfolder

This seems to _work_, my 'old' app (Maverick from Code Sector) now sees all map tile data that is actually on the external card within the internal folder & can access it.

However, after 2 days or so, the folder link suddenly seems to be 'gone' (internal folder shows as empty). Only solution is to reboot the phone, then all is back to normal again.

I already tried to turn off battery savings for the Magisk app and for Maverick, with had no effect.

Question: what could cause this 'disappearance' of an as it seems correctly bound folder? What could I do to keep such links 'alive' even when they are not used/accessed for a longer time? Is there an *easy way* to 'reset' fbind without rebooting the phone? Or did I forget an important command in the config.txt / should I add something beside the above line?

I'm running Android Marshmallow on a Samsung Galaxy S5 mini DuoS