[READ THIS] Got a Boot Loop? Don't post a New Thread!

pulser_g2

Admin Emeritus / Senior Recognized Developer
Nov 27, 2009
19,537
11,591
113
OK so it seems a lot of people are having issues with boot loops when they are messing around with things. First thing. Your phone is NOT bricked or broken.

It's just unable to start due to something missing or broken. Don't panic, there's no issue. I did this the day I got my phone, and there was nobody to "help" as such, so I just fixed it myself.

These are the steps to fix a boot loop. If you do this correctly, it WILL fix it. But you must do it EXACTLY to the letter.

So here we go...

1) Turn off your phone. Unplug it from your computer etc

2) Hold down home, power, and volume UP. This will enter recovery mode. If you are using CF-Root, you'll get CWM recovery. If not, you get stock recovery. It doesn't matter which appears.

3) Choose to wipe user data from the menu.

4) Turn off the phone by long-pressing the power button.

5) Prepare ODIN on your PC by using task manager to kill any KIES processes, then open ODIN.

6) Put your phone into download mode (home + power + volume down)

7) Plug your phone into the computer using the factory USB cable. The leftmost box should go yellow and an ID number will appear.

8) Flash a stock ROM from those available in ODIN format, and the phone will boot correctly.

Alternatively, it is possible to flash VillainROM 1.1 if you are not comfortable in wiping via recovery, or if you cannot do so for any reason (corrupted kernel etc), as it wipes all users data when installing. Simply ignore steps 2 to 4, and flash VillainROM 1.1 via ODIN instead of the stock ROM.

Any questions about boot loops? Ask them here rather than making new threads.

Adding a nice little video from user "dullah"

 
Last edited:

urmybaby

Senior Member
Oct 14, 2010
178
1
0
noted with thx, I wish i had the correct instruction 3 days ago.
one more question, do we have to do one more step to flash the stock kernel after we flash the stock rom?
 
  • Like
Reactions: Taimur Akmal

Dannyboyni

Senior Member
Sep 30, 2010
121
5
0
I plug the phone into the pc, but my drivers dont seem to be working it fails to be recognised. I tried with another Galaxy S II, and this phone does appear on the pc. Im thinking its because my phone isnt in download mode?

Any ideas?
 

JJEgan

Senior Member
Oct 24, 2010
30,216
5,872
243
You can also try just 1 2 3 & 4 and see if phone boots .
Its done just that for me as i try to clear a bootloop from a wipe to stock .


jje
 

jody2k

Senior Member
Jun 3, 2011
1,268
424
113
I have a Boot loop after doing a full reset, It was installed with lightning rom

Now Odin doesnt recognize my phone, thats bacause i'm on other computer now (havnt installed the drivers jet)... i tried installing kies 2.0, didnt help... any suggestions?

Edit: is there no manually way to install you phone on you computer with manual drivers or something.... it's bacause odin still doesnt recognize my phone

EDIT2: I fixed my problem, for everyone that had same issue: http://forum.xda-developers.com/showthread.php?t=961956 => these drivers work
 
Last edited:

jody2k

Senior Member
Jun 3, 2011
1,268
424
113
I have done all the instructions and flashed with a stock rom with odin but my phone still does the boot loop :( any suggestions?

Edit: fixed it with the villainrom, sorry for my post

thx!
 
Last edited:

din5353

Member
Jun 26, 2009
10
0
0
I have done all the instructions and flashed with a stock rom with odin but my phone still does the boot loop :( any suggestions?

Edit: fixed it with the villainrom, sorry for my post

thx!
I also got the boot loop.Here what i have been done:

1.flash villain rom.
2.want to change to lite'ning rom = boot loop
3.clear into factory data reset and flash stock rom = success
4.i still want to use lite'ning rom and flash it = boot loop
5.clear into factory data reset and flash lite'ning = boot loop

Is it somethin wrong with the villain rom or lite'ning rom?
 

Crucio_

Senior Member
May 3, 2011
449
82
0
Ellesmere Port
I plug the phone into the pc, but my drivers dont seem to be working it fails to be recognised. I tried with another Galaxy S II, and this phone does appear on the pc. Im thinking its because my phone isnt in download mode?

Any ideas?
If when connecting phone to your pc and your phone is ON then download the latest version of kies from samsung as this holds the drivers to connect to your computer properly.

If you are talking about when your phone is OFF and using ODIN then it should pick up your phone but you wont be able to flash until you are in download mode.

only other thing id add is try using a different usb port, one that is like a mainboard port not a hub.
 

jody2k

Senior Member
Jun 3, 2011
1,268
424
113
I also got the boot loop.Here what i have been done:

1.flash villain rom.
2.want to change to lite'ning rom = boot loop
3.clear into factory data reset and flash stock rom = success
4.i still want to use lite'ning rom and flash it = boot loop
5.clear into factory data reset and flash lite'ning = boot loop

Is it somethin wrong with the villain rom or lite'ning rom?
Jep having same issues, not really an issue but i'm also stuck with the villain rom :) If i try to flash it with lighting rom i have boot loop
this all has started with a full factory reset, when I was on the lightning rom, the full factory reset caused my bootloop and ever sence the only rom that works on my phone is the villain rom
 
  • Like
Reactions: Taimur Akmal

pulser_g2

Admin Emeritus / Senior Recognized Developer
Nov 27, 2009
19,537
11,591
113
Guys it seems there's an issue with some custom ROMs. VillainROM seems fine, as people can safely return to it.

If you cannot get a ROM to flash, then instead of flashing a custom ROM at the end of the process, ODIN a stock ROM after the wipe. That should fix the issue.

It appears some custom ROMs have a bug with wrong permissions, preventing the system from booting.
 
  • Like
Reactions: johnfre

pulser_g2

Admin Emeritus / Senior Recognized Developer
Nov 27, 2009
19,537
11,591
113
Jep having same issues, not really an issue but i'm also stuck with the villain rom :) If i try to flash it with lighting rom i have boot loop
this all has started with a full factory reset, when I was on the lightning rom, the full factory reset caused my bootloop and ever sence the only rom that works on my phone is the villain rom
Yes, it appears lightning rom can't cope with a full wipe when it's running. VR is set up to work after the full wipe, provided you re-install it via ODIN :)