Reboot Into TWRP Recovery Fail

Search This thread

azfangerrard

Member
Jul 23, 2018
17
4
Kuala Lumpur
Hi,

I've got an Asus Zenfone Pro Max M1 (6/64). And of course I would like to install custom recovery and flash magisk on it.

The thing is after I unlocked the bootloader, and installed the twrp recovery, my device won't reboot into twrp recovery. It goes blank every time and when i reboot normally, it boots up fine. And when I try getting into recovery from there, the stock recovery comes out. Also the same thing happens when I tried to install redwolf recovery.

I tried finding the solution here and everywhere else, but none helped. If anyone could help me, that would be very much appreciated.

Thank you.
 
  • Like
Reactions: rafiraza

dastan4eva

Senior Member
Jul 28, 2014
667
150
There's no solution to this but i also faced same.
Only Trial and Error will work.

Here's what worked for me if i remember correct

Boot to fastboot
flash twrp again (have to do this every time after booting to stock recovery )
Keep holding vol down first
Then press and hold power
It should work now
Its tricky and no one seems have written a guide on why this happens on how to solve this but don't give up, its doable! Best of Luck
 

Tianhe

Senior Member
Mar 16, 2011
659
152
Yes, the issue is there. Try the above method or you can also flash a different version of recovery which if i remember correctly was shared in another forum (I am not sure if XDA rules allow me to say it). It was for those whose TWRP froze, search on forum.
 
  • Like
Reactions: azfangerrard

azfangerrard

Member
Jul 23, 2018
17
4
Kuala Lumpur
There's no solution to this but i also faced same.
Only Trial and Error will work.

Here's what worked for me if i remember correct

Boot to fastboot
flash twrp again (have to do this every time after booting to stock recovery )
Keep holding vol down first
Then press and hold power
It should work now
Its tricky and no one seems have written a guide on why this happens on how to solve this but don't give up, its doable! Best of Luck

Hi, thanks for your suggestion.

I've been trying your suggested method since morning and unfortunately, no joy.
Any other way you might have known?
 
  • Like
Reactions: rafiraza

azfangerrard

Member
Jul 23, 2018
17
4
Kuala Lumpur
Yes, the issue is there. Try the above method or you can also flash a different version of recovery which if i remember correctly was shared in another forum (I am not sure if XDA rules allow me to say it). It was for those whose TWRP froze, search on forum.

Hi, thanks for suggesting this. Although I tried finding it on forum, no success. If you could pinpoint the forum, that would be highly appreciated. Starting to get annoyed with this problem though lol
 
  • Like
Reactions: rafiraza

azfangerrard

Member
Jul 23, 2018
17
4
Kuala Lumpur
PS C:\Users\HP\Desktop\Asus\unlock\unlock> fastboot devices
C4ATAS000000J2E fastboot
PS C:\Users\HP\Desktop\Asus\unlock\unlock> fastboot flash recovery twrp.img
target reported max download size of 536870912 bytes
sending 'recovery' (58328 KB)...
OKAY [ 1.250s]
writing 'recovery'...
OKAY [ 0.000s]
finished. total time: 1.250s
PS C:\Users\HP\Desktop\Asus\unlock\unlock> fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 1.259s]
booting...
FAILED (remote: unknown command)
finished. total time: 1.259s
PS C:\Users\HP\Desktop\Asus\unlock\unlock>

Also failed to load through command.
Tried changing the twrp.img name to recovery.img, still the same.
 

azfangerrard

Member
Jul 23, 2018
17
4
Kuala Lumpur
Bud I am using the twrp which is in the link
But this one cannot flash pie roms
But I am r u using other than these

Ah I see, now I understand.

The solution to your problem is somewhere in this thread https://forum.xda-developers.com/asus-zenfone-max-pro-m1/development/recovery-twrp-3-2-1-x-t3787134

I noticed someone (user: Jide1 if I'm not mistaken) posted the twrp version that's compatible with pie rom which has problem loading into twrp. Look it up.
 

Niki Exodia007

Senior Member
Apr 28, 2017
383
166
Ah I see, now I understand.

The solution to your problem is somewhere in this thread https://forum.xda-developers.com/asus-zenfone-max-pro-m1/development/recovery-twrp-3-2-1-x-t3787134

I noticed someone (user: Jide1 if I'm not mistaken) posted the twrp version that's compatible with pie rom which has problem loading into twrp. Look it up.

Buddy searched it but the file does not exist
Can you send the file in pm if you have

---------- Post added at 05:39 PM ---------- Previous post was at 05:35 PM ----------

Hey mate, this is it. I looked it up

https://www.dropbox.com/s/66kndzisymdq44t/twrp-3.2.3.0(pie)stockboot.img?dl=0

Again, thanks to @jide1

Yes I looked the same link
But the file is deleted

---------- Post added at 05:41 PM ---------- Previous post was at 05:39 PM ----------

Hey mate, this is it. I looked it up

https://www.dropbox.com/s/66kndzisymdq44t/twrp-3.2.3.0(pie)stockboot.img?dl=0

Again, thanks to @jide1

Yes I looked the same link
But the file is deleted
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    There's no solution to this but i also faced same.
    Only Trial and Error will work.

    Here's what worked for me if i remember correct

    Boot to fastboot
    flash twrp again (have to do this every time after booting to stock recovery )
    Keep holding vol down first
    Then press and hold power
    It should work now
    Its tricky and no one seems have written a guide on why this happens on how to solve this but don't give up, its doable! Best of Luck
    1
    Hi,

    I've got an Asus Zenfone Pro Max M1 (6/64). And of course I would like to install custom recovery and flash magisk on it.

    The thing is after I unlocked the bootloader, and installed the twrp recovery, my device won't reboot into twrp recovery. It goes blank every time and when i reboot normally, it boots up fine. And when I try getting into recovery from there, the stock recovery comes out. Also the same thing happens when I tried to install redwolf recovery.

    I tried finding the solution here and everywhere else, but none helped. If anyone could help me, that would be very much appreciated.

    Thank you.
    1
    Yes, the issue is there. Try the above method or you can also flash a different version of recovery which if i remember correctly was shared in another forum (I am not sure if XDA rules allow me to say it). It was for those whose TWRP froze, search on forum.
    1
    There's no solution to this but i also faced same.
    Only Trial and Error will work.

    Here's what worked for me if i remember correct

    Boot to fastboot
    flash twrp again (have to do this every time after booting to stock recovery )
    Keep holding vol down first
    Then press and hold power
    It should work now
    Its tricky and no one seems have written a guide on why this happens on how to solve this but don't give up, its doable! Best of Luck

    Hi, thanks for your suggestion.

    I've been trying your suggested method since morning and unfortunately, no joy.
    Any other way you might have known?
    1
    Yes, the issue is there. Try the above method or you can also flash a different version of recovery which if i remember correctly was shared in another forum (I am not sure if XDA rules allow me to say it). It was for those whose TWRP froze, search on forum.

    Hi, thanks for suggesting this. Although I tried finding it on forum, no success. If you could pinpoint the forum, that would be highly appreciated. Starting to get annoyed with this problem though lol
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone