Recent GPS problems

Search This thread

mikeyk101

Senior Member
I had posted this over on the Note 8 Verizon board but dont think it is really a Verizon problem but more of a Note 8 problem and might get a better response here.

Just recently over the last couple months, I have been having a problem with getting a good gps signal in programs such as Waze and Google maps. I have done all kinds of searches and many mention to go into settings and in location settings, turn on High Accuracy. That option is bo longer available and not sure if it was eliminated in Pie. I have been doing all the latest updates and believe I am current. The only thing I have been able to find is to go into settings, then Google, and then Account Services and there I found location. The only choices under Improve Accuracy is to turn on Wifi scanning and Bluetooth scanning which I have done. There no longer is a choice of High Accuracy and the ability to turn GPS on or off like I had in previous phones and previous versions of Android. I have even tried turning on High Performance under Battery Power settings and turned off any choices to optimize battery or disable apps. I ended up downloading 2 different GPS apps from Store, GPS Status and GPS Fix/Optimizer. I will normally use Waze or Google maps through Android Auto. I can tell when there is a problem when the position indicator keeps bouncing all over the place in Waze and cant find exactly where I am. When that happens, I will check on GPS Status and it always shows that it is having a problem acquiring the satellite signals. I will then open up GPS Fix/Optimizer and on the home screen, there is a button that will say Service Off. I press it and it will then read Service On. Switching back to GPS Status will now show that it is starting to acquire multiple satellite signals. When I switch back to Waze, now it is able to show my exact location and begins to work properly.

This is driving me nuts. I never had this problem on any other of multiple different phones or Android versions. I can get GPS working but have to jump through all these hoops each time and it sucks. So what other steps can I do to be able to fire up Waze and have it find me right away?
 

Anonymously_Unknown

Senior Member
Feb 9, 2012
786
154
Kingston
I've had this problem for YEARS on all my Samsung devices running the latest firmware updates and unrooted while connected to a LTE data plan. The issue doesn't affect my other (new) Samsung A30 however. I've always had the latest note series since the Note2, 3, 4, 5, 8.

If I have my Samsung A30 and Note 8 with Google Maps giving me turn by turn directions, my Note 8 (as with my current phones) will stop reporting my location from the very begining of the trip while my Samsung A30 is giving the correct updates. All phones are connected to the same carrier, and same GPS / App settings.

---------- Post added at 08:05 AM ---------- Previous post was at 08:01 AM ----------

What is consistent about all my Notes is that I've been using Samsung Smart Switch to transfer over the data from the previous Note to the next. I wonder if I transferred over some corrupt settings somewhere. No GPS app works as it should for me unless I'm connected to WiFi, or restart my device, then it works for a few minutes, then gets "lost" again.
 

mikeyk101

Senior Member
I've had this problem for YEARS on all my Samsung devices running the latest firmware updates and unrooted while connected to a LTE data plan. The issue doesn't affect my other (new) Samsung A30 however. I've always had the latest note series since the Note2, 3, 4, 5, 8.

If I have my Samsung A30 and Note 8 with Google Maps giving me turn by turn directions, my Note 8 (as with my current phones) will stop reporting my location from the very begining of the trip while my Samsung A30 is giving the correct updates. All phones are connected to the same carrier, and same GPS / App settings.

---------- Post added at 08:05 AM ---------- Previous post was at 08:01 AM ----------

What is consistent about all my Notes is that I've been using Samsung Smart Switch to transfer over the data from the previous Note to the next. I wonder if I transferred over some corrupt settings somewhere. No GPS app works as it should for me unless I'm connected to WiFi, or restart my device, then it works for a few minutes, then gets "lost" again.

The more I've looked into it, it seems to have occurred following the early Feb update. It also seems to have affected S9 phones and Note 9 and 10 and possibly others after they got the Android 10 update. But it seems to be only a Samsung problem. Samsung, Google, and Verizon are all blaming each other instead of trying to figure out a fix. The biggest issue I see is the lack of control of being able to change the GPS from off to on. Without being able to control the GPS, we are at the mercy of the software to do that and it is obviously failing. The only workaround I have found was what I posted above and utilizing GPS Fix/Optimizer and GPS Status apps, I can get both Waze and Google Maps to work properly. It just bugs me that I have to go through several steps to do this instead of just firing up my navigation app and taking off...

And just to add, I too have used Smart Switch many times before and never had problem. It only started recently. As far as the control for GPS, I'm not sure when that setting was removed. I never paid much attention before because it wasnt necessary. But what I did find curious was that Location setting was buried instead of it being one of the main settings. You really have to dig to find it now...
 
Last edited:
[/COLOR]What is consistent about all my Notes is that I've been using Samsung Smart Switch to transfer over the data from the previous Note to the next. I wonder if I transferred over some corrupt settings somewhere. No GPS app works as it should for me unless I'm connected to WiFi, or restart my device, then it works for a few minutes, then gets "lost" again.

I have noticed that certain apps like GPS apps require that you reinstall them onto your new device from scratch. As SmartSwitch doesn't seem to transfer the data files corrected to other Samsung devices.
 

mikeyk101

Senior Member
I have noticed that certain apps like GPS apps require that you reinstall them onto your new device from scratch. As SmartSwitch doesn't seem to transfer the data files corrected to other Samsung devices.

I agree with that but this is not a new device nor have I done any kind of restore or transfer from an old phone in quite a while. All my apps have been fine for over a year now on this Note 8. This only started after the first February "Security" update.
 
I agree with that but this is not a new device nor have I done any kind of restore or transfer from an old phone in quite a while. All my apps have been fine for over a year now on this Note 8. This only started after the first February "Security" update.

Could be that an OS update requires you to install a newer version of the GPS app, which you are currently using
 

mikeyk101

Senior Member
Could be that an OS update requires you to install a newer version of the GPS app, which you are currently using

Im pretty sure that's not the case. My Note is still on Android 9 (Pie) which it has been for almost a year now. It has only gotten security and various minor updates but not any kind of OS update. Note 8 will not be getting Android 10, only security updates. I always update Waze and Google maps anytime an update comes out. I usually update all the other apps at least once a week. The GPS apps that I recently downloaded are the only reason that I am able to access and use my GPS through Waze and Google maps.
 
Im pretty sure that's not the case. My Note is still on Android 9 (Pie) which it has been for almost a year now. It has only gotten security and various minor updates but not any kind of OS update. Note 8 will not be getting Android 10, only security updates. I always update Waze and Google maps anytime an update comes out. I usually update all the other apps at least once a week. The GPS apps that I recently downloaded are the only reason that I am able to access and use my GPS through Waze and Google maps.

That is interesting as I am running Sygic on my Note 8 and it seems to be working just fine. I am rocking the N950N with the latest OS security updates.
 

Anonymously_Unknown

Senior Member
Feb 9, 2012
786
154
Kingston
Could be that an OS update requires you to install a newer version of the GPS app, which you are currently using

I've cleared cache, app data, uninstalled all GPS apps, before re-installing in an unsuccessful attempt to resolve the issue.
I even left the Google Maps "beta testing programme" thinking that a beta copy of the app might have been the issue.
 

mikeyk101

Senior Member
I've cleared cache, app data, uninstalled all GPS apps, before re-installing in an unsuccessful attempt to resolve the issue.
I even left the Google Maps "beta testing programme" thinking that a beta copy of the app might have been the issue.

Download the 2 apps I mentioned and run them. You may have to do that every time before using Google Maps but it should get you working. It's just aggravating to have to go through several steps when I should be able to open the main app I want and have it work.
 

mikeyk101

Senior Member
Something weird just happened. I know that a couple days ago to find the location setting, I had to go to settings, Google, Account Services, and I found location there. Tonight just messing around, I noticed that it is no longer there. Instead, it is now found under settings, and then Biometrics and Security. It is down towards the bottom. Not sure how this happened as I have not received any kind of system updates. Also GPS Status app seems to just run in the background. When I open up Waze, it seems to find my location right away. I will have to keep monitoring this and see if the problem has actually been worked out.
 
  • Like
Reactions: Anonymously_Unknown

Anonymously_Unknown

Senior Member
Feb 9, 2012
786
154
Kingston
Download the 2 apps I mentioned and run them. You may have to do that every time before using Google Maps but it should get you working. It's just aggravating to have to go through several steps when I should be able to open the main app I want and have it work.

I've already done this from even before this thread was created, but as you said, it is frustrating for me to have to do this every 10 or so minutes, as GPS stops working quite frequently on my Note 8. GPS was fine with the bone-stock firmware out of the box.
 

mikeyk101

Senior Member
I've already done this from even before this thread was created, but as you said, it is frustrating for me to have to do this every 10 or so minutes, as GPS stops working quite frequently on my Note 8. GPS was fine with the bone-stock firmware out of the box.

In GPS Status, did you go into Manage A-GPS State and do the reset and download choices? Also did you try the GPS Fix/Optimizer app and run the Fix GPS?
 

Anonymously_Unknown

Senior Member
Feb 9, 2012
786
154
Kingston
t is now found under settings, and then Biometrics and Security. It is down towards the bottom.

Mine is on the February 1, 2020 security patch, and I have that option there as well. All my permissions are enabled for Location for all apps

---------- Post added at 12:37 AM ---------- Previous post was at 12:33 AM ----------

Also did you try the GPS Fix/Optimizer app and run the Fix GPS?

Yes, and yes. 10 minutes later, GPS stops working. It works great if I'm driving past WiFi, however.

I can stream YouTube continuously, so I know my LTE connection is active.
 
  • Like
Reactions: mikeyk101

sjsuguy83

New member
Feb 21, 2020
2
2
Something weird just happened. I know that a couple days ago to find the location setting, I had to go to settings, Google, Account Services, and I found location there. Tonight just messing around, I noticed that it is no longer there. Instead, it is now found under settings, and then Biometrics and Security. It is down towards the bottom. Not sure how this happened as I have not received any kind of system updates. Also GPS Status app seems to just run in the background. When I open up Waze, it seems to find my location right away. I will have to keep monitoring this and see if the problem has actually been worked out.

Hey Mikey,
I've noticed that it has improved, but definitely not resolved.
I'm wondering if a factory reset will revert all software updates? I have an appointment tomorrow at the samsung store, and they are going to factory reset and install the most recent software update via their system rather than an OTA which builds upon other updates. I'm backing up my phone now... which in itself is a pain. If not, I did try the GPS fix and the other GPS software, but I did not try them concurrently together, as I found GPS fix to work better. Ultimately though, I didn't think it helped by itself.
 
  • Like
Reactions: mikeyk101

mikeyk101

Senior Member
I'm bumping this back up to the top. One thing I have noticed is that if I haven't used any location type apps such as google maps or Waze in a while and then open up Android Auto in my Chevy, I have a 50/50 shot of the gps actually working. Actually probably less although occasionally it will work right away. When it doesnt, I have to pull the cord out of the phone disconnecting the Chevy from My Note 8 and even if I only open up Waze or google maps after that, it will still not be able to locate my exact position. When this happens, I have opened up GPS status app and the phone gps is definitely not working. I will then open up GPS fix/optimizer and in the bottom left of the home screen, I will toggle the Service Off to Service On. Checking back with GPS Status, within a couple seconds, it shows that the GPS is now working. I can then plug my phone back into my Chevy and Android Auto with either Waze or Google Maps will be working fine for as long as I'm using it.

I originally thought it was a Samsung software issue. Now I'm starting to wonder. If I use Waze or Google Maps as standalone, they seem to work most of the time. It seems to happen mostly using Android Auto first which then opens the navigation software and if I haven't used any apps that call for location recently. I'm stumped...
 

mikeyk101

Senior Member
Looks like I may be on the right track and Android Auto could be the cause of my issues: https://support.google.com/androidauto/thread/17860576

I also found some other info that Adaptive Battery and battery optimization might also have something to do with it. I turned off adaptive battery by going into settings, then device care, then clicked on the battery icon. There are 3 dots in upper right which let you into battery settings. You can turn off adaptive battery there. Next, I went into settings, then apps, and first selected Android Auto. I clicked on the battery choice and then optimize battery usage. There in the top left, I switched from apps not optimized to all. From there I then found Android Auto and turned it off. I then while ein same screen turned off optimization for Maps and Waze. Unfortunately I dont drive that often and now with the VID, I am driving even less so it may be a while before I can verify that this worked.
 

mikeyk101

Senior Member
An update to this. I reached out to the sub forum for Android Auto over on Google Support and got semi confirmation that the problem could actually be coming from Android Auto. One of the explanations given had something to do with Android Auto trying to get info from the vehicles gps device to make it more accurate but it may have problems communicating with the vehicle gps system. I do not have a dedicated navigation in my vehicle so not sure what it is trying to actually connect to so this could partially explain the problem. Why Android Auto would need to connect to any gps device in vehicle is beyond me because for years, my phones have always relied on the in phone GPS and have worked just fine. Here is that thread:
https://support.google.com/androidauto/thread/45792804?hl=en
 
Last edited:

ultimase

Member
Jun 9, 2005
12
0
So I'm having the same issue on an unbranded note 8. But I'm not using android auto. I can use gps tools and it holds a lock fine. But if additional programs are launched, waze, maps, jbv1 I lose lock.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Something weird just happened. I know that a couple days ago to find the location setting, I had to go to settings, Google, Account Services, and I found location there. Tonight just messing around, I noticed that it is no longer there. Instead, it is now found under settings, and then Biometrics and Security. It is down towards the bottom. Not sure how this happened as I have not received any kind of system updates. Also GPS Status app seems to just run in the background. When I open up Waze, it seems to find my location right away. I will have to keep monitoring this and see if the problem has actually been worked out.
    1
    t is now found under settings, and then Biometrics and Security. It is down towards the bottom.

    Mine is on the February 1, 2020 security patch, and I have that option there as well. All my permissions are enabled for Location for all apps

    ---------- Post added at 12:37 AM ---------- Previous post was at 12:33 AM ----------

    Also did you try the GPS Fix/Optimizer app and run the Fix GPS?

    Yes, and yes. 10 minutes later, GPS stops working. It works great if I'm driving past WiFi, however.

    I can stream YouTube continuously, so I know my LTE connection is active.
    1
    Something weird just happened. I know that a couple days ago to find the location setting, I had to go to settings, Google, Account Services, and I found location there. Tonight just messing around, I noticed that it is no longer there. Instead, it is now found under settings, and then Biometrics and Security. It is down towards the bottom. Not sure how this happened as I have not received any kind of system updates. Also GPS Status app seems to just run in the background. When I open up Waze, it seems to find my location right away. I will have to keep monitoring this and see if the problem has actually been worked out.

    Hey Mikey,
    I've noticed that it has improved, but definitely not resolved.
    I'm wondering if a factory reset will revert all software updates? I have an appointment tomorrow at the samsung store, and they are going to factory reset and install the most recent software update via their system rather than an OTA which builds upon other updates. I'm backing up my phone now... which in itself is a pain. If not, I did try the GPS fix and the other GPS software, but I did not try them concurrently together, as I found GPS fix to work better. Ultimately though, I didn't think it helped by itself.
    1
    So I'm having the same issue on an unbranded note 8. But I'm not using android auto. I can use gps tools and it holds a lock fine. But if additional programs are launched, waze, maps, jbv1 I lose lock.

    Même problème mais réglé aujourd'hui. Décocher l'optimisation de batterie sur l'application système "fused location".