• We are moving to xdaforums.com!

    Posts made between now and when the migration is complete will not be carried over.
    You will be automatically redirected once the migration is complete.

Recover Data from a broken device

Search This thread


New member
Feb 13, 2022
Hi Everyone,

I am turning to you for help in a dire situation.

I've recently dipped my OnePlus 7T Pro a bit too much into the water, and turns out, waterproofing works both ways. To cut it short, the device is operational, boots into the OS, but immediately freezes on boot completition. I've taken it to a repair shop, and they said, that the whole device is rusted on the inside, with zero chance of fixing.

I've managed to boot it into recovery mode, hoping that I can somehow pull my personal data.

The device itself has unlocked bootloader, and running the latest hardened LineageOS, rooted with magisk, and of course, the lineage recovery as well.

I can enable and access adb inside recovery, but I only see the option to mount the system partition, and adb pull only pulls system if I run it. I've tried to mount the data partition, but somehow it is empty (in adb shell, which is in root mode, I've ran mount /data /data and same with sdcard, but adb pull / still only produces system, not my personal data. I am somewhat of a noob, so there is a major possibility that I've did something wrong, my google-fu failed me.

I would be glad, if anyone could suggest anything to recover my data somehow.

Thank you for reading, and Have a Great Day!


Senior Member
Jun 23, 2020
Samsung Galaxy Note 10+
The cpu and memory chipsets are likely BGA form factor. If the corrosion is underneath them the outlook isn't good. Is the phone completely dry now?
If there's any doubt disconnect the battery and liberally flush with anhydrous isopropyl alcohol. Pull as many connectors as possible first, carefully, and take a few pictures before doing so. Then displace as much of the alcohol as fast as possible. Use clean, dry low pressure air if available, carefully. Put in a warm 80-100F, dry room with a fan on it for at least a day. Stand it or the pieces on end.

If no one here has a recovery solution that works try disassembling it and cleaning the corrosion enough to make it bootable. It may be on the pins of the ribbon connector contacts. Maybe a peripheral assemble like the cam is killing the boot. You may be able to use a toothbrush to carefully remove enough to get it operational for a short time. Use small amounts of water then anhydrous isopropyl alcohol as a final wash/drying agent.

If you had caught the water contamination immediately it may have been salvageable using anhydrous isopropyl alcohol to dry it. The device must be powered down and battery must be pulled asap. Energized exposed metal accelerates the corrosion process greatly. Once corrosion forms on the power buses, contacts, BGA pads, etc it becomes unrepairable. Salt water is extremely corrosive, fresh water not near as bad.


New member
Feb 13, 2022
Thank you for your suggestions blackhawk!

Unfortunatelly, the repair shop already went through with these practices, they've used deoxidizing agents, cleaned up the mainboard as good as possible, and disconnected everything but the battery and screen from the mainboard, still no luck.

It was in fact thermal water, so maybe somewhere between fresh and salt, due to high mineral concentration.

I do not know what could causes the system freeze, as recovery/fastboot runs fine, and the whole boot process completes.

I'll still holding my hope out for someone with some recovery/adb magic. :)


New member
Feb 6, 2015
Just a bit of an update, I've also posted this to the 7TPro TWRP Thread in search of answers:

Since no answers came, I tried to flash TWRP over the Lineage Recovery, which in turn, works, abeit, with flaws, since I simply cannot decryt the data partition. I know that the password is correct, still, no luck.

I hope it's a good sign, that I can see the folder structure/files at least encrypted, but another issue is, with TWRP MTP mount, I cannot copy those files from the phone to the PC (errors out on copy).

Right now I'm wondering, is there a TWRP version for this phone that could decrypt my data? (A10)

Tested: 3.6.0_11 & 3.6.1_11 both FBEv2 and FBEv1 no luck. FBEv2 is the correct one as, my ROM is custom:

Also the FBEv1 shows 0MB data, and cannot mount it even in the encrypted format.

Any help is apprecated, Thank you all in advance!