[RECOVERY][11.0][UNOFFICIAL] TWRP 3.7.0_11-0 for Unihertz Atom L and XL [Alpha] [2022-10-05]

Search This thread


Senior Member
Nov 1, 2006
The problem with no touch in recovery is with a hardcoded boot-mode detection which disables the touch driver when booting into recovery mode. Therefore I had to "modify" the kernel in my TWRP build to behave mirrored (no touch in system while touch in recovery).

Hey. I just saw this. How did you modify this kernel? I have wanted to do the same thing for my phone, but I can't find any specifics to patch this boot-mode detection.


Senior Member
Nov 1, 2006
See my guide
Ah, thanks for this. That's quite a read. I do recall seeing that hovatek guide. I tried to follow it, but I do not have access to that ominous tool you mention. If I send you the recovery image kernel, would you be able to modify it for me?


Senior Member
Jul 28, 2016
Samsung Galaxy S5 Mini
Ah, thanks for this. That's quite a read. I do recall seeing that hovatek guide. I tried to follow it, but I do not have access to that ominous tool you mention. If I send you the recovery image kernel, would you be able to modify it for me?
I could do that but you wouldn't learn anything from that ;)
There is a possibility to get that tool by searching for "github" and it's name in google.

If you want to take the easy way out I'd need the symbols besides the kernel. Contact me via PM.


Senior Member
Jul 28, 2016
Samsung Galaxy S5 Mini
After a long time of tampering, testing, failing and starting over from scratch I'm finally confident enough to present you my newest releases. Sadly, I couldn't figure out how to get decryption to work (won't boot if enabled) but at least everything else is working just fine.

Please be aware that you NEED to upgrade your stock rom release to 2021-11 (internally it's 2021-07-05).


Senior Member
Jul 28, 2016
Samsung Galaxy S5 Mini
I just realized that there are in fact TWO different touchpad drivers in the kernel. So I created a new release with both drivers modified to load in recovery mode. Hopefully this will fix that elusive "touchpad not working" bug. Also the new twrp version 3.7.0_11.0 seemed to have been already active in the repos while not officially endorsed yet.

Top Liked Posts

  • There are no posts matching your filters.
  • 2

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    This is a TWRP 3.7.0_11-0 recovery for the Helios P60 based Atom L (Atom_L) and Atom XL (Atom_XL), two rugged Android phone released by Unihertz in July 2020.

    This recovery supports both devices as well as both regional variants!
    You need to make sure which device and variant you need!

    Team Win Recovery Project, or twrp for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    Backup your data before trying to decrypt inside TWRP.
    Decrypting could potentially lock you out from your ROM. I learned that the hard way.
    Although I'm quite certain that I fixed the underlying issue it's better to be save than sorry.

    Not Working
    • Decryption (still work in progress)
    • MTP under Linux
    • You tell me
    Atom L EEA (european union)
    Atom XL EEA (european union)
    Atom L TEE (non-european union)
    Atom XL TEE (non-european union)

    How to install
    How to Update


    Common device tree
    Device tree Atom L EEA (european union)
    Device tree Atom XL EEA (european union)
    Device tree Atom L TEE (non-european union)
    Device tree Atom XL TEE (non-european union)
    Bug reporting

    * Modified the second touchpad driver to work in recovery mode too
    * Switched to TWRP 3.6.2_11-0
    * July 2021 vendor updates included (needs vendor to be upgraded manually)
    * Decryption is not working (for now)
    2022-01-30 (Only for Atom L TEE)
    * Changed the patched kernel to the one from the Atom L EEA
    * Security string set to 2099-12-05
    * May vendor updates included (needs vendor update to be applied beforehand)
    * Decryption is fully working now
    * Version bump to TWRP 3.5.2
    * Combining the work for the Atom L and XL
    * Version bump to TWRP 3.5.1
    * Decryption is working now (with the exception of the user scope like /data/media/0 & others)
    * trustkernel daemon (teed) is working now, decryption still doesn't work
    * adb is working now without the need to deactivate mtp
    * Timezone set to europe by default
    * Vibration is back (but turned down)
    * Sideload is working
    * Install zip/img is working
    * Data decryption is not working
    * MTP is not working
    * ADB is working (MTP needs to be disabled)

    Help from other developers is certainly welcome.

    Credit and Thanks

    • TWRP team
    • @PeterCxy for starting the work on the Atom L

    Enjoy! (y)

    XDA:DevDB Information
    TWRP 3.7.0_11-0 for Unihertz Atom L and XL, ROM for the Android General


    Source Code: https://github.com/ADeadTrousers/twrp_device_Unihertz_Atom_LXL

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: TWRP

    Version Information

    Created 2021-01-15
    Last Updated 2022-10-05
    Now Atom L and Atom XL are supported as well as both regional variants EEA (european union) and TEE (non-european union)
    Got any Crypto addresses or PayPal that I can send gratitude to?
    Your happiness is gratification enough.:cool:
    When following tutorial to use SP Flash Stock, it only links to EEA Stock ROMs. I'm just following that guide because it's the only one that mentions SP Flash like you said to use but honestly I'm quite confused as to how flashing the stock rom will fix it from getting stuck when trying to boot into TWRP recovery.
    Like I said: It's the bootloader causing this. It needs to be the one compatible with the kernel (used by LOS and TWRP). So in order to change between the various devices and variants you need to change the entire ROM portion including bootloader and modem.

    Ok, the google drive link is a little bit misleading. I'll have to correct it. Nevertheless on the top of the page you should find a navigation bar (Software_Firmware > Atom_XL > EuropeanUnion_EEA). Simply click on "Atom_XL" and then select "None_EEA".
    Strange things. Wiping didn't help, I've tried many recovery images, no success.
    Finally, I've saved some time and successfully built recovery at home (now just L EEA), and now it is not rebooting at least :)
    When rebooted into recovery from CLI, it shows TWRP splash, but it is not reacting on touch/keys.
    logcat shows repeating
    06-09 05:32:46.450 323 323 W ServiceManagement: Waited one second for [email protected]::IKeymasterDevice/default 06-09 05:32:46.451 323 323 I ServiceManagement: getService: Trying again for [email protected]::IKeymasterDevice/default...
    so I think now it should be encryption related problem, as you wrote before.

    When booted into recovery by pressing Volume - button, it boots into "old CWM recovery-looking menu as I know from years ago" - simple list, moving in menu by volume buttons works, confirming with power button, but - that menu is in chinese :)

    Today or tomorrow I will get some time again for playing with phone, I will try to build and try recovery images also for XLs and TEE region, and also I will play with that encryption.