• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RECOVERY] [11] [OFFICIAL] TeamWin Recovery Project (7T / 7T Pro)

Search This thread
When it's literally the same day of the new release for official..
Everyone: (myself included)
6abe2b8a376edd673c34dbe25294f88d.jpg

But seriously it might be day or two, a week, maybe longer, who knows. Lossy does have a life besides this.
But on the plus side it might be easier because it mentions FBE decryption fixes and stuff of that nature.
I'd love to see "reliable" restoration come from this.
 

fullydeveloped

Senior Member
Jul 29, 2014
166
17
Is there a way to save and restore system settings manually? They aren't preserved with twrp backup and restore (of boot, data, dtbo, and super). Not sure how it works with A11.
 
I'm having an issue decrypting my data. I was running OOS10 (not sure what version, I got my 7T Pro back in April 2020 and rooted it straight away and hadn't updated since) and it seems my system partiton got corrupted (fell asleep, phone died, woke up and plugged it in and constantly got sent back to recovery mode when trying to boot, used the common techniques to try to get out of it but it didn't work and after booting twrp it said I did not have an installed system on slot b so I suppose that inidicates it was indeed corrupted). I also tried booting on slot a and it gets to the boot up animation but remains stuck there (as in the animation continues for ever).

So I installed different versions of the oos and sdcardfs twrp in this thread but I cannot get decryption to work. I had both a pattern and fingerprint set up (pattern only at boot up or as a backup for the fingerprint) but TWRP asks for neither and only has an option to input a password.

At this point I'm at a loss and would be grateful for anyone who can maybe help recover some of my data (only had some of it backed up unfortunately). I know it's likely that it's lost but I'm willing to try just about anything. I've got some experience with android rooting and adb and fastboot and I'm perfectly comfortable with terminals and command lines. And I don't know if it's allowed but I'm willing to make a fairly generous donation (think $50-100 depending on how much I'm able to recover) to anyone who helps successfully.

Thanks in advance
 
Last edited:

Lossyx

Senior Member
Jan 14, 2014
1,545
820
OnePlus 7T Pro
I'm having an issue decrypting my data. I was running OOS10 (not sure what version, I got my 7T Pro back in April 2020 and rooted it straight away and hadn't updated since) and it seems my system partiton got corrupted (fell asleep, phone died, woke up and plugged it in and constantly got sent back to recovery mode when trying to boot, used the common techniques to try to get out of it but it didn't work and after booting twrp it said I did not have an installed system on slot b so I suppose that inidicates it was indeed corrupted). I also tried booting on slot a and it gets to the boot up animation but remains stuck there (as in the animation continues for ever).

So I installed different versions of the oos and sdcardfs twrp in this thread but I cannot get decryption to work. I had both a pattern and fingerprint set up (pattern only at boot up or as a backup for the fingerprint) but TWRP asks for neither and only has an option to input a password.

At this point I'm at a loss and would be grateful for anyone who can maybe help recover some of my data (only had some of it backed up unfortunately). I know it's likely that it's lost but I'm willing to try just about anything. I've got some experience with android rooting and adb and fastboot and I'm perfectly comfortable with terminals and command lines. And I don't know if it's allowed but I'm willing to make a fairly generous donation (think $50-100 depending on how much I'm able to recover) to anyone who helps successfully.

Thanks in advance
Try flashing stock boot image, seems like a module or something is causing issues.
 

HueyT

Senior Member
Apr 3, 2014
4,378
2,031
New Albany, IN
OnePlus 7T
I'm having an issue decrypting my data. I was running OOS10 (not sure what version, I got my 7T Pro back in April 2020 and rooted it straight away and hadn't updated since) and it seems my system partiton got corrupted (fell asleep, phone died, woke up and plugged it in and constantly got sent back to recovery mode when trying to boot, used the common techniques to try to get out of it but it didn't work and after booting twrp it said I did not have an installed system on slot b so I suppose that inidicates it was indeed corrupted). I also tried booting on slot a and it gets to the boot up animation but remains stuck there (as in the animation continues for ever).

So I installed different versions of the oos and sdcardfs twrp in this thread but I cannot get decryption to work. I had both a pattern and fingerprint set up (pattern only at boot up or as a backup for the fingerprint) but TWRP asks for neither and only has an option to input a password.

At this point I'm at a loss and would be grateful for anyone who can maybe help recover some of my data (only had some of it backed up unfortunately). I know it's likely that it's lost but I'm willing to try just about anything. I've got some experience with android rooting and adb and fastboot and I'm perfectly comfortable with terminals and command lines. And I don't know if it's allowed but I'm willing to make a fairly generous donation (think $50-100 depending on how much I'm able to recover) to anyone who helps successfully.

Thanks in advance
Restore all but data. Boot up oos10 but skip setup. Remove all lock screen and FP. Boot back into twrp. Restore data. Reboot to rom twice (1st time has black screen, 2nd time all fixed)
 
Try flashing stock boot image, seems like a module or something is causing issues.
That's what I tried initially but it didn't make a difference. I was still stuck in a recovery loop. I can't even seem to get slot a running either (which should have been fine as I never did any OTA).

Edit: I see some errors in the twrp log:
Updating partition details…
Failed to mount ‘/system_ext’ (Block device required)
…done
Unable to mount storage
Unable to mount /data/media/TWRP/.twrps
Unable to mount /data/media/TWRP/.twrps
 
Last edited:

HueyT

Senior Member
Apr 3, 2014
4,378
2,031
New Albany, IN
OnePlus 7T
Is the version with the oos suffix (as opposed to the oos11) not meant to work with OOS10?

Also, is there no way to support decryption by the unlock pattern? I think I've seen other twrp versions on other devices support it. Or what about a modded stock recovery?
Yes, made for OOS11. It can decrypt via pattern but best to remove lock screen when restoring encrypted data
 
Yes, made for OOS11. It can decrypt via pattern but best to remove lock screen when restoring encrypted data
Yeah but that doesn't help if you were using OOS10 and can't get into the system to disable the locks.

I'm just hoping someone at some point makes it work with OOS10 (even though I know it's not super likely since it's an older version). In the meantime I bought a new (budget) phone just so I wouldn't have to wipe and reinstall (and thus lose all hope to recover the data) my OP 7T Pro...
 

mrk2815

Senior Member
May 16, 2012
1,457
324
burbank
thanks brandon, mine is a one plus 7t hb1907 supposably t-mobile but its running oxygen global rom when i went into about section of the device when i bought it off of amazon as an unlocked refreshed unit. hoping ot keep fora good amount of time. asi tend to keep devices around for a good amount of time.
 

android bot

Member
Oct 24, 2014
31
6
31
OnePlus 3T
OnePlus 7T Pro
I am a noob with respect to custom recoveries. I am fed up of OOS so thought of trying out custom roms. I am on OOS 11.0.4.1. Which of these twrp versions will work for oneplus 7t pro devices running OOS 11.0.4.1 ? If some one can confirm this, I might start on this process.. Can someone help me here. Any help is appreciated.
 
Last edited:

Top Liked Posts