Development [RECOVERY] [11] [OFFICIAL] TeamWin Recovery Project

Search This thread

blackbile

Senior Member
Oct 16, 2009
182
36
Maybe you did it wrong. First boot into twrp/ wipe / advance wipe / select data / change file system / change file system / f2fs / swipe. Then go back to hom / advance/ flash current twrp. Return to hom/ install - select the file twrp-install3.6.0.zip.
I did it again like you said - doesn't work either!
0mb internal memory after reboot to twrp.
 

Aitra

Senior Member
May 17, 2021
62
5
I did it again like you said - doesn't work either!
0mb internal memory after reboot to twrp.
after putting the data in f2fs format, format "yes" again. Then move the file systemrw.zip to the device memory to flash. It only works when you already have twrp permanently and enter twrp right from "settings" or the hard key, not with the command "fastboot boot twrp.img"
 
Last edited:

Aitra

Senior Member
May 17, 2021
62
5
I did it again like you said - doesn't work either!
0mb internal memory after reboot to twrp.
This image is a confirmation of what I have said. It is also possible that because I do not know English, the presentation is not clear and you have misunderstood.
Screenshot_2021-12-26-08-32-34.png
 

Aitra

Senior Member
May 17, 2021
62
5
I unlocked the boatloader and went straight to the MIUI 13 version, it even enters the twrp, but everything is reset with nothing, I restart and it loses the twrp, what am I doing wrong here, could you help me?
You need a new memory card inside contains files: twrp-installer v3.6.0-renoj.zip to flash. First of all, you boot into twrp3.6.0 and then press "advance", press "flash current twrp", return to hom press "installer", select SD memory card and then flash the file "twrp-installer-3.6.0-renoj.zip". and you've got twrp forever.
 
Last edited:

Rainman67

Member
Jan 21, 2013
41
20
Hi,
today i had to restore a TWRP-Backup. All seemed to be fine, no error message at the end, but when i want to reboot the phone, there is only the "Mi-Logo" in the Display. I waited 20 minutes, but the phone won't boot. Please help!
 

MyCake

Member
Jun 8, 2014
21
2
Switzerland
It broke my partitions, I am now 100% stuck in fastboot.
I will now try to flash the fastboot ofw... I hope it will fix it.

EDIT: This fastboot ROM saved my renoir: renoir_global_images_V12.5.5.0.RKIMIXM_20210805.0000.00_11.0_global_9f22a26eac.tgz
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 16



    Introduction:

    Team Win Recovery Project or TWRP for short, is a custom recovery built with ease of use and customization in mind. We started from the ground up by taking AOSP recovery and loading it with the standard recovery options, then added a lot of our own features. It's a fully touch driven user interface , no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    Key Features:

    Touchscreen driven with real buttons and drag-to-scroll
    XML-based GUI that allows full customization of the layout true theming!
    Settings are saved to the sdcard and persist through reboots
    Ability to choose which partitions to back up and which to restore
    Ability to choose to compress backups now with pigz (multi-core processor support for faster compression times)
    Onscreen keyboard
    Easy selection of internal/external storage

    In addition to the above new features, TWRP features a scripting engine that allows an app to send commands to the recovery for the recovery to perform during startup. We call this scripting engine OpenRecoveryScript. This engine will be put to use immediately in the GooManager app. GooManager will be able to install recoveries automatically for most supported devices. The app will also let you choose to install multiple zips from within Android, wipe, and run a backup.

    We are looking for other talented developers, themers, and device maintainers if they are interested in helping with a free, open source project.

    Source Code:

    GitHub - https://github.com/TeamWin/android_bootable_recovery

    Gerrit Instance - http://gerrit.twrp.me

    If you have made your own TWRP build for an unsupported device, please let us know. We might add your build to the list of unofficial builds. Bear in mind that we are working hard to add more devices and we may add your device to our official build list later.


    Hello, this is TWRP, for Mi 11 lite 5G

    bugs:
    backup/restore is unreliable
    adb sideload and fastbootd

    Installation:
    1. fastboot boot twrp.img
    2. go to Advanced > Flash Current TWRP
    3. after that is done, if you were using a custom kernel, reflash it now
    4. if you were using magisk, reflash it now

    Updating to a newer build:
    1. download new build to internal storage
    2. go to Advanced > Install Recovery Ramdisk
    4. select the new image
    5. after that is done, if you were using a custom kernel, reflash it now
    6. if you were using magisk, reflash it now

    Send me a beer: Crypto (Preferred) | PayPal

    Contributors:
    @VladV1V , @TheMalachite

    Tree:

    Kernel:
    https://github.com/VladV1V/kernel_xiaomi_renoir

    Telegram group: https://t.me/NSSFB

    Download: https://twrp.me/xiaomi/xiaomimi11lite5g.html
    8
    Official builds have started

    5
    @Nebrassy
    Thank you for bringing TWRP to this excellent device.
    Unfortunately this is the buggiest TWRP I have ever used and it also has a lot of limitations.
    Is there any active development to fix all the issues?
    4
    Then i tried the TWRP-Backup again and all was working fine!
    ....and for those, who are worry about restoring a TWRP-Backup: I tried this too, and restoring of the TWRP-Backup worked fine too! (y)
    4
    I confirm that a bakcup works by copying it to the PC via the internal memory.

    But I still don't understand why you can't mount an SD card via TWRP. The most frustrating thing is that there is no communication about the lack of support for SD cards and other USB sticks, so this bug is still not fixed.

    Is it due to the new snapdragon 780G processor still not well mastered?

    A lack of time for volunteer developers, despite the fact that it is now more than 4 months?

    In short, staying in the dark for lack of communication is more than frustrating...

    Translated with DeepL
    Lack of time, lack of testers, many other more important stuff to work on, and I don't have the device

    Otg does not work on any GKI devices in twrp, though I wasn't aware that sdcard had issues, join my tg group and tag me if you can test