• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[RECOVERY][3-2-12]Clockwork Mod Recovery

Search This thread

imnuts

Inactive Recognized Developer
Jul 27, 2007
3,808
3,174
West Chester
www.imnuts.org
So I spent the weekend working on some things, and one of them was trying to get CWM fixed up. I believe that I have all of the problems fixed, but I can only do so much testing on my own. The button mappings work, and I have been using this and similar versions (bugfixes and such added since then) for about a week now. I completely removed backup/restore as my attempt to get it to work properly didn't work, so I'm guessing something else is wrong with it than what I initially found and reported to Koush. I will try to keep this updated as updates come out for CWM as well. Flash with Odin/Heimdall

Button Mapping
Vol Up / Home - Go up
Vol Dn / Menu - Go Down
Back - Go Back
Power / Search - Select Item

Flashing Tips
Use the rear USB Ports on your computer if possible, and without a USB extension cable.
When in Download mode with the battery out, put the battery back in and uncheck Auto-Reboot in Odin. When done flashing, remove the battery and USB cable, put the battery back in and reboot - credit to jami2976

Changelog
0302
"Fix" fix_permissions - mount all partitions under mounts and storage prior to running

1209
Put fat.format back in place so restore and data wipes work properly.

1207
CWM 5.x Update

0817
Fix backup/restore

0807/0808 - Not posted
Update to the latest CWM source
Fix the fix_permissions script

0730
Using stock CWM Source
-> No more advanced options that aren't in stock CWM

0713
More updates, hopefully fixed restore problem too.

0709
Updated to the latest CWM Source
Backup/Restore has been added back
-Has had some successful testing, but no large scale testing or use so be careful for now
Odin dump function expanded

0611
Initial release

Known Issues
CWM Getting over-written by stock recovery - Flash a custom kernel or delete /system/etc/install-recovery.sh
Failed to mount /sdcard error(s) - Perform the following commands with ADB:
Code:
adb shell
umount /sdcard
rm -f /sdcard
mkdir /sdcard
exit
Type each line in and press enter. Do not skip a line, or you may loose data ;) It seems to have worked for anyone that tested and had this issue.

Download
 
Last edited:

papi92

Senior Member
Nov 15, 2009
2,436
1,565
Everything works for me. Thank you. I didn't test backup tho or restore

Sent from my SCH-I510 using XDA Premium App
 

ShotgunSam

Senior Member
Dec 12, 2010
148
9
Huntsville
So I spent the weekend working on some things, and one of them was trying to get CWM fixed up. I believe that I have all of the problems fixed, but it needs testing to verify. If anyone would like to try it out and see if there are any more problems, please download and flash with Odin. The button mappings work, and I have been using it for a day and flashing things and that works as well. I have not tested out backup/restore, though I did find an issue that may have been causing the problem and put in a fix, so I'm hoping that it works as well. If all goes well, we can start using this full time, or go back and look for anything else that may be causing problems.

Button Mapping
Vol Up/Down - Navigate through the menus
Power - Select Item
Menu/Home/Back/Search - Go Back to the previous menu

Download

Ill test it. But first, did the people who bricked their phone ever find a way to unbrick it after trying a cwm restore?
 

imnuts

Inactive Recognized Developer
Jul 27, 2007
3,808
3,174
West Chester
www.imnuts.org
Ill test it. But first, did the people who bricked their phone ever find a way to unbrick it after trying a cwm restore?

Some have and some haven't. People that are having issues can't flash the package that I put together for the fix, but others have flashed it without issue.

One thing that may also be "broken" is data wipe in CWM, as it may get stuck on deleting /sdcard/.android_secure and I'm looking for why it's doing it and how to fix it.
 
  • Like
Reactions: ijustdontcare

papi92

Senior Member
Nov 15, 2009
2,436
1,565
My data wipe is good. I'm still trying to grow a pair and backup and restore lol

Sent from my SCH-I510 using XDA Premium App
 

RaptorMD

Senior Member
May 2, 2010
1,820
228
Imnuts can we install this CWM any other way than Odin? I have been trying to get the Voodoo Kernel and CWM-2 installed but its an either or situation. If I install Voodoo kernel then CWM, I get a soft brick even though CWM says it passed.
 

imnuts

Inactive Recognized Developer
Jul 27, 2007
3,808
3,174
West Chester
www.imnuts.org
Imnuts can we install this CWM any other way than Odin? I have been trying to get the Voodoo Kernel and CWM-2 installed but its an either or situation. If I install Voodoo kernel then CWM, I get a soft brick even though CWM says it passed.

You can flash with Heimdall as well, just extract and put recovery.bin in the proper place.
 

papi92

Senior Member
Nov 15, 2009
2,436
1,565
Well it doesnt work lol
1. it backsups fine it seems.
2. During restore it said it couldnt mount system but hey it formatted it
3. seemed to flash a rom but everytime i reboot it goes into cwm.
4. I was able to odin fine
 

papi92

Senior Member
Nov 15, 2009
2,436
1,565
nevermind im stuck in recovery now. Can i restore with odin even tho i have the voodoo lagfix enabled before cwr bricked my phone?
 
  • Like
Reactions: Blaqhawk

imnuts

Inactive Recognized Developer
Jul 27, 2007
3,808
3,174
West Chester
www.imnuts.org
You can flash ANY Odin file to your phone regardless of what you were on and what you are flashing as long as you aren't flashing a kernel that does not understand EXT4 to your phone and you had lagfix enabled. If you are flashing a non-voodoo kernel (or one that doesn't understand ext4) make sure you are also flashing /system, /data, /cache, and /dbdata so that they get wiped out.
 

papi92

Senior Member
Nov 15, 2009
2,436
1,565
well my problem is i had lagfixed enabled. I flashed your cwr and i knew the risk. Know im stuck with the same problem as everyone else. lol so how do i disable lagfix? i can only get into download mode and the ed1 cwr fix isnt flashing. I still have lagfix since i never disabled before trying restoring. My backup was a rom that had the lagfix.
 

brabe1979

Member
Sep 19, 2010
49
1
well my problem is i had lagfixed enabled. I flashed your cwr and i knew the risk. Know im stuck with the same problem as everyone else. lol so how do i disable lagfix? i can only get into download mode and the ed1 cwr fix isnt flashing. I still have lagfix since i never disabled before trying restoring. My backup was a rom that had the lagfix.
Are you getting the stock recovery screen now? and the cmdline=7 message?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 45
    So I spent the weekend working on some things, and one of them was trying to get CWM fixed up. I believe that I have all of the problems fixed, but I can only do so much testing on my own. The button mappings work, and I have been using this and similar versions (bugfixes and such added since then) for about a week now. I completely removed backup/restore as my attempt to get it to work properly didn't work, so I'm guessing something else is wrong with it than what I initially found and reported to Koush. I will try to keep this updated as updates come out for CWM as well. Flash with Odin/Heimdall

    Button Mapping
    Vol Up / Home - Go up
    Vol Dn / Menu - Go Down
    Back - Go Back
    Power / Search - Select Item

    Flashing Tips
    Use the rear USB Ports on your computer if possible, and without a USB extension cable.
    When in Download mode with the battery out, put the battery back in and uncheck Auto-Reboot in Odin. When done flashing, remove the battery and USB cable, put the battery back in and reboot - credit to jami2976

    Changelog
    0302
    "Fix" fix_permissions - mount all partitions under mounts and storage prior to running

    1209
    Put fat.format back in place so restore and data wipes work properly.

    1207
    CWM 5.x Update

    0817
    Fix backup/restore

    0807/0808 - Not posted
    Update to the latest CWM source
    Fix the fix_permissions script

    0730
    Using stock CWM Source
    -> No more advanced options that aren't in stock CWM

    0713
    More updates, hopefully fixed restore problem too.

    0709
    Updated to the latest CWM Source
    Backup/Restore has been added back
    -Has had some successful testing, but no large scale testing or use so be careful for now
    Odin dump function expanded

    0611
    Initial release

    Known Issues
    CWM Getting over-written by stock recovery - Flash a custom kernel or delete /system/etc/install-recovery.sh
    Failed to mount /sdcard error(s) - Perform the following commands with ADB:
    Code:
    adb shell
    umount /sdcard
    rm -f /sdcard
    mkdir /sdcard
    exit
    Type each line in and press enter. Do not skip a line, or you may loose data ;) It seems to have worked for anyone that tested and had this issue.

    Download
    6
    0302 is posted. Fix permissions works now, as long as you have everything mounted under mounts and storage.
    4
    Updated. Backup/Restore seem to be working for people now. If you ever receive the error that /system cannot be unmounted, run the following with your phone hooked up via adb.
    Code:
    adb shell umount -l /system
    3
    Hope you can find it -- I have got to get this a custom kernel and ROM on my Charge ASAP --- the battery life is atrocious

    I posted this in the kernel thread,

    Yeah. Here is what you do. Scroll to the menu to your selection, then press home( banana will appear) then press power, and the new menu will appear. After you are off the main menu just use power and back buttons to flash then return to main menu where you will have to press home then power to reboot.

    Cheers
    2
    Trying to fix recovery is on my list of things to do this weekend then ;)