[RECOVERY][3.4.0-0][I01WD]Official/Unofficial TWRP for Asus ZenFone 6 (Stable)

Search This thread

Zormal

Senior Member
Oct 10, 2008
55
3
Thank you for this. It works even better than the official one, which sometimes doesn't find /system/ when on slot A.

Only problem with both is that time and date doesn't seem to work. But adding date to backup names manually is a small bother, so I'm not complaining :)
 

AlDollaz

Senior Member
Nov 1, 2012
438
197
Philadelphia
OnePlus 8
Would this be the correct flashing order?:

Unlock bootloader > flash TWRP img file via fastboot > boot to recovery > in TWRP, flash TWRP installer > in TWRP, flash Magisk > Reboot?

Thanks for any responses. I have this phone coming to me in a few days and want to know what to expect. ?️

Edit: this is pretty much what happened.
 
Last edited:
  • Like
Reactions: kenturky

kenturky

Senior Member
Hi, I successfully flashed TWRP, using the above steps.
I started adb shell using windows powershell(command prompt option wasn't available)
fastboot flash boot_a twrp.img
fastboot flash boot_b twrp.img
and booted into twrp.
flashed twrp installer, flashed magisk, and now I have twrp and magisk.

Now, I want to flash a custom rom. How do I go about doing that? Please let me know soon!

Edit: I had just got my Zenfone today! Flashing phones right away is what I love!
 
Last edited:

sn0maan

Senior Member
May 6, 2014
55
19
The link to the working unoffical recovery isn't working. Could anyone please post the link again?
 

kenturky

Senior Member
You can go to each Custom rom thread in the dedicated forum. Most of them explain clearly how to flash ROMs.

I keep getting this problem when flashing any rom using this twrp
Installing zip file "/sdcard/(ROM file).zip'
Checking for disgest file...
Skipping digest check: no Digest file found
Step 1/2
Step 2/2
updating partition details
done.

I reboot, and it's stuck on rom logo for like forever.
Now I don't have any OS. Stuck on either fastboot or TWRP.
 

EMJI79

Senior Member
Sep 7, 2014
1,959
212
Paris
Apple iPhone 12
Google Pixel 6 Pro
I keep getting this problem when flashing any rom using this twrp
Installing zip file "/sdcard/(ROM file).zip'
Checking for disgest file...
Skipping digest check: no Digest file found
Step 1/2
Step 2/2
updating partition details
done.

I reboot, and it's stuck on rom logo for like forever.
Now I don't have any OS. Stuck on either fastboot or TWRP.

I haven't flashed with latest ROMs and TWRP but you might want to try flashing again Magisk patched boot after flashing Custom ROM.
 

kenturky

Senior Member
Then I don't know. Just do everything again maybe. It could work.

I figured it out. I used some unbrick guide, and it worked, but when flashing this TWRP, I get some sort of error that says "unable to mount /data". /data is on f2fs partition, and only changing the partition to /ext4 works, but the stock rom doesnt boot after that. It's a continuous bootloop. It seems like there's no one on this forum other than you. Dead forum?
 

Top Liked Posts