[RECOVERY][3.4.0-10][Cheeseburger/Dumpling]Official/Unofficial TWRP for OnePlus 5/5T

Search This thread

Sinfamy

Senior Member
Aug 15, 2011
234
62
steamcommunity.com
Hello, everytime I try to boot into recovery it boots into the Qualcomm HS-USB Diagnostics 900E mode, no the recovery.
Flashed the recovery and used fastboot boot recovery.img
 

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
5,968
13,744
31
Ambala
OnePlus 9R
Hello, everytime I try to boot into recovery it boots into the Qualcomm HS-USB Diagnostics 900E mode, no the recovery.
Flashed the recovery and used fastboot boot recovery.img

fastboot boot recovery.img only boots into the recovery image temporarily. If you wish to permanently replace the stock recovery with TWRP, you have to use fastboot flash recovery recovery.img.
 

Sinfamy

Senior Member
Aug 15, 2011
234
62
steamcommunity.com
fastboot boot recovery.img only boots into the recovery image temporarily. If you wish to permanently replace the stock recovery with TWRP, you have to use fastboot flash recovery recovery.img.

Sorry I should have been more clear.
Besides the official recovery, I cannot boot into any TWRP recovery, neither from TWRP.me or from here.
Regardless of whether I boot directly into it, or flash it and select it from the fastboot bootloader, it just goes straight into the Qualcomm recovery mode with the blue LED, and I'm wondering if I'm missing anything / any steps.
 

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
5,968
13,744
31
Ambala
OnePlus 9R
Sorry I should have been more clear.
Besides the official recovery, I cannot boot into any TWRP recovery, neither from TWRP.me or from here.
Regardless of whether I boot directly into it, or flash it and select it from the fastboot bootloader, it just goes straight into the Qualcomm recovery mode with the blue LED, and I'm wondering if I'm missing anything / any steps.

Most likely you messed up your partitions. I recommend using the unbrick tool to restore to stock and start from scratch.
 

calvio

Senior Member
Jul 23, 2009
77
18
A strange thing happened to me: few days ago I updated TWRP to 3.4.0 version without any problem (I'm with Derpfest dumpling). Yesterday I tried to flash first rom upgrade with new TWRP, flashing went fine but after that I couldn't start the phone because it went back to recovery. I tried to recover backup made just before upgrading and after recover it went in fastboot mode. No way to restart the phone. After various attemps and when I started to be afraid of not finding a solution (I thought it was a rom related problem), last TWRP upgrade came to my mind, I restored previous 3.3.1 version and upgrade went fine and phone could boot again. I don't know why this happened and I also don't know why 3.4.0 recovery always asked for my password even if I'm decrypted. Where am I wrong? :confused:
 
Last edited:

vdbhb59

Senior Member
Feb 15, 2016
1,332
501
OnePlus 5
Samsung Galaxy M30
A strange thing happened to me: few days ago I updated TWRP to 3.4.0 version without any problem (I'm with Derpfest dumpling). Yesterday I tried to flash first rom upgrade with new TWRP, flashing went fine but after that I couldn't start the phone because it went back to recovery. I tried to recover backup made just before upgrading and after recover it went in fastboot mode. No way to restart the phone. After various attemps and when I started to be afraid of not finding a solution (I thought it was a rom related problem), last TWRP upgrade came to my mind, I restored previous 3.3.1 version and upgrade went fine and phone could boot again. I don't know why this happened and I also don't know why 3.4.0 recovery always asked for my password even if I'm decrypted. Where am I wrong? :confused:
You are not wrong anywhere. I too have faced this, and tbvh, I am using CodeworkX or BluSpark only for one of these various reasons. Unless TWRP from CodeworkX or BluSpark are not working, I will stick so that these smaller issues do not turn big.
 

calvio

Senior Member
Jul 23, 2009
77
18
You will never be able to restore a backup from 3.3.1 in 3.4.0 because backups from 3.3.1 are broken.

My problem was with 3.4.0, backup was made with 3.4.0 and I tried to restore it with 3.4.0. My problem was trying to upgrade the rom with 3.4.0, I could manage it only after I went back to 3.3.1
 

osm0sis

Senior Recognized Developer / Contributor
Mar 14, 2012
14,954
33,896
Halifax
GT-i9250
Google Nexus 4
My problem was with 3.4.0, backup was made with 3.4.0 and I tried to restore it with 3.4.0. My problem was trying to upgrade the rom with 3.4.0, I could manage it only after I went back to 3.3.1

Ah, this will need @mauronofrio to look into it then. Thanks for clarifying. I think he also has a TG group where you can bring things to his attention.
 
Last edited:

Stupifier

Senior Member
Jun 8, 2010
1,913
680
OnePlus5 on Official OOS 10 ROM (clean flash, rooted, latest Magisk) with this TWRP 3.4.0 version.

-I set a Pin OR password in Android . Reboot to Recovery. I type in password at TWRP screen when prompted. It fails! Why?
-I reboot phone. I type in password to boot Android. I go to settings and REMOVE pin/password entirely. Then I reboot to recovery and TWRP just boots up fine....as it should.

So what is going on here.....why is TWRP not accepting my pin/password I set? I tried doing this process multiple times, same result.
I came from an AOSP-based version 9 ROM...but I completely wiped it (data/system/vendor/cache/dalvik/etc)....and flashed this 3.4.0 recovery along with the Official OOS 10 ROM.

Any help welcome! Thanks
 
Last edited:

mauronofrio

Recognized Developer
Jun 29, 2012
4,359
13,735
25
Castellana Grotte
toolaio.tk
OnePlus5 on Official OOS 10 ROM (clean flash, rooted, latest Magisk) with this TWRP 3.4.0 version.

-I set a Pin OR password in Android . Reboot to Recovery. I type in password at TWRP screen when prompted. It fails! Why?
-I reboot phone. I type in password to boot Android. I go to settings and REMOVE pin/password entirely. Then I reboot to recovery and TWRP just boots up fine....as it should.

So what is going on here.....why is TWRP not accepting my pin/password I set? I tried doing this process multiple times, same result.

Any help welcome! Thanks

Strange thing, there is another twrp that is working properly?
 

Stupifier

Senior Member
Jun 8, 2010
1,913
680
Try my latest 3.3.1 twrp or blue spark twrp

Tried your 3.3.1 = same result
Tried blu spark 3.4.0 = same result
Tried blu spark 3.3.1 = same result

And just to give more info on the failure
The TWRP prompt screen says "Enter Password for User [0]". Then when I enter the password/pin....it goes to a quick log screen and says
"Attempting to decrypt FBE for user 0 . . ."
"failed to decrypt user 0"
After that, it just spits me back on the TWRP password prompt screen. I CAN press "cancel" button....and it takes me to the "Keep System Read Only?" prompt screen....the one that has the bottom slider to "Swipe to Allow Modifications".

Any further ideas?
 

vdbhb59

Senior Member
Feb 15, 2016
1,332
501
OnePlus 5
Samsung Galaxy M30
Tried your 3.3.1 = same result
Tried blu spark 3.4.0 = same result
Tried blu spark 3.3.1 = same result

And just to give more info on the failure
The TWRP prompt screen says "Enter Password for User [0]". Then when I enter the password/pin....it goes to a quick log screen and says
"Attempting to decrypt FBE for user 0 . . ."
"failed to decrypt user 0"
After that, it just spits me back on the TWRP password prompt screen. I CAN press "cancel" button....and it takes me to the "Keep System Read Only?" prompt screen....the one that has the bottom slider to "Swipe to Allow Modifications".

Any further ideas?
Are you on OOS? If so first flash CodwworkX, and then after setting pin pwd etc do decrypt data from CX recovery. After you are successful 2-3 times flash BluSpark .115 or MF’s 3.3.1X. It will work.
 

Stupifier

Senior Member
Jun 8, 2010
1,913
680
Are you on OOS? If so first flash CodwworkX, and then after setting pin pwd etc do decrypt data from CX recovery. After you are successful 2-3 times flash BluSpark .115 or MF’s 3.3.1X. It will work.

  1. Could you give link to CodwworkX you are referring to? Just wanna make sure we're talking about what I think we are talking about.
  2. Decrypt Data from CX recovery? DO you mean CS Recovery will accept my pin pwd when prompted for it? Or are you talking about completely running the phone unencrypted......cuz doesn't that wipe/format? Unless I am misunderstanding....maybe you can explain that further.

Thanks
 

vdbhb59

Senior Member
Feb 15, 2016
1,332
501
OnePlus 5
Samsung Galaxy M30
Could you give link to CodwworkX you are referring to? Just wanna make sure we're talking about what I think we are talking about.
Decrypt Data from CX recovery? DO you mean CS Recovery will accept my pin pwd when prompted for it? Or are you talking about completely running the phone unencrypted......cuz doesn't that wipe/format? Unless I am misunderstanding....maybe you can explain that further.


Thanks
Link: https://sourceforge.net/projects/ch...rkx-signed-forcedecrypt-dumpling.img/download
By decrypt I meant the former one, give pin password in the CX recovery. Try that once.
 

Top Liked Posts