[RECOVERY][3.4.0-10][U][guacamole]Official/Unofficial TWRP recovery for OnePlus 7 Pro

Search This thread

hammered58

Senior Member
Nov 4, 2017
454
123
Wisconsin
I have TWRP Installer3.6.1 and TWRP 3.6.0 and am going to flash HavocOS. This is my fist 1+ DEVICE (7pRO tmo gm1915) I've attempted to root but I'm no stranger to LG ZTE, or Samsung roots. I am a bit confused regarding the patched boot.img and how to create/extract it. Apologies for the noob question, but does anyone have any advice?
I would make sure you have the MSM tool working first before installing a rom , just in case things go bad also maybe join the havoc telegram ,, the op7p is a diff animal for sure ,I came from a HTC where TWRP was mandatory , but op7p not so much as most roms have a built in recovery which I use and seldom use TWRP, have fun, pm me if u need help.
 
I would make sure you have the MSM tool working first before installing a rom , just in case things go bad also maybe join the havoc telegram ,, the op7p is a diff animal for sure ,I came from a HTC where TWRP was mandatory , but op7p not so much as most roms have a built in recovery which I use and seldom use TWRP, have fun, pm me if u need help.
Thanks., but I joined that telegraph Team looking before I started gathering root files ;)
 

mrpeev

Senior Member
Mar 27, 2013
252
69
Hey guys,
I am using curently Pixel Experience and after booting the TWRP, I dont see my phone memory. The PC recognizes the phone when I turn off MTP, but nothing else. Basically I cant even flash the TWRP itself or any other rom or whatever. Maybe someone here can help me resolve the issue.
 

HippoMan

Senior Member
May 5, 2009
1,899
724
Hippoland
Hey guys,
I am using curently Pixel Experience and after booting the TWRP, I dont see my phone memory. The PC recognizes the phone when I turn off MTP, but nothing else. Basically I cant even flash the TWRP itself or any other rom or whatever. Maybe someone here can help me resolve the issue.
I think you posted this message in the wrong forum. This forum is for questions about TWRP for the "guacamole" OnePlus 7Pro device.
 

shjeanpy

Senior Member
May 2, 2011
262
22
I am new user of GM1917, I flashed BlissRom and then TWRP but I have this error described in the image. Your help will be very useful to allow me to use the Recovery
 

Attachments

  • IMG_20220518_194242.jpg
    IMG_20220518_194242.jpg
    3.3 MB · Views: 73
Apr 7, 2016
7
2
Think I brikked my OP7P. I had TWRP running and was trying to flash it with OnePlus7Pro.11.0.1.1.GM21AA.magisk_patched_boot.img and I'd seen it "writing boot_a". Then I rebooted the phone, my old LineageOS image started running, skipped the setup steps for wifi, backup, fingerprint. Then tried to setup wifi but it couldn't see any networks and then it went black.

Can't get it to do anything anymore. It won't power on at all. Any tips?
 

VampireHeart

Senior Member
Jan 13, 2015
1,426
695
Viterbo
OnePlus 7 Pro
Think I brikked my OP7P. I had TWRP running and was trying to flash it with OnePlus7Pro.11.0.1.1.GM21AA.magisk_patched_boot.img and I'd seen it "writing boot_a". Then I rebooted the phone, my old LineageOS image started running, skipped the setup steps for wifi, backup, fingerprint. Then tried to setup wifi but it couldn't see any networks and then it went black.

Can't get it to do anything anymore. It won't power on at all. Any tips?
What you are trying to do? Root your phone with patched image? On which system you are before? Seem you are on Lineage and not oxygen.
 

Top Liked Posts