[RECOVERY][3.5.0-0][UNOFFICIAL] TWRP Xiaomi POCO X3 [surya][karna]

Search This thread


Senior Member
New twrp-3.6.1_11-2-surya-22.05-fix.img available (not sure what the fix is about, couldn't find info on TG either)
Official changelog:
- Add support for installation realme/OPPO OTA - Ctapchuk
- Add lptools to ramdisk - CaptainThrowback & phhusson
- Add EROFS support - pomelohan
- Fastbootd - check for and run startup script - RazaDroid
- Add TARGET\_OTA\_ASSERT\_DEVICE for custom device asserts - DarthJabba9
- Updated Chinese Simplified translations - sekaiacg
- Fixes
  - Update partition details after switching slot - Nebrassy
  - Unmounting dynamic devices - do not remove mountpoints - bigbiff
  - Installing zips - remove unecessary CloseArchive calls - sekaicg
  - /sdcard mounting - bigbiff
  - Installing zips - support 64 bit zips - sekaiacg
  - Fuse issues with OTA > 4 GiB - luoqiangwei1
  - Installing zips - StartIteration crash - sekaiacg
  - Kernel module loader log cleanup - Megendanz
  - Startup script cleanup - CaptainThrowback
  - Update Boot HIDL for switching slots - MoetaYuko
  - Sepolicy for ueventd - ghostrider-reborn
  - Change TWRP folder cleanup - Nebrassy
  - Support fscryptv1 - bigbiff
  - libresetprop cleanup - bigbiff
  - Restore with PIN enabled - sekaiacg & CaptainThrowback
  - Install custom theme - sekaiacg
  - Set prop after kernel module loading is done - ghostrider-reborn
  - Add gki directory for kernel module loading - sekaiacg
  - Exclude com.android.art apex from backup - nijel8
  - twrpRepacker code duplication - DarthJabba9
  - fstab flag cleanup - CaptainThrowback

Changes by brigudav
- sload_f2fs: update code for correct binary name (of.)
- Added option to delete /system/addon.d/ folder to prevent save scripts from triggering when installing custom ROMs;
- Updated the uninstall script and added a script to disable the last installed Magisk module;
- Added cleaning (Wipe - Package Cache) directory /data/system/package_cache;
- Slightly improved and fixed interface, updated translation;
- and mbechn...

Fix reason:
- fix error wipe Cache


Senior Member
Your answer is very cryptic. I'm just reporting what I've observed, hoping this will make for a better product for all...
Thanks anyways for noting the issue. 😉
There was nothing wrong with your comment. It wasn't even necessarily targeting his build; it could have been questioning TWRP 3.6.2 in general.

All of the files have been deleted. I guess we'll see whether that's permanent or not.


Senior Member
Apr 30, 2012
... I'm just reporting what I've observed, hoping this will make for a better product for all...

There was nothing wrong with your comment. It wasn't even necessarily targeting his build...
I agree. Hope @brigudav will re-upload his fine work.
The new TWRP does not have any of the tools and features that are available in the TWRP released on 22nd May, right? So, is the new TWRP truly beneficial to users who are already decrypted and wish to stay decrypted? It appears it is encrypted users who can benefit from it.


Senior Member
Apr 16, 2021
TWRP 3.6.2_12-0

- UI updated
- Additional wipe's (Package Cache and Metadata)
- Additional patches from 3.6.1 (dfe and other)
- Padding size fixed
- Settings now saved after reboot
- Maybe more fixes

- Decryption on A12.1 ROMs is fully working


Senior Member
Sep 20, 2014
Thanks for offering a new version. Does this work for A11 as well? Some day I plan to upgrade from A11 to A12.1 ...


May 25, 2013
Xiaomi Poco X3 NFC
Is it possible to update from within existing TWRP (NOT in fastboot)?
If yes, what is the proper way to do it (e.g. wipe dalvik/cache etc.)

[EDIT] Done and successfully updated!
Turns out it's pretty straightforward:
- boot to recovery
- select "Install"
- select "Images" button
- select TWRP img file from storage/SD
- select "Recovery" partition
- Confirm (swipe)
- to ascertain newer version is installed reboot to recovery
- reboot system
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    New recovery from Brigudav.


    anyone tested? encryption still ok on A12 roms?
    MiFlash is just the program you use to flash the MIUI fastboot ROM in Windows.

    Woah... I can breathe now !

    I've tried in another way. No TWRP? Ok. No Android system? Ok.

    But FastBoot? VOL- & POWER and my phone booted in FastBoot mode. Great...


    1) fastboot flash recovery TWRP_3.6.2.IMG ==> OK, it worked
    2) fastboot boot TWRP_3.6.2.IMG ==> OK, it booted
    3) from TWRP 3.6.2 , reboot system ==> OK, it booted, my Android system is untouched

    which one did u flash?

    Latest 3.7.0 release. File name 'twrp-3.7.0_12-0-surya_26.09.img'.

    Don't know if it's possible to post here the link, it's latest TWRP for X3 NFC on Brigudav android file host :sneaky:
    New recovery from Brigudav. twrp-3.7.0_12-0-surya_26.09.img
    There seems to be another one - with support for FBEv2.
    How did you install it? I flashed v3.7 from within TWRP 3.6 and it worked fine. I downloaded it from the website.

    You'll have to flash MIUI using MiFlash.

    I've flashed in the same way of any previous TWRP release. Downloading IMG file, reboot into TWRP, flash, image, choose image, recovery as a destination, run...

    I'm trying to download latest MIUI EEA, fastboot version, but it's so slow... What it's MiFlash?
  • 20

    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.

    - Touch Works in all states (No matter about lockscreen there or not)
    - Decryption works
    - Otg works
    - Flash Rom works
    - F2FS support
    - Fastboot boot command support

    Not working:
    - Fastbootd
    - Adb sideload
    - Backup restore and image flash (system-vendor-product)

    1. Download the TWRP image file to your PC.
    2. Put your device into fastboot.
    3. Type the following command to flash the recovery:-
    fastboot flash recovery "name_of_recovery.img"
    4. On installation of TWRP , to boot the recovery do:-
    fastboot boot "name_of_recovery.img"
    The device will automatically reboot into TWRP, and you will have TWRP as your permanent recovery!
    5. Enjoy!

    TWRP By mahajant99

    PayPal: PayPal.me/mhjn950
    UPI: [email protected]

    XDA:DevDB Information
    TWRP, Tool/Utility for the Xiaomi Poco X3 NFC

    Source Code: https://github.com/mahajant99/device_xiaomi_surya_twrp

    Version Information
    Beta Release Date: 2020-09-26

    Created 2020-09-26
    Last Updated 2021-01-02


    Synced with latest source changes
    • Add Support for karna
    • Fixed Decryption issue
    • Built kernel from source
    Could you upload it somewhere?
    I uploaded latest brigudav's TWRP 3.6.0_10-0 and 3.5.2_10-12.
    maybe the good dev @brigudav took note of this post and did the needful.
    No, that post has nothing to do with it, encryption works on both 11 and 12 android. The problem is completely different, TWRP version 3.6.2-12 works perfectly only on MIUI on Android 12 & custom roms, and on MIUI A11 it causes problems with some applications and permissions to their databases, so Bluetooth and others stop working.Therefore, I release TWRP on Android 11, i.e. version 3.6.2-11, which is for MIUI.