Development [RECOVERY] [ALPHA] TeamWin Recovery Project

Search This thread

wolfydRg

Member
Sep 2, 2009
11
2
Hello, I'm receiving this error (on windows & linux):

Image 1.jpg
 

DonKonfetti

Member
Nov 15, 2017
23
1
Could someone please explain why persist is so important? What kind of information does it contain and what happens in case it gets overriden or corrupted?
 

minotavros

Senior Member
Jan 3, 2014
122
30
1.After flash xiaomi.eu rom twrp keep or must flash again?
2.Need format data after install twrp? Need again format data after flash the new rom?
Thanks for your work!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    Never, why would you ever do that
    Maybe he wants to flash BrickOS
    3
    @Nebrassy hi, I have been trying to use my USB stick with Xiaomi.EU stable and TWRP. It is either this or that :-(
    Formatting the stick under MiUI (defaults to exFAT) lets me use the stick under Mi. Booting TWRP and selecting the stick for backup gives me the message:permission denied (see attached screenshot) If I format the stick with ext4 I can backup but the phone does not mount the stick anymore.
    What could possibly be wrong?
    thanks for your time
    Hans
    join my tg group and tag me, will need to do a few changes and send you a test build
    2
    hi

    still like 3 days before unlock
    no prblems.. if i install it twrp then install Xiaomi.EU 12.5.3.0 ?
    1
    Hi all! I'm on Miui EU 12.5.2.0.
    From OSX terminal:
    fastboot boot /Users/xxxxxx/Desktop/twrp.img
    (twrp.img - previously renamed is on my desktop)
    Sending 'boot.img' (131072 KB) OKAY [ 4.153s]
    Booting OKAY [ 0.281s]
    BUT
    when the phone reeboot it goes in MIUI Recovery (vers 5.0)
    not in Twrp.
    Can someone help me?
    Thanks!
    You haven't flashed twrp as recovery. Fastboot boot only runs it temporarily. Follow the full instructions to install TWRP (as this is alpha I just use fastboot boot command as I don't want to lose my ramdisk until this is official)
    1
    how to fix internal storage 0 after format data ? i have tried twice still not change
    Boot a rom then reboot recovery
  • 57



    Introduction:

    Team Win Recovery Project or TWRP for short, is a custom recovery built with ease of use and customization in mind. We started from the ground up by taking AOSP recovery and loading it with the standard recovery options, then added a lot of our own features. It's a fully touch driven user interface , no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

    Key Features:

    Touchscreen driven with real buttons and drag-to-scroll
    XML-based GUI that allows full customization of the layout true theming!
    Settings are saved to the sdcard and persist through reboots
    Ability to choose which partitions to back up and which to restore
    Ability to choose to compress backups now with pigz (multi-core processor support for faster compression times)
    Onscreen keyboard
    Easy selection of internal/external storage

    In addition to the above new features, TWRP features a scripting engine that allows an app to send commands to the recovery for the recovery to perform during startup. We call this scripting engine OpenRecoveryScript. This engine will be put to use immediately in the GooManager app. GooManager will be able to install recoveries automatically for most supported devices. The app will also let you choose to install multiple zips from within Android, wipe, and run a backup.

    We are looking for other talented developers, themers, and device maintainers if they are interested in helping with a free, open source project.

    Source Code:

    GitHub - https://github.com/TeamWin/android_bootable_recovery

    Gerrit Instance - http://gerrit.twrp.me

    If you have made your own TWRP build for an unsupported device, please let us know. We might add your build to the list of unofficial builds. Bear in mind that we are working hard to add more devices and we may add your device to our official build list later.

    Hello, this is an alpha build of TWRP, for Poco F3/Mi 11X/Redmi K40

    touch and adb work
    flashing works
    USB OTG works
    Decryption is working

    fastbootd and vibration do not work

    Installation:
    1. fastboot boot twrp.img
    2. copy that same twrp image to the device
    3. go to Advanced > Install Recovery Ramdisk
    4. select the image you copied
    5. after that is done, if you were using a custom kernel, reflash it now
    6. if you were using magisk, reflash it now
    7. reboot to recovery, you should now be able to boot TWRP normally using Power+volume up

    repeat step 3 and 4 directly after flashing a new rom, then reboot recovery to flash additional stuff

    Send me a beer: Crypto(Preferred) | PayPal

    Trees:
    https://github.com/nebrassy/device_xiaomi_alioth-TWRP
    https://github.com/nebrassy/device_xiaomi_sm8250-common-TWRP

    Telegram group: https://t.me/NSSFB

    Download: https://www.androidfilehost.com/?w=files&flid=325130
    23
    new build is up
    -fixed spunvm spam in log
    -fixed flashing payload roms, stock and custom AOSP roms should now flash correctly
    8
    @Nebrassy Nice work - tested on my crDroid working-build and all ok 👍
    7
    Never, why would you ever do that
    Maybe he wants to flash BrickOS
    6
    new build is up
    -fixed spunvm spam in log
    -fixed flashing payload roms, stock and custom AOSP roms should now flash correctly
    Works fine man on crDroid payload...NICE WORKS 🔥