[RECOVERY] Bypass the Read-Only partition (Merlin)

Search This thread


Sep 25, 2022
Hi everyone, I found after many tests a way to bypass the Read-Only.

WARNING: This is not a permanent fix, it is just a bypass where you can edit files.

Trying different AIO Tools (Universal, swflash etc etc) none of them unfortunately worked but thanks to an unofficial recovery (OrangeFox) that was recreated for this phone, it worked.


If you want only the recovery, unpack the zip, open cmd-adb and type: fastboot flash recovery <recoveryname.img> otherwise flash the entire zip from your recovery.

After just reboot to recovery (if u prefer: fastboot reboot recovery) and edit your files!

Tip: when you open OrangeFox probably if you have encrypted files it will tell you to enter the password (try it, unfortunately it doesn't work for me, since you should format the phone) if for you also doesn't work just click the Cancel button.

Please note: the recovery is not mine but it is made by shas45558

If you like this method, please leave a like!



  • recovery.img
    64 MB · Views: 52
  • Merlin_S_vendor_OrangeFox_R11_1_2_Unofficial_merlin.zip
    56.6 MB · Views: 74
Last edited: