[RECOVERY][dumpling] TWRP 3.3.X by codeworkx

Search This thread

bikeaholics

Senior Member
Apr 14, 2011
142
6
What did I wrong when I am not able to make a backuo because the partition could not mounted? I camera from oos b1 flashed your universal, did a Backup and it worked. The flashed omni, gapps, magisk. Them wanted to flash lineage and wanted to do a backup the the error is shown. Thanks a lot

Gesendet von meinem ONEPLUS A5010 mit Tapatalk
 

Jamie_oppo

Senior Member
Sep 21, 2016
1,386
391
Sydney
I need some help.

Im on ob1. I created a backup and with system image not system.

I flash some roms with no variety zip etc and they booted. Only way for them to boot was with that zip and I decided to restore my backup.
the firmware was the exact same (ob1)

The restore worked perfectly.

But I cannot decypt data anymore?

I've used the same universal twrp to backup and flash all these roms with no problems. Also when I did the backup I removed my pin.

I have a 3x3 pin but when I boot into twrp. It asks for a pw. So I changed my pattern to a password and typed it in twrp. Error , then it asks do u want to make mods or keep system read only.

I know format data will probably work but I don't want to format data. Can yous help?

Edit: when I remove the pin after restore I'm able to decypt data. weird. So after restore I'm not able to decryot with a pin?
 
Last edited:

the Doctor

Retired Senior Moderator
Dec 15, 2011
4,590
4,520
In the TARDIS
I need some help.

Im on ob1. I created a backup and with system image not system.

I flash some roms with no variety zip etc and they booted. Only way for them to boot was with that zip and I decided to restore my backup.
the firmware was the exact same (ob1)

The restore worked perfectly.

But I cannot decypt data anymore?

I've used the same universal twrp to backup and flash all these roms with no problems. Also when I did the backup I removed my pin.

I have a 3x3 pin but when I boot into twrp. It asks for a pw. So I changed my pattern to a password and typed it in twrp. Error , then it asks do u want to make mods or keep system read only.

I know format data will probably work but I don't want to format data. Can yous help?

Edit: when I remove the pin after restore I'm able to decypt data. weird. So after restore I'm not able to decryot with a pin?
Yes, this is a known problem. The only way I know to fix it is to re-format data with factory encryption using a stock recovery, which probably won't be worth it to you. As you say, removing lockscreen protection before entering TWRP works fine.
 
  • Like
Reactions: Jamie_oppo

Jamie_oppo

Senior Member
Sep 21, 2016
1,386
391
Sydney
Yes, this is a known problem. The only way I know to fix it is to re-format data with factory encryption using a stock recovery, which probably won't be worth it to you. As you say, removing lockscreen protection before entering TWRP works fine.
That's annoying. So nothing else will work, flashing dm verity or formatting data in twrp doesn't even work that's going piss me off.

I think I'll go through this big process when the official oreo comes out as we need a clean flash anyway.
 

zanderzone

Senior Member
Sep 14, 2011
194
49
Hey guys, need some help

I cannot seem to boot into recovery after I boot into system. I know I need to boot into recovery atleast once right after flashing and I am doing it, however, as soon as I boot into system, default recovery takes over. Can anybody help ?

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash recovery "C:\Users\ULTRABOOK 840 G1\Downloads\twrp-3.2.1-0-universal-codeworkx-dumpling"
target reported max download size of 536870912 bytes
sending 'recovery' (25256 KB)...
OKAY [ 0.588s]
writing 'recovery'...
OKAY [ 0.238s]
finished. total time: 0.831s


C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot boot "C:\Users\ULTRABOOK 840 G1\Downloads\twrp-3.2.1-0-universal-codeworkx-dumpling"
downloading 'boot.img'...
OKAY [ 0.588s]
booting...
OKAY [ 0.015s]
finished. total time: 0.608s

Phones boots into TWRP fine. At this time I can repeatedly reboot phone into TWRP from TWRP reboot menu, however, as soon as boot into system and then try to reboot into recovery, default recovery take over
 

the Doctor

Retired Senior Moderator
Dec 15, 2011
4,590
4,520
In the TARDIS
That's annoying. So nothing else will work, flashing dm verity or formatting data in twrp doesn't even work that's going piss me off.

I think I'll go through this big process when the official oreo comes out as we need a clean flash anyway.

I've seen several users report that they've tried formatting /data in TWRP with no effect. My understanding is that it's because the issue has to do with encryption key storage, not encryption of the partition itself. So yes, waiting might be your best bet.

Then again, TWRP might be updated to handle OOS's method of encryption key storage.
 

the Doctor

Retired Senior Moderator
Dec 15, 2011
4,590
4,520
In the TARDIS
Hey guys, need some help

I cannot seem to boot into recovery after I boot into system. I know I need to boot into recovery atleast once right after flashing and I am doing it, however, as soon as I boot into system, default recovery takes over. Can anybody help ?

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash recovery "C:\Users\ULTRABOOK 840 G1\Downloads\twrp-3.2.1-0-universal-codeworkx-dumpling"
target reported max download size of 536870912 bytes
sending 'recovery' (25256 KB)...
OKAY [ 0.588s]
writing 'recovery'...
OKAY [ 0.238s]
finished. total time: 0.831s


C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot boot "C:\Users\ULTRABOOK 840 G1\Downloads\twrp-3.2.1-0-universal-codeworkx-dumpling"
downloading 'boot.img'...
OKAY [ 0.588s]
booting...
OKAY [ 0.015s]
finished. total time: 0.608s

Phones boots into TWRP fine. At this time I can repeatedly reboot phone into TWRP from TWRP reboot menu, however, as soon as boot into system and then try to reboot into recovery, default recovery take over
Are you running stock OOS unrooted? It will always flash back to stock recovery on boot.
 

zanderzone

Senior Member
Sep 14, 2011
194
49
Are you running stock OOS unrooted? It will always flash back to stock recovery on boot.

Yes, I am running stock OOS Oero Beta without root. I have been able to get TWRP working with this before. Today I wanted to re-flash a kernel hence dirty flashed the ROM and since then not been able to use the recovery. What are my options?
 

mad-murdock

Retired Recognized Developer
Oct 11, 2010
2,373
1,670
Detmold
That's annoying. So nothing else will work, flashing dm verity or formatting data in twrp doesn't even work that's going piss me off.

I think I'll go through this big process when the official oreo comes out as we need a clean flash anyway.

Don't mix up not being able to mount /data with not being able to flash files. If you cannot mount /data there are 3 workarounds I know of to flash files anyways. Most flashable .zip files do not need access to /data to successfully flash anyways.

  • Use a OTG Cable and a USB stick for your backups and files to flash. Has added advantage of keeping your internal storage free
  • copy files to flash with a root enabled file browser to /cache. you can always access /cache without issues. just remember to delete files after flashing.
  • there is always adb sideload. while it requires a computer to send the files via sideload to your android system, it is a fallback that always works.
 

kanekz

Senior Member
Nov 23, 2011
306
72
Don't mix up not being able to mount /data with not being able to flash files. If you cannot mount /data there are 3 workarounds I know of to flash files anyways. Most flashable .zip files do not need access to /data to successfully flash anyways.

  • Use a OTG Cable and a USB stick for your backups and files to flash. Has added advantage of keeping your internal storage free
  • copy files to flash with a root enabled file browser to /cache. you can always access /cache without issues. just remember to delete files after flashing.
  • there is always adb sideload. while it requires a computer to send the files via sideload to your android system, it is a fallback that always works.

I am in a situation where I wiped internal data and no rom on the phone. I am trying to move files from my pc to internal storage on the phone while connected in TWRP, but it wont work. Can i still adb sideload a stock zip? What are the commands?

I tried with this command and got: adb push (name of fie).zip /sdcard/ob1.zip
error: device not found
 

eljefe27

Senior Member
Jul 15, 2010
131
4
Brownsville, TX
I am in a situation where I wiped internal data and no rom on the phone. I am trying to move files from my pc to internal storage on the phone while connected in TWRP, but it wont work. Can i still adb sideload a stock zip? What are the commands?

I tried with this command and got: adb push (name of fie).zip /sdcard/ob1.zip
error: device not found

Download op's recovery and use https://forum.xda-developers.com/on...ol-tool-one-driversunlocktwrpfactory-t3706840 to flash it
 

Top Liked Posts