[RECOVERY][mako] TWRP 3.1.1-0 touch recovery [2017-05-19]

Search This thread

Faith_G

Senior Member
Sep 27, 2011
107
15
I'm getting partition errors in TWRP since I flashed the stock lollipop zip. I'm on 2.8.2. Log attached.
 

Attachments

  • recovery.log.txt
    18.3 KB · Views: 35

PeterFdeVries

Senior Member
Jan 20, 2008
121
12
Hi guys,

Today I got the message that TWRP can't write to my (external?) SD-card. TWRP should know I have a nexus 4 (since I updated TWRP to 2.8.2.0 using the app). I had to apply a patch within the TWRP-app. Is this really necessary considering that the nexus only has an internal SD-card?
 

psak

Senior Member
Oct 13, 2010
50
2
Hi everyone,
quick question: How do i run decrypt command from TWRP?
Nexus 4 has 5 stock
Here is the scenario i did:
fastbook oem unlock
fastboot devices (successfully saw my device in terminal, so i flashed recovery....)
fastboot flash recovery.img

rebooted into 2.8.20 successfully
Thought i would be all-set, wanted to do full wipe & continue flashing lolipop ROM)
but faced with "Could not mount/data and unable to find crypto folder"
any solutions?

Thanks in advance.
 
Last edited:

l33ch0r

Senior Member
Apr 12, 2011
1,242
249
Since Philz Touch is no longer updated I find myself in the need to flash this recovery.

But the installation with TWRP Manager does not work.
On TF300T it always crashed before finishing but still has flashed recovery and so on.

On mako with CM12 Lollerpop the app crashes as soon as I choose "install TWRP"

Could someone provide me with a flashable zip? Philz Touch Recovery unfortunately is not capable of backing up 5.0 ROMs :rolleyes:

Thx in advance ;)

Nevermind, found one on the previous page :)
 
Last edited:

KreAch3R

Inactive Recognized Developer
Nov 15, 2010
1,076
1,984
Transfer files - Permissions bug?

PROBLEM: When you copy/create files/folders in the scdard while in TWRP, you can't delete them in android.
VERSION: MultiROM TWRP 2.8.1.0 (2014-11-15) (latest)

More information:
Hello,

I am having a strange problem. Last time I used this installer is when I tested the beta 2.0 installer + multirom combination (when I said that I had to use PA-GApss folder for the installer to recognize the .gapps-config file). That time I flashed it in a secondary Kitkat ROM. Now I am running SimpleAOSP-Lollipop only (primary).
Yesterday I noticed that I can't delete the PA-GApps folder & files. It seems to be related with permission errors, but the permissions & owner are the same as all the other folders! I tried multiple file managers, full wipe and clean install of another ROM, tried to delete it from terminal/adb (with root permissions), tried to chmod, nothing. My only option is to format the storage (haven't done that yet).

Has anyone else had this problem? Is it even related with PA-GApps installer?

Code:
-rw-rw---- root     sdcard_r 420451139 2014-11-22 00:55 pa_gapps-stock-4.4.4-20141121-signed.zip
-rw-rw---- root     sdcard_r    27337 2014-12-09 20:58 pa_gapps_debug_info.tar.gz
-rw-rw---- root     sdcard_r     3174 2014-12-09 20:58 pa_gapps_log.txt


I think it's a problem with permissions. If you transfer files with adb or mtp while in TWRP, you won't be able to delete the files in android.


Can anyone else reproduce this bug? If so, we should notify the TWRP developers. :)
 
Last edited:
  • Like
Reactions: fr3quency

fr3quency

Senior Member
Sep 20, 2008
2,199
856
29
Patra
fr3quency.deviantart.com
PROBLEM: When you copy/create files/folders in the scdard while in TWRP, you can't delete them in android.
VERSION: MultiROM TWRP 2.8.1.0 (2014-11-15) (latest)

More information:






Can anyone else reproduce this bug? If so, we should notify the TWRP developers. :)
I second that. I was like 'wtf is going on?' So I tried flashing the factory image yet the problem persisted. Thanks for shading some light on this matter.
 
  • Like
Reactions: KreAch3R

KreAch3R

Inactive Recognized Developer
Nov 15, 2010
1,076
1,984
I second that. I was like 'wtf is going on?' So I tried flashing the factory image yet the problem persisted. Thanks for shading some light on this matter.
I was also completely puzzled. So, can anyone else reproduce that? When I find the time, I should check with other twrp versions too. Can anyone do it in non multirom or 2.8.2.0 versions?
 

arvindgr

Senior Member
Nov 8, 2013
918
333
Tamilan
Is your fix taken to TWRP 2.8.2.0 on Nexus 4?

---------- Post added at 07:55 AM ---------- Previous post was at 07:53 AM ----------

Hello,

I was annoyed by the fact that the newly announced MTP feature wasn't working on our devices, and I managed to find a way to fix it. The necessary changes are due to the init.rc file.

This is the changed code:

Code:
# Always start adbd on userdebug and eng builds
# In recovery, always run adbd as root.
on property:ro.debuggable=1
    write /sys/class/android_usb/android0/enable 0
    write /sys/class/android_usb/android0/idVendor 18D1
    [B]write /sys/class/android_usb/android0/idProduct 4EE2[/B]
    [B]write /sys/class/android_usb/android0/functions mtp,adb[/B]
    #write /sys/class/android_usb/android0/enable 1
    write /sys/class/android_usb/android0/iManufacturer $ro.product.manufacturer
    write /sys/class/android_usb/android0/iProduct $ro.product.model
    write /sys/class/android_usb/android0/iSerial $ro.serialno
    [B]write /sys/module/rmnet_usb/parameters/rmnet_data_init 1[/B]
    #start adbd
    setprop service.adb.root 1

Now MTP and adb are working correctly (YMMV). Tested on both Windows Pro 8.1. x64 and Xubuntu 14.04.

I have attached two modified files, a plain 2.8.10 twrp and a multirom one. I zipped them because of XDA upload restrictions. Please test them and report back if it works for you.
DISCLAIMER! As always, it is not my fault if you obliterate your device! /DISCLAIMER!

I will try to contact the TWRP devs to find out how and where to do a proper pull request.

Is your fix taken to latest TWRP?
 

KreAch3R

Inactive Recognized Developer
Nov 15, 2010
1,076
1,984
Is your fix taken to TWRP 2.8.2.0 on Nexus 4?

I think they updated the .initrc to a working one (following the other phone builds, not ours) after I provided them with my fix. So, I think that MTP is working on 2.8.2.0 but not due to my fix. I am using MultiROM 2.8.1.0 though and I haven't tested it to be sure.
 
  • Like
Reactions: bombadier

VivaErBetis

Senior Member
Nov 26, 2006
1,155
925
Madrid (Spain)
Cannot mount encrypted data partition in 2.8.3.0 or 2.8.3.1 :(

Reverting back to 2.8.2.0.

---------- Post added at 10:13 PM ---------- Previous post was at 10:11 PM ----------

2.8.3.1 image is already available for download for Mako. What's the difference between 2.8.3.1 and 2.8.3.0?
The 2.8.3.0 recovery has an incorrect (small) screen resolution so it's shown really small in the Nexus 4 screen...
 
  • Like
Reactions: hazard209

Top Liked Posts

  • There are no posts matching your filters.
  • 336
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.




    CHANGELOG for 3.0.2-0:

    -Backups will now include adopted storage keys (Dees_Troy)
    -Fixed an adb restore issue (bigbiff)
    -Fixed rebooting when no OS is present (Dees_Troy)
    -Fixed line wrapping in the GUI terminal (_that)
    -Updated TWRP source code to AOSP 7.1.2 (Dees_Troy)


    CHANGELOG for 3.1.0-0:

    -vold decrypt on a few select HTC devices, TWRP will now attempt to use the system partition's vold and vdc binaries and libraries to decrypt the data partition (nkk71 and CaptainThrowback)
    -adb backup to stream a backup directly to or from your PC, see documentation here: https://github.com/omnirom/android_bootable_recovery/commit/ce8f83c48d200106ff61ad530c863b15c16949d9 (bigbiff)
    -tweak MTP startup routines (mdmower)
    -support new Android 7.x xattrs for backup and restore to fix loss of data after a restore (Dees_Troy)
    -support POSIX file capabilities backup and restore to fix VoLTE on HTC devices and possibly other issues (Dees_Troy)
    -better indicate to users that internal storage is not backed up (Dees_Troy)
    -improve automatic determination of TW_THEME (mdmower)
    -minimal getcap and setcap support (_that)
    -try mounting both ext4 and f2fs during decrypt (jcadduono and Dees_Troy)
    -shut off backlight with power key (mdmower)
    -timeout during FDE decrypt (Dees_Troy and nkk71)
    -support for FBE decrypt and backing up and restoring FBE policies (Dees_Troy)
    -boot slot support (Dees_Troy)
    -TWRP app install prompt during reboot (Dees_Troy)
    -support for AB OTA zips (Dees_Troy)
    -support new Android 7.x log command (Dees_Troy)
    -update recovery sources to AOSP 7.1 (Dees_Troy)
    -numerous bugfixes and improvements by too many people to mention

    CHANGELOG for 3.0.2-0:

    -Fix a bug with the input box that affected masked inputs (passwords). This fixes decrypt of full device encryption on devices that support decrypt. This bug also impacts encrypted backups. Users are highly encouraged to stop using 3.0.1 if you use encrypted backups or if you need decrypt of data in TWRP.
    -Add Greek translation to some builds.

    CHANGELOG for 3.0.1-0:

    -support new CM 13.0 pattern encryption (sultanqasim)
    -fix slow flashing issue due to modprobe (present on only some devices) (#twrp)
    -libtar updated to latest upstream and fixes (jcadduono)
    -fixes for loading custom themes (_that)
    -TWRP will now detect and install TWRP themes automatically through the normal zip install process (Dees_Troy)
    -translation updates - added Italian, Czech and Polish and significant updates to Dutch
    -progress bar improvements - progress bar updates during image flashing and better tracks progress during file system backups (tar) (Dees_Troy)
    -fix input box text display (Dees_Troy)
    -reboot option after zip install complete (bigbiff)
    -other mostly invisible bug fixes and improvements

    CHANGELOG for 3.0.0-0:

    -Completely new theme - Much more modern and much nicer looking (by z31s1g)
    -True Terminal Emulator - Includes arrow keys, tab and tab completion, etc. (by _that)
    -Language translation - It won’t be perfect and especially some languages that require large font files like Chinese & Japanese won’t be availble on most devices. Also some languages may only be partially translated at this time. Feel free to submit more translations to OmniROM’s Gerrit. (mostly by Dees_Troy)
    -Flashing of sparse images - On select devices you will be able to flash some parts of factory images via the TWRP GUI (by HashBang173)
    -Adopted storage support for select devices - TWRP can now decrypt adopted storage partitions from Marshmallow
    -Reworked graphics to bring us more up to date with AOSP - includes support for adf and drm graphics (by Dees_Troy)
    -SuperSU prompt will no longer display if a Marshmallow ROM is installed
    -Update exfat, exfat fuse, dosfstools (by mdmower)
    -Update AOSP base to 6.0
    -A huge laundry list of other minor fixes and tweaks

    WARNING: This is our first release in a long time. We have a lot of new and somewhat aggressive changes in this new release. The changes to the graphics back-end may cause some devices to not boot up properly or have other display-related issues. If you are not in a position to reflash an older build of TWRP, then wait until you are or at least wait until others have tried the new version for your specific device. You don’t want to end up with a non-working recovery and have to wait several hours or days to get to a computer to be able to fix it.

    Notes for themers: In addition to the udpated theme, we have introduced a theme version variable to the TWRP theme system. If the theme version does not match the version that TWRP expects, TWRP will reject the custom theme and load its stock theme. This change will ensure that people who update TWRP without updating their theme will still have a workable recovery. We have removed libjpeg support. The stock theme was only using a jpeg image for the splash / curtain. This change means that any custom themes will no longer be able to use jpeg images. It also means that tools used to repack recovery images with a different curtain / splash will need to be updated to use the new method.

    Version number notes: For a while we’ve been using a 4 digit version number and reserved the 4th digit for device-specific updates. For instance, we find and fix a device-specific issue like decryption of data on Nexus 5, we would release that as a 2.8.7.1. After a while, some people would start asking where 2.8.7.1 was for other devices. So, going forward we have decided to change the numbering scheme to 3.0.0-2, etc. Our hope is that this version numbering scheme will more clearly identify that the 4th digit does not indicate a version change for the code base.

    We need your help! The bulk of TWRP work is done by 3 people on a volunteer basis. We have pushed most of our device files to our github and we have a gerrit instance. If you have the ability, please help us maintain our official devices and/or add your device to our official device list. Thanks in advance!

    DOWNLOAD:
    1) Install the TWRP app from the Play Store or grab the apk from our website
    2) Open the app, agree to the terms, and enable root access
    3) Select TWRP Flash
    4) Search for your device and select the version you wish to download
    5) Once the download is complete, select the file (it's usually in your downloads folder) and then Flash Recovery
    OR:
    Most devices can be updated quickly and easily within TWRP if you already have version 2.8.4.0 or higher installed
    1) Download the latest version from our website on your device
    2) Reboot to TWRP
    3) Hit Install and tap the "Images..." button in the lower right
    4) Browse to the location of the TWRP image on your device and select it
    5) Select recovery from the partition list and swipe to flash
    OR:
    You can find more information and download links on our website.

    BUGS:
    If you have found a bug, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, your best bet is to PM me directly, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    SUPPORT:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.
    79
    TWRP 2.6.3.2 flashable .zip!

    Just made a flashable .zip...enjoy!
    52
    The TWRP recovery has been updated to version 2.7.0.0:
    http://techerrata.com/browse/twrp2/mako
    As usual, update by flashing it in fastboot mode

    or flash in any custom recovery using the flashable zips below

    j.mp/n4twrp for TWRP

    j.mp/n4cwm for CWM Touch and normal

    Flash it in recovery and you are all done. You can revert back to either recoveries by flashing the version you want to.

    all zips have been tested on my N4. recovery img files are sourced from clockworkmod.com for CWM and goo.im or techerrata.com for TWRP.

    Sent from my Nexus 4 using Tapatalk 4
    48
    [RECOVERY] TWRP 2.6.0.0 touch recovery [2013-07-08]
    46
    ok , because @azrash looks busy atm , i`ve replaced the new twrp image in his zip and made a flashable 2.7.1.0

    don`t thank me please , anyone can do it :cowboy:
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone